SameBoy.SlackBuild 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127
  1. #!/bin/sh
  2. # Slackware build script for SameBoy
  3. # Copyright 2017-2019 orbea
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=SameBoy
  23. LIBNAM=$(printf %s $PRGNAM | tr 'A-Z' 'a-z')_libretro
  24. SRCNAM=${LIBNAM%%_*}
  25. BRANCH=${BRANCH:-master}
  26. RGBBRN=${RGBBRN:-master}
  27. BUILD=${BUILD:-1}
  28. TAG=${TAG:-_git}
  29. if [ -z "$ARCH" ]; then
  30. case "$( uname -m )" in
  31. i?86) ARCH=i586 ;;
  32. arm*) ARCH=arm ;;
  33. *) ARCH=$( uname -m ) ;;
  34. esac
  35. fi
  36. CWD=$(pwd)
  37. TMP=${TMP:-/tmp/SBo}
  38. PKG=$TMP/package-$PRGNAM
  39. OUTPUT=${OUTPUT:-/tmp}
  40. LIBDIRSUFFIX=
  41. [ "$ARCH" = x86_64 ] && LIBDIRSUFFIX=64
  42. set -eu
  43. if pkg-config --exists sdl2; then
  44. SDL="${SDL:-yes}"
  45. else
  46. SDL=no
  47. fi
  48. if [ "${LIBRETRO:=yes}" != yes ] && [ "$SDL" != yes ]; then
  49. printf %s\\n 'ERROR: Both the SDL2 and Libretro builds are disabled.' >&2
  50. exit 1
  51. fi
  52. rm -rf $PKG
  53. mkdir -p $TMP $PKG $OUTPUT
  54. cd $TMP
  55. rm -rf $PRGNAM
  56. git clone --depth=1 -b $BRANCH https://github.com/LIJI32/$PRGNAM
  57. git clone --depth=1 -b $RGBBRN https://github.com/rednex/rgbds $PRGNAM/rgbds
  58. cd $PRGNAM
  59. HEAD="$(git rev-parse --short HEAD)"
  60. DATE="$(git show -s --format=%cd --date=format:%Y.%m.%d)"
  61. VERSION="${DATE}_$HEAD"
  62. chown -R root:root .
  63. find -L . \
  64. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  65. -o -perm 511 \) -exec chmod 755 {} \; -o \
  66. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  67. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  68. if [ "${DEBUG:=0}" != 0 ]; then
  69. CONF=debug
  70. DEBUG=1
  71. else
  72. CONF=release
  73. fi
  74. PATH="$TMP/$PRGNAM/rgbds/bin:$PATH"
  75. make -C rgbds Q=
  76. make -C rgbds install Q= \
  77. PREFIX=. \
  78. DESTDIR=./
  79. if [ "$SDL" = yes ]; then
  80. make CONF=$CONF DATA_DIR=/usr/share/games/$SRCNAM/
  81. mkdir -p $PKG/usr/games $PKG/usr/share/games
  82. cp -av build/bin/SDL $PKG/usr/share/games/$SRCNAM
  83. mv $PKG/usr/share/games/$SRCNAM/$SRCNAM $PKG/usr/games
  84. else
  85. make bootroms
  86. fi
  87. if [ "$LIBRETRO" = yes ]; then
  88. make -C libretro DEBUG=$DEBUG
  89. install -Dm0644 build/bin/$LIBNAM.so \
  90. $PKG/usr/lib${LIBDIRSUFFIX}/libretro/$LIBNAM.so
  91. curl --create-dirs -o $PKG/usr/lib${LIBDIRSUFFIX}/libretro/info/$LIBNAM.info \
  92. https://raw.githubusercontent.com/libretro/libretro-super/master/dist/info/$LIBNAM.info
  93. find $PKG/usr/lib${LIBDIRSUFFIX}/libretro -mindepth 1 -type d -exec chmod 755 {} \;
  94. fi
  95. if [ $DEBUG = 0 ]; then
  96. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
  97. grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  98. fi
  99. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  100. cp -a CHANGES.md LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
  101. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  102. mkdir -p $PKG/install
  103. cat $CWD/slack-desc > $PKG/install/slack-desc
  104. cd $PKG
  105. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-${VERSION}_$BRANCH-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}