123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127 |
- #!/bin/sh
- # Slackware build script for SameBoy
- # Copyright 2017-2019 orbea
- # All rights reserved.
- #
- # Redistribution and use of this script, with or without modification, is
- # permitted provided that the following conditions are met:
- #
- # 1. Redistributions of this script must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- #
- # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
- # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
- # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
- # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
- # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
- # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
- # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
- # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
- # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
- # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- PRGNAM=SameBoy
- LIBNAM=$(printf %s $PRGNAM | tr 'A-Z' 'a-z')_libretro
- SRCNAM=${LIBNAM%%_*}
- BRANCH=${BRANCH:-master}
- RGBBRN=${RGBBRN:-master}
- BUILD=${BUILD:-1}
- TAG=${TAG:-_git}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- CWD=$(pwd)
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- LIBDIRSUFFIX=
- [ "$ARCH" = x86_64 ] && LIBDIRSUFFIX=64
- set -eu
- if pkg-config --exists sdl2; then
- SDL="${SDL:-yes}"
- else
- SDL=no
- fi
- if [ "${LIBRETRO:=yes}" != yes ] && [ "$SDL" != yes ]; then
- printf %s\\n 'ERROR: Both the SDL2 and Libretro builds are disabled.' >&2
- exit 1
- fi
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $PRGNAM
- git clone --depth=1 -b $BRANCH https://github.com/LIJI32/$PRGNAM
- git clone --depth=1 -b $RGBBRN https://github.com/rednex/rgbds $PRGNAM/rgbds
- cd $PRGNAM
- HEAD="$(git rev-parse --short HEAD)"
- DATE="$(git show -s --format=%cd --date=format:%Y.%m.%d)"
- VERSION="${DATE}_$HEAD"
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- if [ "${DEBUG:=0}" != 0 ]; then
- CONF=debug
- DEBUG=1
- else
- CONF=release
- fi
- PATH="$TMP/$PRGNAM/rgbds/bin:$PATH"
- make -C rgbds Q=
- make -C rgbds install Q= \
- PREFIX=. \
- DESTDIR=./
- if [ "$SDL" = yes ]; then
- make CONF=$CONF DATA_DIR=/usr/share/games/$SRCNAM/
- mkdir -p $PKG/usr/games $PKG/usr/share/games
- cp -av build/bin/SDL $PKG/usr/share/games/$SRCNAM
- mv $PKG/usr/share/games/$SRCNAM/$SRCNAM $PKG/usr/games
- else
- make bootroms
- fi
- if [ "$LIBRETRO" = yes ]; then
- make -C libretro DEBUG=$DEBUG
- install -Dm0644 build/bin/$LIBNAM.so \
- $PKG/usr/lib${LIBDIRSUFFIX}/libretro/$LIBNAM.so
- curl --create-dirs -o $PKG/usr/lib${LIBDIRSUFFIX}/libretro/info/$LIBNAM.info \
- https://raw.githubusercontent.com/libretro/libretro-super/master/dist/info/$LIBNAM.info
- find $PKG/usr/lib${LIBDIRSUFFIX}/libretro -mindepth 1 -type d -exec chmod 755 {} \;
- fi
- if [ $DEBUG = 0 ]; then
- find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
- grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- fi
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a CHANGES.md LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-${VERSION}_$BRANCH-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|