xinput-gui-9999.ebuild 622 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. PYTHON_COMPAT=( python3_{6..9} )
  5. inherit distutils-r1
  6. DESCRIPTION="A simple GUI for Xorg's Xinput tool"
  7. HOMEPAGE="https://github.com/IvanFon/xinput-gui"
  8. if [[ ${PV} == "9999" ]]; then
  9. EGIT_REPO_URI="https://github.com/IvanFon/${PN}.git"
  10. inherit git-r3
  11. else
  12. SRC_URI="https://github.com/IvanFon/${PN}/releases/download/${PV}/${P}.tar.gz"
  13. KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86"
  14. fi
  15. LICENSE="GPL-3"
  16. SLOT="0"
  17. RDEPEND="
  18. dev-python/pygobject
  19. x11-apps/xinput
  20. x11-libs/gtk+:3
  21. "