lemonbar-1.4.ebuild 552 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. DESCRIPTION="A featherweight, lemon-scented, bar based on xcb"
  5. HOMEPAGE="https://github.com/LemonBoy/bar"
  6. SRC_URI="${HOMEPAGE}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  7. LICENSE="MIT"
  8. SLOT="0"
  9. KEYWORDS="amd64 ~x86"
  10. IUSE="doc"
  11. DEPEND="x11-libs/libxcb"
  12. RDEPEND="${DEPEND}"
  13. BDEPEND="doc? ( dev-lang/perl )"
  14. S="${WORKDIR}/${P##lemon}"
  15. src_compile() {
  16. emake all $(usev doc)
  17. }
  18. src_install() {
  19. dobin "${PN}"
  20. use doc && doman "${PN}.1"
  21. }