LegacyFox-9999.ebuild 653 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit multilib
  5. DESCRIPTION="Monkeypatching Firefox Quantum to run VimFx"
  6. HOMEPAGE="https://git.gir.st/LegacyFox.git"
  7. LICENSE="MPL-2.0"
  8. SLOT="0"
  9. if [[ "${PV}" == 9999 ]]; then
  10. EGIT_REPO_URI="https://git.gir.st/LegacyFox.git"
  11. inherit git-r3
  12. else
  13. SRC_URI="
  14. https://git.gir.st/${PN}.git/snapshot/refs/tags/v${PV}.tar.gz
  15. -> ${P}.tar.gz"
  16. KEYWORDS="amd64 arm64 ppc64 x86"
  17. S="${WORKDIR}/${PN}-v${PV}"
  18. fi
  19. src_install() {
  20. local FF_DIR
  21. FF_DIR="/usr/$(get_libdir)/firefox/"
  22. dodir "${FF_DIR}"
  23. emake DESTDIR="${ED}/${FF_DIR#/}" install
  24. }