ytop-0.6.2.ebuild 2.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157
  1. # Copyright 2017-2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. CRATES="
  5. ansi_term-0.11.0
  6. arc-swap-0.4.6
  7. arrayref-0.3.6
  8. arrayvec-0.5.1
  9. atty-0.2.14
  10. autocfg-1.0.0
  11. backtrace-0.3.46
  12. backtrace-sys-0.1.37
  13. base64-0.11.0
  14. battery-0.7.5
  15. better-panic-0.2.0
  16. bitflags-1.2.1
  17. blake2b_simd-0.5.10
  18. cassowary-0.3.0
  19. cc-1.0.52
  20. cfg-if-0.1.10
  21. chrono-0.4.11
  22. clap-2.33.0
  23. clicolors-control-1.0.1
  24. cloudabi-0.0.3
  25. console-0.9.2
  26. constant_time_eq-0.1.5
  27. core-foundation-0.6.4
  28. core-foundation-sys-0.6.2
  29. crossbeam-channel-0.4.2
  30. crossbeam-deque-0.7.3
  31. crossbeam-epoch-0.8.2
  32. crossbeam-queue-0.2.1
  33. crossbeam-utils-0.7.2
  34. crossterm-0.17.4
  35. crossterm_winapi-0.6.1
  36. ctrlc-3.1.4
  37. darwin-libproc-0.1.2
  38. darwin-libproc-sys-0.1.2
  39. derive_more-0.99.5
  40. dirs-2.0.2
  41. dirs-sys-0.3.4
  42. doc-comment-0.3.3
  43. either-1.5.3
  44. encode_unicode-0.3.6
  45. fern-0.6.0
  46. fuchsia-zircon-0.3.3
  47. fuchsia-zircon-sys-0.3.3
  48. getrandom-0.1.14
  49. glob-0.3.0
  50. heck-0.3.1
  51. hermit-abi-0.1.12
  52. iovec-0.1.4
  53. itertools-0.9.0
  54. itoa-0.4.5
  55. kernel32-sys-0.2.2
  56. lazy_static-1.4.0
  57. lazycell-1.2.1
  58. libc-0.2.69
  59. lock_api-0.3.4
  60. log-0.4.8
  61. mach-0.2.3
  62. mach-0.3.2
  63. maybe-uninit-2.0.0
  64. memchr-2.3.3
  65. memoffset-0.5.4
  66. mio-0.6.22
  67. miow-0.2.1
  68. net2-0.2.34
  69. nix-0.15.0
  70. nix-0.17.0
  71. ntapi-0.3.4
  72. num-bigint-0.2.6
  73. num-integer-0.1.42
  74. num-rational-0.2.4
  75. num-traits-0.2.11
  76. num_cpus-1.13.0
  77. once_cell-1.3.1
  78. parking_lot-0.10.2
  79. parking_lot_core-0.7.2
  80. platform-dirs-0.2.0
  81. platforms-0.2.1
  82. proc-macro-error-1.0.2
  83. proc-macro-error-attr-1.0.2
  84. proc-macro2-1.0.12
  85. psutil-3.1.0
  86. quote-1.0.4
  87. rayon-1.3.0
  88. rayon-core-1.7.0
  89. redox_syscall-0.1.56
  90. redox_users-0.3.4
  91. regex-1.3.7
  92. regex-syntax-0.6.17
  93. rust-argon2-0.7.0
  94. rustc-demangle-0.1.16
  95. ryu-1.0.4
  96. scopeguard-1.1.0
  97. serde-1.0.110
  98. serde_derive-1.0.110
  99. serde_json-1.0.53
  100. signal-hook-0.1.14
  101. signal-hook-registry-1.2.0
  102. size-0.1.2
  103. slab-0.4.2
  104. smallvec-1.4.0
  105. snafu-0.6.7
  106. snafu-derive-0.6.7
  107. strsim-0.8.0
  108. structopt-0.3.14
  109. structopt-derive-0.4.7
  110. syn-1.0.19
  111. syn-mid-0.5.0
  112. sysinfo-0.14.1
  113. termios-0.3.2
  114. textwrap-0.11.0
  115. time-0.1.43
  116. tui-0.9.2
  117. typenum-1.12.0
  118. unescape-0.1.0
  119. unicode-segmentation-1.6.0
  120. unicode-width-0.1.7
  121. unicode-xid-0.2.0
  122. uom-0.26.0
  123. vec_map-0.8.2
  124. version_check-0.9.1
  125. void-1.0.2
  126. wasi-0.9.0+wasi-snapshot-preview1
  127. winapi-0.2.8
  128. winapi-0.3.8
  129. winapi-build-0.1.1
  130. winapi-i686-pc-windows-gnu-0.4.0
  131. winapi-x86_64-pc-windows-gnu-0.4.0
  132. ws2_32-sys-0.2.1
  133. ${P}
  134. "
  135. inherit cargo flag-o-matic
  136. DESCRIPTION="A TUI system monitor written in Rust"
  137. HOMEPAGE="
  138. https://crates.io/crates/ytop
  139. https://github.com/cjbassi/ytop
  140. "
  141. SRC_URI="$(cargo_crate_uris ${CRATES})"
  142. RESTRICT="mirror"
  143. LICENSE="MIT Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD BSD-2 CC0-1.0 Unlicense"
  144. SLOT="0"
  145. KEYWORDS="~amd64"
  146. src_compile() {
  147. filter-flags -flto* # building fails when compiling with LTO
  148. cargo_src_compile
  149. }