bottom-0.6.3.ebuild 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213
  1. # Copyright 2017-2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. CRATES="
  5. addr2line-0.15.1
  6. adler-0.2.3
  7. aho-corasick-0.7.18
  8. ansi_term-0.11.0
  9. anyhow-1.0.40
  10. assert_cmd-1.0.3
  11. async-channel-1.5.1
  12. async-executor-1.4.0
  13. async-fs-1.5.0
  14. async-io-1.3.1
  15. async-lock-2.3.0
  16. async-net-1.5.0
  17. async-process-1.0.1
  18. async-task-4.0.3
  19. atomic-waker-1.0.0
  20. atty-0.2.14
  21. autocfg-1.0.1
  22. backtrace-0.3.59
  23. battery-0.7.8
  24. bitflags-1.2.1
  25. blocking-1.0.2
  26. bstr-0.2.15
  27. byteorder-1.4.2
  28. cache-padded-1.1.1
  29. cargo-husky-1.5.0
  30. cassowary-0.3.0
  31. cc-1.0.67
  32. cfg-if-0.1.10
  33. cfg-if-1.0.0
  34. chrono-0.4.19
  35. clap-2.33.3
  36. concurrent-queue-1.2.2
  37. const_fn-0.4.4
  38. core-foundation-0.7.0
  39. core-foundation-0.9.1
  40. core-foundation-sys-0.7.0
  41. core-foundation-sys-0.8.2
  42. crc32fast-1.2.1
  43. crossbeam-channel-0.5.0
  44. crossbeam-deque-0.8.0
  45. crossbeam-epoch-0.9.1
  46. crossbeam-utils-0.8.1
  47. crossterm-0.18.2
  48. crossterm_winapi-0.6.2
  49. ctrlc-3.1.9
  50. difference-2.0.0
  51. dirs-3.0.2
  52. dirs-sys-0.3.6
  53. doc-comment-0.3.3
  54. either-1.6.1
  55. event-listener-2.5.1
  56. fastrand-1.4.0
  57. fern-0.6.0
  58. flate2-1.0.20
  59. float-cmp-0.8.0
  60. futures-0.3.14
  61. futures-channel-0.3.14
  62. futures-core-0.3.14
  63. futures-executor-0.3.14
  64. futures-io-0.3.14
  65. futures-lite-1.11.2
  66. futures-macro-0.3.14
  67. futures-sink-0.3.14
  68. futures-task-0.3.14
  69. futures-timer-3.0.2
  70. futures-util-0.3.14
  71. fxhash-0.2.1
  72. getrandom-0.2.3
  73. gimli-0.24.0
  74. glob-0.3.0
  75. hashbrown-0.9.1
  76. heim-0.1.0-rc.1
  77. heim-common-0.1.0-rc.1
  78. heim-cpu-0.1.0-rc.1
  79. heim-disk-0.1.0-rc.1
  80. heim-memory-0.1.0-rc.1
  81. heim-net-0.1.0-rc.1
  82. heim-runtime-0.1.0-rc.1
  83. heim-sensors-0.1.0-rc.1
  84. hermit-abi-0.1.17
  85. hex-0.4.3
  86. indexmap-1.6.2
  87. instant-0.1.9
  88. itertools-0.10.0
  89. lazy_static-1.4.0
  90. lazycell-1.3.0
  91. libc-0.2.94
  92. lock_api-0.4.2
  93. log-0.4.14
  94. macaddr-1.0.1
  95. mach-0.3.2
  96. memchr-2.4.0
  97. memoffset-0.6.1
  98. miniz_oxide-0.4.3
  99. mio-0.7.6
  100. miow-0.3.6
  101. nb-connect-1.0.2
  102. nix-0.19.1
  103. nix-0.20.0
  104. normalize-line-endings-0.3.0
  105. ntapi-0.3.6
  106. num-integer-0.1.44
  107. num-rational-0.3.2
  108. num-traits-0.2.14
  109. num_cpus-1.13.0
  110. object-0.24.0
  111. once_cell-1.5.2
  112. parking-2.0.0
  113. parking_lot-0.11.1
  114. parking_lot_core-0.8.1
  115. pin-project-lite-0.1.11
  116. pin-project-lite-0.2.4
  117. pin-utils-0.1.0
  118. polling-2.0.2
  119. predicates-1.0.8
  120. predicates-core-1.0.0
  121. predicates-tree-1.0.0
  122. proc-macro-hack-0.5.19
  123. proc-macro-nested-0.1.6
  124. proc-macro2-1.0.27
  125. procfs-0.9.1
  126. quote-1.0.7
  127. rayon-1.5.0
  128. rayon-core-1.9.0
  129. redox_syscall-0.1.57
  130. redox_syscall-0.2.8
  131. redox_users-0.4.0
  132. regex-1.5.4
  133. regex-automata-0.1.9
  134. regex-syntax-0.6.25
  135. rustc-demangle-0.1.18
  136. scopeguard-1.1.0
  137. serde-1.0.125
  138. serde_derive-1.0.125
  139. signal-hook-0.1.16
  140. signal-hook-registry-1.2.2
  141. slab-0.4.2
  142. smallvec-1.5.1
  143. smol-1.2.5
  144. socket2-0.3.17
  145. strsim-0.8.0
  146. syn-1.0.72
  147. sysinfo-0.18.2
  148. textwrap-0.11.0
  149. thiserror-1.0.24
  150. thiserror-impl-1.0.24
  151. time-0.1.44
  152. toml-0.5.8
  153. treeline-0.1.0
  154. tui-0.14.0
  155. typed-builder-0.9.0
  156. typenum-1.12.0
  157. unicode-segmentation-1.7.1
  158. unicode-width-0.1.8
  159. unicode-xid-0.2.1
  160. uom-0.30.0
  161. vec-arena-1.0.0
  162. vec_map-0.8.2
  163. wait-timeout-0.2.0
  164. waker-fn-1.1.0
  165. wasi-0.10.0+wasi-snapshot-preview1
  166. wepoll-sys-3.0.1
  167. widestring-0.4.3
  168. winapi-0.3.9
  169. winapi-i686-pc-windows-gnu-0.4.0
  170. winapi-x86_64-pc-windows-gnu-0.4.0
  171. ${P}
  172. "
  173. inherit cargo
  174. DESCRIPTION="TUI process/system monitor with multitude of features"
  175. HOMEPAGE="
  176. https://crates.io/crates/bottom
  177. https://github.com/ClementTsang/bottom
  178. "
  179. SRC_URI="
  180. $(cargo_crate_uris ${CRATES})
  181. "
  182. RESTRICT="mirror"
  183. LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 MIT MPL-2.0"
  184. SLOT="0"
  185. KEYWORDS="amd64 ~arm64 ~ppc64"
  186. src_install() {
  187. local _PN=btm
  188. local DOCS=( README.md )
  189. dobin "target/release/${_PN}"
  190. einstalldocs
  191. cd "target/release/build/${PN}-"*/out || die 'failed to cd'
  192. # bash
  193. dobashcomp "./${_PN}.bash"
  194. # zsh
  195. insinto /usr/share/zsh/site-functions
  196. doins "./_${_PN}"
  197. # fish
  198. insinto /usr/share/fish/vendor_completions.d
  199. doins "./${_PN}.fish"
  200. }