duf-0.6.2.ebuild 2.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667
  1. # Copyright 2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit go-module
  5. EGO_SUM=(
  6. "github.com/davecgh/go-spew v1.1.1"
  7. "github.com/davecgh/go-spew v1.1.1/go.mod"
  8. "github.com/jedib0t/go-pretty/v6 v6.0.5"
  9. "github.com/jedib0t/go-pretty/v6 v6.0.5/go.mod"
  10. "github.com/lucasb-eyer/go-colorful v1.2.0"
  11. "github.com/lucasb-eyer/go-colorful v1.2.0/go.mod"
  12. "github.com/mattn/go-isatty v0.0.12"
  13. "github.com/mattn/go-isatty v0.0.12/go.mod"
  14. "github.com/mattn/go-runewidth v0.0.9/go.mod"
  15. "github.com/mattn/go-runewidth v0.0.10"
  16. "github.com/mattn/go-runewidth v0.0.10/go.mod"
  17. "github.com/muesli/termenv v0.8.1"
  18. "github.com/muesli/termenv v0.8.1/go.mod"
  19. "github.com/pkg/profile v1.2.1/go.mod"
  20. "github.com/pmezard/go-difflib v1.0.0"
  21. "github.com/pmezard/go-difflib v1.0.0/go.mod"
  22. "github.com/rivo/uniseg v0.1.0"
  23. "github.com/rivo/uniseg v0.1.0/go.mod"
  24. "github.com/stretchr/testify v1.2.2"
  25. "github.com/stretchr/testify v1.2.2/go.mod"
  26. "golang.org/x/crypto v0.0.0-20190308221718-c2843e01d9a2/go.mod"
  27. "golang.org/x/crypto v0.0.0-20200820211705-5c72a883971a"
  28. "golang.org/x/crypto v0.0.0-20200820211705-5c72a883971a/go.mod"
  29. "golang.org/x/net v0.0.0-20190404232315-eb5bcb51f2a3/go.mod"
  30. "golang.org/x/sys v0.0.0-20180816055513-1c9583448a9c/go.mod"
  31. "golang.org/x/sys v0.0.0-20190215142949-d0b11bdaac8a/go.mod"
  32. "golang.org/x/sys v0.0.0-20190412213103-97732733099d/go.mod"
  33. "golang.org/x/sys v0.0.0-20200116001909-b77594299b42/go.mod"
  34. "golang.org/x/sys v0.0.0-20200918174421-af09f7315aff"
  35. "golang.org/x/sys v0.0.0-20200918174421-af09f7315aff/go.mod"
  36. "golang.org/x/text v0.3.0/go.mod"
  37. )
  38. go-module_set_globals
  39. SRC_URI="
  40. https://github.com/muesli/${PN}/archive/refs/tags/v${PV}.tar.gz
  41. -> ${P}.tar.gz
  42. ${EGO_SUM_SRC_URI}
  43. "
  44. DESCRIPTION="Disk Usage/Free Utility - a better 'df' alternative"
  45. HOMEPAGE="https://github.com/muesli/duf"
  46. LICENSE="MIT"
  47. SLOT="0"
  48. KEYWORDS="amd64 arm arm64 ppc64 ~s390 x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
  49. src_compile() {
  50. go build || die 'go build failed'
  51. }
  52. src_install() {
  53. local DOCS=( *.md )
  54. dobin "${PN}"
  55. einstalldocs
  56. }