just-0.10.1.ebuild 2.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116
  1. # Copyright 2017-2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. CRATES="
  5. aho-corasick-0.7.18
  6. ansi_term-0.11.0
  7. ansi_term-0.12.1
  8. atty-0.2.14
  9. autocfg-1.0.1
  10. bitflags-1.3.2
  11. camino-1.0.5
  12. cc-1.0.69
  13. cfg-if-1.0.0
  14. clap-2.33.3
  15. cradle-0.0.22
  16. ctor-0.1.20
  17. ctrlc-3.2.0
  18. derivative-2.2.0
  19. diff-0.1.12
  20. doc-comment-0.3.3
  21. dotenv-0.15.0
  22. edit-distance-2.1.0
  23. either-1.6.1
  24. env_logger-0.9.0
  25. executable-path-1.0.0
  26. getrandom-0.2.3
  27. heck-0.3.3
  28. hermit-abi-0.1.19
  29. humantime-2.1.0
  30. lazy_static-1.4.0
  31. lexiclean-0.0.1
  32. libc-0.2.101
  33. linked-hash-map-0.5.4
  34. log-0.4.14
  35. memchr-2.4.1
  36. memoffset-0.6.4
  37. nix-0.22.0
  38. output_vt100-0.1.2
  39. ppv-lite86-0.2.10
  40. pretty_assertions-0.7.2
  41. proc-macro2-1.0.28
  42. quote-1.0.9
  43. rand-0.8.4
  44. rand_chacha-0.3.1
  45. rand_core-0.6.3
  46. rand_hc-0.3.1
  47. redox_syscall-0.2.10
  48. regex-1.5.4
  49. regex-syntax-0.6.25
  50. remove_dir_all-0.5.3
  51. rustversion-1.0.5
  52. snafu-0.6.10
  53. snafu-derive-0.6.10
  54. strsim-0.8.0
  55. strum-0.21.0
  56. strum_macros-0.21.1
  57. syn-1.0.75
  58. target-2.0.0
  59. tempfile-3.2.0
  60. temptree-0.2.0
  61. term_size-0.3.2
  62. termcolor-1.1.2
  63. textwrap-0.11.0
  64. typed-arena-2.0.1
  65. unicode-segmentation-1.8.0
  66. unicode-width-0.1.8
  67. unicode-xid-0.2.2
  68. vec_map-0.8.2
  69. wasi-0.10.2+wasi-snapshot-preview1
  70. which-4.2.2
  71. winapi-0.3.9
  72. winapi-i686-pc-windows-gnu-0.4.0
  73. winapi-util-0.1.5
  74. winapi-x86_64-pc-windows-gnu-0.4.0
  75. yaml-rust-0.4.5
  76. ${P}
  77. "
  78. inherit bash-completion-r1 cargo
  79. DESCRIPTION="Just a command runner (with syntax inspired by 'make')"
  80. HOMEPAGE="
  81. https://just.systems/
  82. https://crates.io/crates/just
  83. https://github.com/casey/just
  84. "
  85. SRC_URI="$(cargo_crate_uris ${CRATES})"
  86. LICENSE="Apache-2.0 CC0-1.0 MIT"
  87. SLOT="0"
  88. KEYWORDS="amd64 ~arm64 ~x86"
  89. RESTRICT="mirror"
  90. src_install() {
  91. local DOCS=( README.adoc )
  92. dobin "target/release/${PN}"
  93. doman man/*
  94. einstalldocs
  95. # bash-completion
  96. newbashcomp "completions/${PN}.bash" "${PN}"
  97. # zsh-completion
  98. insinto /usr/share/zsh/site-functions
  99. newins "completions/${PN}.zsh" "_${PN}"
  100. # fish-completion
  101. insinto /usr/share/fish/vendor_completions.d
  102. doins "completions/${PN}.fish"
  103. }