tldr-1.0.0_alpha.ebuild 8.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206
  1. # Copyright 2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. EGO_SUM=(
  5. "github.com/alcortesm/tgz v0.0.0-20161220082320-9c5fe88206d7"
  6. "github.com/alcortesm/tgz v0.0.0-20161220082320-9c5fe88206d7/go.mod"
  7. "github.com/alecthomas/template v0.0.0-20190718012654-fb15b899a751"
  8. "github.com/alecthomas/template v0.0.0-20190718012654-fb15b899a751/go.mod"
  9. "github.com/alecthomas/units v0.0.0-20190924025748-f65c72e2690d"
  10. "github.com/alecthomas/units v0.0.0-20190924025748-f65c72e2690d/go.mod"
  11. "github.com/anmitsu/go-shlex v0.0.0-20161002113705-648efa622239"
  12. "github.com/anmitsu/go-shlex v0.0.0-20161002113705-648efa622239/go.mod"
  13. "github.com/armon/go-socks5 v0.0.0-20160902184237-e75332964ef5"
  14. "github.com/armon/go-socks5 v0.0.0-20160902184237-e75332964ef5/go.mod"
  15. "github.com/c-bata/go-prompt v0.2.3"
  16. "github.com/c-bata/go-prompt v0.2.3/go.mod"
  17. "github.com/creack/pty v1.1.7/go.mod"
  18. "github.com/creack/pty v1.1.9/go.mod"
  19. "github.com/davecgh/go-spew v1.1.0/go.mod"
  20. "github.com/davecgh/go-spew v1.1.1"
  21. "github.com/davecgh/go-spew v1.1.1/go.mod"
  22. "github.com/emirpasic/gods v1.12.0"
  23. "github.com/emirpasic/gods v1.12.0/go.mod"
  24. "github.com/fatih/color v1.7.0"
  25. "github.com/fatih/color v1.7.0/go.mod"
  26. "github.com/fatih/color v1.9.0"
  27. "github.com/fatih/color v1.9.0/go.mod"
  28. "github.com/flynn/go-shlex v0.0.0-20150515145356-3f9db97f8568"
  29. "github.com/flynn/go-shlex v0.0.0-20150515145356-3f9db97f8568/go.mod"
  30. "github.com/gliderlabs/ssh v0.2.2"
  31. "github.com/gliderlabs/ssh v0.2.2/go.mod"
  32. "github.com/go-git/gcfg v1.5.0"
  33. "github.com/go-git/gcfg v1.5.0/go.mod"
  34. "github.com/go-git/go-billy/v5 v5.0.0"
  35. "github.com/go-git/go-billy/v5 v5.0.0/go.mod"
  36. "github.com/go-git/go-git-fixtures/v4 v4.0.1"
  37. "github.com/go-git/go-git-fixtures/v4 v4.0.1/go.mod"
  38. "github.com/go-git/go-git/v5 v5.1.0"
  39. "github.com/go-git/go-git/v5 v5.1.0/go.mod"
  40. "github.com/google/go-cmp v0.3.0"
  41. "github.com/google/go-cmp v0.3.0/go.mod"
  42. "github.com/imdario/mergo v0.3.9"
  43. "github.com/imdario/mergo v0.3.9/go.mod"
  44. "github.com/isacikgoz/gia v0.2.0/go.mod"
  45. "github.com/isacikgoz/gitin v0.2.4-0.20200912114409-236a7ef883ae"
  46. "github.com/isacikgoz/gitin v0.2.4-0.20200912114409-236a7ef883ae/go.mod"
  47. "github.com/isacikgoz/gitin v0.2.5"
  48. "github.com/isacikgoz/gitin v0.2.5/go.mod"
  49. "github.com/jbenet/go-context v0.0.0-20150711004518-d14ea06fba99"
  50. "github.com/jbenet/go-context v0.0.0-20150711004518-d14ea06fba99/go.mod"
  51. "github.com/jessevdk/go-flags v1.4.0/go.mod"
  52. "github.com/jroimartin/gocui v0.4.0/go.mod"
  53. "github.com/juju/errors v0.0.0-20150916125642-1b5e39b83d18/go.mod"
  54. "github.com/juju/loggo v0.0.0-20160511211902-0e0537f18a29/go.mod"
  55. "github.com/juju/testing v0.0.0-20160203233110-321edad6b2d1/go.mod"
  56. "github.com/juju/utils v0.0.0-20160815113839-bdb77b07e7e3/go.mod"
  57. "github.com/justincampbell/bigduration v0.0.0-20160531141349-e45bf03c0666/go.mod"
  58. "github.com/justincampbell/timeago v0.0.0-20160528003754-027f40306f1d/go.mod"
  59. "github.com/kelseyhightower/envconfig v1.4.0"
  60. "github.com/kelseyhightower/envconfig v1.4.0/go.mod"
  61. "github.com/kevinburke/ssh_config v0.0.0-20190725054713-01f96b0aa0cd"
  62. "github.com/kevinburke/ssh_config v0.0.0-20190725054713-01f96b0aa0cd/go.mod"
  63. "github.com/kr/pretty v0.1.0/go.mod"
  64. "github.com/kr/pty v1.1.1/go.mod"
  65. "github.com/kr/pty v1.1.8/go.mod"
  66. "github.com/kr/text v0.1.0/go.mod"
  67. "github.com/kr/text v0.2.0"
  68. "github.com/kr/text v0.2.0/go.mod"
  69. "github.com/kylelemons/godebug v1.1.0"
  70. "github.com/kylelemons/godebug v1.1.0/go.mod"
  71. "github.com/libgit2/git2go/v30 v30.0.9/go.mod"
  72. "github.com/mattn/go-colorable v0.1.2"
  73. "github.com/mattn/go-colorable v0.1.2/go.mod"
  74. "github.com/mattn/go-colorable v0.1.4"
  75. "github.com/mattn/go-colorable v0.1.4/go.mod"
  76. "github.com/mattn/go-isatty v0.0.8/go.mod"
  77. "github.com/mattn/go-isatty v0.0.10/go.mod"
  78. "github.com/mattn/go-isatty v0.0.11"
  79. "github.com/mattn/go-isatty v0.0.11/go.mod"
  80. "github.com/mattn/go-runewidth v0.0.4"
  81. "github.com/mattn/go-runewidth v0.0.4/go.mod"
  82. "github.com/mattn/go-runewidth v0.0.6"
  83. "github.com/mattn/go-runewidth v0.0.6/go.mod"
  84. "github.com/mattn/go-tty v0.0.3"
  85. "github.com/mattn/go-tty v0.0.3/go.mod"
  86. "github.com/mitchellh/go-homedir v1.1.0"
  87. "github.com/mitchellh/go-homedir v1.1.0/go.mod"
  88. "github.com/niemeyer/pretty v0.0.0-20200227124842-a10e7caefd8e"
  89. "github.com/niemeyer/pretty v0.0.0-20200227124842-a10e7caefd8e/go.mod"
  90. "github.com/nsf/termbox-go v0.0.0-20190325093121-288510b9734e/go.mod"
  91. "github.com/pelletier/go-buffruneio v0.2.0/go.mod"
  92. "github.com/pkg/errors v0.8.1"
  93. "github.com/pkg/errors v0.8.1/go.mod"
  94. "github.com/pkg/term v0.0.0-20200520122047-c3ffed290a03"
  95. "github.com/pkg/term v0.0.0-20200520122047-c3ffed290a03/go.mod"
  96. "github.com/pmezard/go-difflib v1.0.0"
  97. "github.com/pmezard/go-difflib v1.0.0/go.mod"
  98. "github.com/sahilm/fuzzy v0.1.0"
  99. "github.com/sahilm/fuzzy v0.1.0/go.mod"
  100. "github.com/sergi/go-diff v1.0.0/go.mod"
  101. "github.com/sergi/go-diff v1.1.0"
  102. "github.com/sergi/go-diff v1.1.0/go.mod"
  103. "github.com/src-d/gcfg v1.4.0"
  104. "github.com/src-d/gcfg v1.4.0/go.mod"
  105. "github.com/stretchr/objx v0.1.0/go.mod"
  106. "github.com/stretchr/objx v0.2.0/go.mod"
  107. "github.com/stretchr/testify v1.3.0/go.mod"
  108. "github.com/stretchr/testify v1.4.0"
  109. "github.com/stretchr/testify v1.4.0/go.mod"
  110. "github.com/waigani/diffparser v0.0.0-20190426062500-1f7065f429b5/go.mod"
  111. "github.com/waigani/diffparser v0.0.0-20190828052634-7391f219313d/go.mod"
  112. "github.com/xanzy/ssh-agent v0.2.1"
  113. "github.com/xanzy/ssh-agent v0.2.1/go.mod"
  114. "golang.org/x/crypto v0.0.0-20160824173033-351dc6a5bf92/go.mod"
  115. "golang.org/x/crypto v0.0.0-20190219172222-a4c6cb3142f2/go.mod"
  116. "golang.org/x/crypto v0.0.0-20190308221718-c2843e01d9a2/go.mod"
  117. "golang.org/x/crypto v0.0.0-20190701094942-4def268fd1a4/go.mod"
  118. "golang.org/x/crypto v0.0.0-20200302210943-78000ba7a073"
  119. "golang.org/x/crypto v0.0.0-20200302210943-78000ba7a073/go.mod"
  120. "golang.org/x/crypto v0.0.0-20200728195943-123391ffb6de"
  121. "golang.org/x/crypto v0.0.0-20200728195943-123391ffb6de/go.mod"
  122. "golang.org/x/net v0.0.0-20190404232315-eb5bcb51f2a3/go.mod"
  123. "golang.org/x/net v0.0.0-20190620200207-3b0461eec859/go.mod"
  124. "golang.org/x/net v0.0.0-20190724013045-ca1201d0de80/go.mod"
  125. "golang.org/x/net v0.0.0-20200301022130-244492dfa37a"
  126. "golang.org/x/net v0.0.0-20200301022130-244492dfa37a/go.mod"
  127. "golang.org/x/sync v0.0.0-20190423024810-112230192c58/go.mod"
  128. "golang.org/x/sync v0.0.0-20190911185100-cd5d95a43a6e/go.mod"
  129. "golang.org/x/sys v0.0.0-20190215142949-d0b11bdaac8a/go.mod"
  130. "golang.org/x/sys v0.0.0-20190221075227-b4e8571b14e0/go.mod"
  131. "golang.org/x/sys v0.0.0-20190222072716-a9d3bda3a223/go.mod"
  132. "golang.org/x/sys v0.0.0-20190412213103-97732733099d/go.mod"
  133. "golang.org/x/sys v0.0.0-20190726091711-fc99dfbffb4e/go.mod"
  134. "golang.org/x/sys v0.0.0-20191008105621-543471e840be/go.mod"
  135. "golang.org/x/sys v0.0.0-20191026070338-33540a1f6037/go.mod"
  136. "golang.org/x/sys v0.0.0-20191120155948-bd437916bb0e/go.mod"
  137. "golang.org/x/sys v0.0.0-20200302150141-5c8b2ff67527"
  138. "golang.org/x/sys v0.0.0-20200302150141-5c8b2ff67527/go.mod"
  139. "golang.org/x/text v0.3.0/go.mod"
  140. "golang.org/x/text v0.3.2"
  141. "golang.org/x/text v0.3.2/go.mod"
  142. "golang.org/x/tools v0.0.0-20180917221912-90fa682c2a6e/go.mod"
  143. "golang.org/x/tools v0.0.0-20190729092621-ff9f1409240a/go.mod"
  144. "gopkg.in/alecthomas/kingpin.v2 v2.2.6"
  145. "gopkg.in/alecthomas/kingpin.v2 v2.2.6/go.mod"
  146. "gopkg.in/check.v1 v0.0.0-20161208181325-20d25e280405/go.mod"
  147. "gopkg.in/check.v1 v1.0.0-20160105164936-4f90aeace3a2/go.mod"
  148. "gopkg.in/check.v1 v1.0.0-20180628173108-788fd7840127/go.mod"
  149. "gopkg.in/check.v1 v1.0.0-20190902080502-41f04d3bba15/go.mod"
  150. "gopkg.in/check.v1 v1.0.0-20200227125254-8fa46927fb4f"
  151. "gopkg.in/check.v1 v1.0.0-20200227125254-8fa46927fb4f/go.mod"
  152. "gopkg.in/mgo.v2 v2.0.0-20150529124711-01ee097136da/go.mod"
  153. "gopkg.in/src-d/go-billy.v4 v4.3.2"
  154. "gopkg.in/src-d/go-billy.v4 v4.3.2/go.mod"
  155. "gopkg.in/src-d/go-git-fixtures.v3 v3.5.0"
  156. "gopkg.in/src-d/go-git-fixtures.v3 v3.5.0/go.mod"
  157. "gopkg.in/src-d/go-git.v4 v4.13.1"
  158. "gopkg.in/src-d/go-git.v4 v4.13.1/go.mod"
  159. "gopkg.in/warnings.v0 v0.1.2"
  160. "gopkg.in/warnings.v0 v0.1.2/go.mod"
  161. "gopkg.in/yaml.v2 v2.0.0-20160715033755-e4d366fc3c79/go.mod"
  162. "gopkg.in/yaml.v2 v2.2.2/go.mod"
  163. "gopkg.in/yaml.v2 v2.2.4"
  164. "gopkg.in/yaml.v2 v2.2.4/go.mod"
  165. )
  166. inherit go-module
  167. go-module_set_globals
  168. DESCRIPTION="fast and interactive tldr client written with go"
  169. HOMEPAGE="
  170. https://isacikgoz.me/tldr/
  171. https://github.com/isacikgoz/tldr
  172. "
  173. SRC_URI="
  174. https://github.com/isacikgoz/${PN}/archive/v${PV/_/-}.tar.gz
  175. -> ${P}.tar.gz
  176. ${EGO_SUM_SRC_URI}
  177. "
  178. LICENSE="MIT"
  179. SLOT="0"
  180. KEYWORDS="~amd64 ~arm ~arm64 ~x86"
  181. IUSE="+static"
  182. DEPEND="!sys-apps/tealdeer"
  183. RDEPEND="${DEPEND}"
  184. S="${WORKDIR}/${PN}-${PV/_/-}"
  185. src_compile() {
  186. local goflags=( -ldflags='-s -w' )
  187. use static && goflags+=( -ldflags='-w -extldflags "-static"' )
  188. CGO_ENABLED=0 GO111MODULE=on go build "${goflags[@]}" ./cmd/tldr \
  189. || die 'failed to build go module'
  190. }
  191. src_install() {
  192. exeinto /usr/bin
  193. doexe "${PN}"
  194. }