tealdeer-1.4.1.ebuild 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228
  1. # Copyright 2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. CRATES="
  5. addr2line-0.13.0
  6. adler-0.2.3
  7. aho-corasick-0.7.13
  8. android_log-sys-0.1.2
  9. ansi_term-0.12.1
  10. app_dirs2-2.3.0
  11. ascii-0.9.3
  12. assert_cmd-1.0.1
  13. atty-0.2.14
  14. autocfg-1.0.1
  15. backtrace-0.3.50
  16. base64-0.12.3
  17. bitflags-1.2.1
  18. bumpalo-3.4.0
  19. byteorder-1.3.4
  20. bytes-0.5.6
  21. cc-1.0.59
  22. cesu8-1.1.0
  23. cfg-if-0.1.10
  24. combine-3.8.1
  25. core-foundation-0.7.0
  26. core-foundation-sys-0.7.0
  27. crc32fast-1.2.0
  28. derivative-2.1.1
  29. difference-2.0.0
  30. doc-comment-0.3.3
  31. docopt-1.1.0
  32. dtoa-0.4.6
  33. either-1.6.0
  34. encoding_rs-0.8.24
  35. env_logger-0.7.1
  36. errno-0.2.6
  37. errno-dragonfly-0.1.1
  38. error-chain-0.12.4
  39. escargot-0.5.0
  40. filetime-0.2.12
  41. flate2-1.0.17
  42. float-cmp-0.8.0
  43. fnv-1.0.7
  44. foreign-types-0.3.2
  45. foreign-types-shared-0.1.1
  46. fuchsia-zircon-0.3.3
  47. fuchsia-zircon-sys-0.3.3
  48. futures-channel-0.3.5
  49. futures-core-0.3.5
  50. futures-io-0.3.5
  51. futures-sink-0.3.5
  52. futures-task-0.3.5
  53. futures-util-0.3.5
  54. gcc-0.3.55
  55. getrandom-0.1.14
  56. gimli-0.22.0
  57. h2-0.2.6
  58. hashbrown-0.8.2
  59. hermit-abi-0.1.15
  60. http-0.2.1
  61. http-body-0.3.1
  62. httparse-1.3.4
  63. humantime-1.3.0
  64. hyper-0.13.7
  65. hyper-tls-0.4.3
  66. idna-0.2.0
  67. indexmap-1.5.2
  68. iovec-0.1.4
  69. ipnet-2.3.0
  70. itoa-0.4.6
  71. jni-0.14.0
  72. jni-sys-0.3.0
  73. js-sys-0.3.44
  74. kernel32-sys-0.2.2
  75. lazy_static-1.4.0
  76. libc-0.2.76
  77. log-0.4.11
  78. matches-0.1.8
  79. memchr-2.3.3
  80. mime-0.3.16
  81. mime_guess-2.0.3
  82. miniz_oxide-0.4.1
  83. mio-0.6.22
  84. miow-0.2.1
  85. native-tls-0.2.4
  86. ndk-0.1.0
  87. ndk-glue-0.1.0
  88. ndk-sys-0.1.0
  89. net2-0.2.34
  90. normalize-line-endings-0.3.0
  91. num-traits-0.2.12
  92. num_cpus-1.13.0
  93. num_enum-0.4.3
  94. num_enum_derive-0.4.3
  95. object-0.20.0
  96. once_cell-1.4.1
  97. openssl-0.10.30
  98. openssl-probe-0.1.2
  99. openssl-sys-0.9.58
  100. pager-0.15.0
  101. percent-encoding-2.1.0
  102. pin-project-0.4.23
  103. pin-project-internal-0.4.23
  104. pin-project-lite-0.1.7
  105. pin-utils-0.1.0
  106. pkg-config-0.3.18
  107. ppv-lite86-0.2.9
  108. predicates-1.0.5
  109. predicates-core-1.0.0
  110. predicates-tree-1.0.0
  111. proc-macro-crate-0.1.5
  112. proc-macro2-1.0.19
  113. quote-1.0.7
  114. quick-error-1.2.3
  115. rand-0.7.3
  116. rand_chacha-0.2.2
  117. rand_core-0.5.1
  118. rand_hc-0.2.0
  119. redox_syscall-0.1.57
  120. regex-1.3.9
  121. regex-syntax-0.6.18
  122. remove_dir_all-0.5.2
  123. reqwest-0.10.8
  124. rustc-demangle-0.1.16
  125. ryu-1.0.5
  126. same-file-1.0.6
  127. schannel-0.1.19
  128. security-framework-0.4.4
  129. security-framework-sys-0.4.3
  130. serde-1.0.115
  131. serde_derive-1.0.115
  132. serde_json-1.0.57
  133. serde_urlencoded-0.6.1
  134. slab-0.4.2
  135. socket2-0.3.12
  136. strsim-0.9.3
  137. syn-1.0.39
  138. tar-0.4.30
  139. tempfile-3.1.0
  140. termcolor-1.1.0
  141. thread_local-1.0.1
  142. time-0.1.44
  143. tinyvec-0.3.4
  144. tokio-0.2.22
  145. tokio-tls-0.3.1
  146. tokio-util-0.3.1
  147. toml-0.5.6
  148. tower-service-0.3.0
  149. tracing-0.1.19
  150. tracing-core-0.1.15
  151. treeline-0.1.0
  152. try-lock-0.2.3
  153. unicase-2.6.0
  154. unicode-bidi-0.3.4
  155. unicode-normalization-0.1.13
  156. unicode-xid-0.2.1
  157. unreachable-1.0.0
  158. url-2.1.1
  159. vcpkg-0.2.10
  160. version_check-0.9.2
  161. void-1.0.2
  162. wait-timeout-0.2.0
  163. walkdir-2.3.1
  164. want-0.3.0
  165. wasi-0.10.0+wasi-snapshot-preview1
  166. wasi-0.9.0+wasi-snapshot-preview1
  167. wasm-bindgen-0.2.67
  168. wasm-bindgen-backend-0.2.67
  169. wasm-bindgen-futures-0.4.17
  170. wasm-bindgen-macro-0.2.67
  171. wasm-bindgen-macro-support-0.2.67
  172. wasm-bindgen-shared-0.2.67
  173. web-sys-0.3.44
  174. winapi-0.2.8
  175. winapi-0.3.9
  176. winapi-build-0.1.1
  177. winapi-i686-pc-windows-gnu-0.4.0
  178. winapi-util-0.1.5
  179. winapi-x86_64-pc-windows-gnu-0.4.0
  180. winreg-0.7.0
  181. ws2_32-sys-0.2.1
  182. xattr-0.2.2
  183. xdg-2.2.0
  184. ${P}
  185. "
  186. inherit eutils cargo
  187. DESCRIPTION="Very fast implementation of tldr in Rust"
  188. HOMEPAGE="
  189. https://dbrgn.github.io/tealdeer
  190. https://github.com/dbrgn/tealdeer
  191. "
  192. SRC_URI="
  193. $(cargo_crate_uris ${CRATES})
  194. zsh-completion? (
  195. https://github.com/dbrgn/${PN}/releases/download/v${PV}/completions_zsh
  196. -> ${P}.zsh
  197. )
  198. "
  199. LICENSE="Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD MIT Unlicense ZLIB"
  200. SLOT="0"
  201. KEYWORDS="amd64 ~arm64 ~x86"
  202. IUSE="bash-completion zsh-completion fish-completion"
  203. DEPEND="!sys-apps/tldr"
  204. RDEPEND="${DEPEND}"
  205. src_install() {
  206. cargo_src_install
  207. einstalldocs
  208. use bash-completion && newbashcomp "bash_${PN}" "${PN}"
  209. use zsh-completion && {
  210. insinto /usr/share/zsh/site-functions
  211. newins "${DISTDIR}/${P}.zsh" "_${PN}"
  212. }
  213. use fish-completion && {
  214. insinto /usr/share/fish/vendor_completions.d
  215. newins "fish_${PN}" "${PN}.fish"
  216. }
  217. }