hexyl-0.9.0.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. # Copyright 2017-2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. CRATES="
  5. aho-corasick-0.7.18
  6. ansi_term-0.11.0
  7. ansi_term-0.12.1
  8. anyhow-1.0.42
  9. assert_cmd-1.0.7
  10. atty-0.2.14
  11. autocfg-1.0.1
  12. bitflags-1.2.1
  13. bstr-0.2.16
  14. clap-2.33.3
  15. difflib-0.4.0
  16. doc-comment-0.3.3
  17. either-1.6.1
  18. float-cmp-0.8.0
  19. hermit-abi-0.1.19
  20. itertools-0.10.1
  21. lazy_static-1.4.0
  22. libc-0.2.98
  23. memchr-2.4.0
  24. normalize-line-endings-0.3.0
  25. num-traits-0.2.14
  26. predicates-2.0.0
  27. predicates-core-1.0.2
  28. predicates-tree-1.0.2
  29. proc-macro2-1.0.27
  30. quote-1.0.9
  31. regex-1.5.4
  32. regex-automata-0.1.10
  33. regex-syntax-0.6.25
  34. strsim-0.8.0
  35. syn-1.0.73
  36. term_size-0.3.2
  37. textwrap-0.11.0
  38. thiserror-1.0.26
  39. thiserror-impl-1.0.26
  40. treeline-0.1.0
  41. unicode-width-0.1.8
  42. unicode-xid-0.2.2
  43. wait-timeout-0.2.0
  44. winapi-0.3.9
  45. winapi-i686-pc-windows-gnu-0.4.0
  46. winapi-x86_64-pc-windows-gnu-0.4.0
  47. ${P}
  48. "
  49. inherit cargo
  50. DESCRIPTION="A command-line hex viewer"
  51. HOMEPAGE="https://github.com/sharkdp/hexyl"
  52. SRC_URI="$(cargo_crate_uris ${CRATES})"
  53. LICENSE="Apache-2.0 MIT Unlicense"
  54. SLOT="0"
  55. KEYWORDS="amd64"
  56. RESTRICT="mirror"