exa-0.10.1.ebuild 1.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899
  1. # Copyright 1999-2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. CRATES="
  5. ansi_term-0.12.1
  6. autocfg-1.0.1
  7. bitflags-1.2.1
  8. byteorder-1.4.3
  9. cc-1.0.67
  10. cfg-if-1.0.0
  11. datetime-0.5.2
  12. exa-0.10.1
  13. form_urlencoded-1.0.1
  14. git2-0.13.17
  15. glob-0.3.0
  16. hermit-abi-0.1.18
  17. idna-0.2.2
  18. jobserver-0.1.21
  19. lazy_static-1.4.0
  20. libc-0.2.93
  21. libgit2-sys-0.12.18+1.1.0
  22. libz-sys-1.1.2
  23. locale-0.2.2
  24. log-0.4.14
  25. matches-0.1.8
  26. natord-1.0.9
  27. num_cpus-1.13.0
  28. number_prefix-0.4.0
  29. openssl-src-111.15.0+1.1.1k
  30. openssl-sys-0.9.61
  31. pad-0.1.6
  32. percent-encoding-2.1.0
  33. pkg-config-0.3.19
  34. redox_syscall-0.1.57
  35. scoped_threadpool-0.1.9
  36. term_grid-0.1.7
  37. term_size-0.3.2
  38. tinyvec-1.2.0
  39. tinyvec_macros-0.1.0
  40. unicode-bidi-0.3.5
  41. unicode-normalization-0.1.17
  42. unicode-width-0.1.8
  43. url-2.2.1
  44. users-0.11.0
  45. vcpkg-0.2.11
  46. winapi-0.3.9
  47. winapi-i686-pc-windows-gnu-0.4.0
  48. winapi-x86_64-pc-windows-gnu-0.4.0
  49. zoneinfo_compiled-0.5.1
  50. ${P}
  51. "
  52. inherit bash-completion-r1 cargo
  53. DESCRIPTION="A modern replacement for 'ls' written in Rust"
  54. HOMEPAGE="https://the.exa.website/"
  55. SRC_URI="
  56. $(cargo_crate_uris ${CRATES})
  57. https://github.com/ogham/${PN}/releases/download/v${PV}/${PN}-accoutrements-v${PV}.zip
  58. "
  59. LICENSE="Apache-2.0 MIT"
  60. SLOT="0"
  61. KEYWORDS="amd64 ~ppc64 ~x86"
  62. IUSE="+git"
  63. DEPEND="git? ( dev-libs/libgit2:= )"
  64. RDEPEND="${DEPEND}"
  65. # some tests fail on tmpfs/zfs/btrfs
  66. RESTRICT="test"
  67. QA_FLAGS_IGNORED="/usr/bin/${PN}"
  68. src_compile() {
  69. export LIBGIT2_SYS_USE_PKG_CONFIG=1
  70. export PKG_CONFIG_ALLOW_CROSS=1
  71. cargo_src_compile $(usex git "" --no-default-features)
  72. }
  73. src_install() {
  74. dobin "target/release/${PN}"
  75. doman "${WORKDIR}/man"/*
  76. # bash-completion
  77. newbashcomp completions/completions.bash "${PN}"
  78. # zsh-completion
  79. insinto /usr/share/zsh/site-functions
  80. newins completions/completions.zsh "_${PN}"
  81. # fish-completion
  82. insinto /usr/share/fish/vendor_completions.d
  83. newins completions/completions.fish "${PN}.fish"
  84. }