instalooter-2.4.4.ebuild 1008 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 2020-2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. PYTHON_COMPAT=( python3_{7..9} )
  5. DISTUTILS_USE_SETUPTOOLS=rdepend
  6. inherit distutils-r1
  7. DESCRIPTION="Another API-less Instagram pictures and videos downloader"
  8. HOMEPAGE="
  9. https://instalooter.readthedocs.io
  10. https://pypi.org/project/instalooter
  11. https://github.com/althonos/InstaLooter
  12. "
  13. SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
  14. LICENSE="GPL-3"
  15. SLOT="0"
  16. KEYWORDS="~amd64 ~x86"
  17. DEPEND="
  18. dev-python/coloredlogs[${PYTHON_USEDEP}]
  19. dev-python/python-dateutil[${PYTHON_USEDEP}]
  20. dev-python/docopt[${PYTHON_USEDEP}]
  21. dev-python/fake-useragent[${PYTHON_USEDEP}]
  22. dev-python/fs[${PYTHON_USEDEP}]
  23. dev-python/requests[${PYTHON_USEDEP}]
  24. dev-python/six[${PYTHON_USEDEP}]
  25. dev-python/tqdm[${PYTHON_USEDEP}]
  26. dev-python/tenacity[${PYTHON_USEDEP}]
  27. dev-python/verboselogs[${PYTHON_USEDEP}]
  28. "
  29. RDEPEND="${DEPEND}"
  30. src_prepare() {
  31. sed -i setup.cfg -e 's/~=/>=/' || die 'sed failed'
  32. default
  33. }