gping-1.2.3.ebuild 1.7 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394
  1. # Copyright 2017-2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. CRATES="
  5. aho-corasick-0.7.18
  6. ansi_term-0.11.0
  7. anyhow-1.0.42
  8. atty-0.2.14
  9. autocfg-1.0.1
  10. bitflags-1.2.1
  11. cassowary-0.3.0
  12. cfg-if-1.0.0
  13. chrono-0.4.19
  14. clap-2.33.3
  15. crossterm-0.19.0
  16. crossterm-0.20.0
  17. crossterm_winapi-0.7.0
  18. crossterm_winapi-0.8.0
  19. dns-lookup-1.0.8
  20. either-1.6.1
  21. heck-0.3.2
  22. hermit-abi-0.1.18
  23. instant-0.1.9
  24. itertools-0.10.1
  25. lazy_static-1.4.0
  26. libc-0.2.88
  27. lock_api-0.4.2
  28. log-0.4.14
  29. memchr-2.4.0
  30. mio-0.7.9
  31. miow-0.3.6
  32. ntapi-0.3.6
  33. num-integer-0.1.44
  34. num-traits-0.2.14
  35. os_info-3.0.6
  36. parking_lot-0.11.1
  37. parking_lot_core-0.8.3
  38. pinger-0.3.4
  39. proc-macro-error-1.0.4
  40. proc-macro-error-attr-1.0.4
  41. proc-macro2-1.0.24
  42. quote-1.0.9
  43. redox_syscall-0.2.5
  44. regex-1.5.4
  45. regex-syntax-0.6.25
  46. scopeguard-1.1.0
  47. signal-hook-0.1.17
  48. signal-hook-0.3.9
  49. signal-hook-mio-0.2.1
  50. signal-hook-registry-1.4.0
  51. smallvec-1.6.1
  52. socket2-0.3.19
  53. socket2-0.4.0
  54. static_assertions-1.1.0
  55. strsim-0.8.0
  56. structopt-0.3.22
  57. structopt-derive-0.4.15
  58. syn-1.0.62
  59. textwrap-0.11.0
  60. thiserror-1.0.26
  61. thiserror-impl-1.0.26
  62. time-0.1.44
  63. tui-0.15.0
  64. unicode-segmentation-1.7.1
  65. unicode-width-0.1.8
  66. unicode-xid-0.2.1
  67. vec_map-0.8.2
  68. version_check-0.9.2
  69. wasi-0.10.0+wasi-snapshot-preview1
  70. winapi-0.3.9
  71. winapi-i686-pc-windows-gnu-0.4.0
  72. winapi-x86_64-pc-windows-gnu-0.4.0
  73. winapi_forked_icmpapi-0.3.7
  74. winping-0.10.1
  75. ${P}
  76. "
  77. inherit cargo
  78. DESCRIPTION="Ping, but with a graph"
  79. HOMEPAGE="
  80. https://github.com/orf/gping
  81. https://crates.io/crates/gping
  82. "
  83. SRC_URI="$(cargo_crate_uris ${CRATES})"
  84. RESTRICT="mirror"
  85. LICENSE="Apache-2.0 BSD-2 MIT Unlicense"
  86. SLOT="0"
  87. KEYWORDS="amd64 ~arm64 ~x86"