mobi-0.3.1.ebuild 555 B

12345678910111213141516171819202122232425262728
  1. # Copyright 2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. PYTHON_COMPAT=( python3_{8..9} )
  5. inherit distutils-r1
  6. DESCRIPTION="Library for unpacking unencrypted mobi files"
  7. HOMEPAGE="
  8. https://pypi.org/project/mobi/
  9. https://github.com/iscc/mobi
  10. "
  11. SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
  12. LICENSE="GPL-3"
  13. SLOT="0"
  14. KEYWORDS="~amd64 ~ppc64 ~x86"
  15. DEPEND="dev-python/loguru"
  16. RDEPEND="${DEPEND}"
  17. src_prepare() {
  18. default
  19. rm -- mobi/mobiml2xhtml.py || die # until python2 syntax will be fixed
  20. }