TgCrypto-1.2.2.ebuild 613 B

123456789101112131415161718192021222324252627
  1. # Copyright 2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. PYTHON_COMPAT=( python3_{7..9} )
  5. inherit distutils-r1
  6. DESCRIPTION="Fast and Portable Telegram Crypto Library for Python"
  7. HOMEPAGE="
  8. https://docs.pyrogram.org/topics/tgcrypto
  9. https://github.com/pyrogram/tgcrypto
  10. "
  11. SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
  12. LICENSE="LGPL-3"
  13. SLOT="0"
  14. KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
  15. IUSE="test"
  16. RESTRICT="!test? ( test )"
  17. python_install() {
  18. rm -r -- "${BUILD_DIR}/lib/tests" || die 'failed to remove tests'
  19. distutils-r1_python_install
  20. }