alt-getopt-0.8.0.ebuild 806 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. LUA_COMPAT=( lua5-{1..4} luajit )
  5. inherit lua
  6. MY_PN="lua-${PN}"
  7. MY_P="${MY_PN}-${PV}"
  8. DESCRIPTION="Lua bindings to getopt_long"
  9. HOMEPAGE="
  10. http://luaforge.net/projects/alt-getopt
  11. https://github.com/cheusov/lua-alt-getopt
  12. "
  13. SRC_URI="
  14. https://github.com/cheusov/${MY_PN}/archive/${PV}.tar.gz
  15. -> ${MY_P}.tar.gz
  16. "
  17. LICENSE="MIT"
  18. SLOT="0"
  19. KEYWORDS="amd64 arm ppc x86 ~amd64-linux ~x86-linux"
  20. REQUIRED_USE="${LUA_REQUIRED_USE}"
  21. RDEPEND="${LUA_DEPS}"
  22. DEPEND="${RDEPEND}"
  23. DOCS=( README )
  24. S="${WORKDIR}/${MY_P}"
  25. LUA_S="${MY_P}"
  26. src_compile() { :; }
  27. lua_src_install() {
  28. insinto "$(lua_get_lmod_dir)"
  29. doins "${PN/-/_}.lua"
  30. }
  31. src_install() {
  32. einstalldocs
  33. lua_foreach_impl lua_src_install
  34. }