skalibs-9999.ebuild 835 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit git-r3
  5. DESCRIPTION="General-purpose libraries from skarnet.org"
  6. HOMEPAGE="https://www.skarnet.org/software/skalibs/"
  7. EGIT_REPO_URI="https://github.com/skarnet/${PN}.git"
  8. LICENSE="ISC"
  9. SLOT="0/$(ver_cut 1-2)"
  10. IUSE="doc ipv6 static-libs"
  11. HTML_DOCS=( doc/. )
  12. src_prepare() {
  13. default
  14. # Avoid QA warning for LDFLAGS addition; avoid overriding -fstack-protector
  15. sed -i -e 's/.*-Wl,--hash-style=both$/:/' -e '/-fno-stack-protector$/d' \
  16. configure || die
  17. }
  18. src_configure() {
  19. econf \
  20. --datadir=/etc \
  21. --dynlibdir=/usr/$(get_libdir) \
  22. --libdir=/usr/$(get_libdir)/${PN} \
  23. --sysdepdir=/usr/$(get_libdir)/${PN} \
  24. --enable-clock \
  25. --enable-shared \
  26. $(use_enable static-libs static) \
  27. $(use_enable ipv6)
  28. }