pandoc-bin-2.14.2.ebuild 668 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. MY_PN="${PN%%-bin}"
  5. MY_P="${MY_PN}-${PV}"
  6. DESCRIPTION="Universal markup converter"
  7. HOMEPAGE="
  8. https://pandoc.org
  9. https://github.com/jgm/pandoc
  10. "
  11. SRC_URI="
  12. https://github.com/jgm/${MY_PN}/releases/download/${PV}/${MY_P}-linux-${ARCH}.tar.gz
  13. "
  14. LICENSE="GPL-2"
  15. SLOT="0"
  16. KEYWORDS="amd64"
  17. RDEPEND="
  18. !${CATEGORY}/${MY_PN}
  19. "
  20. RESTRICT="strip"
  21. S="${WORKDIR}/${MY_P}"
  22. src_unpack() {
  23. default
  24. gzip -d "${S}/share/man/man1/${MY_PN}.1.gz" \
  25. || die 'failed to decompress man page'
  26. }
  27. src_install() {
  28. dobin "bin/${MY_PN}"
  29. doman "share/man/man1/${MY_PN}.1"
  30. }