epy-9999.ebuild 867 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. PYTHON_COMPAT=( python3_{8..10} )
  5. inherit distutils-r1 optfeature
  6. DESCRIPTION="CLI Ebook Reader"
  7. HOMEPAGE="https://github.com/wustho/epy"
  8. if [ "${PV}" = 9999 ]; then
  9. inherit git-r3
  10. EGIT_REPO_URI="https://github.com/wustho/epy.git"
  11. else
  12. MY_PN="${PN}-reader"
  13. MY_P="${MY_PN}-${PV}"
  14. S="${WORKDIR}/${MY_P}"
  15. SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
  16. KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ~ppc64 ~riscv ~s390 sparc x86"
  17. fi
  18. LICENSE="GPL-3"
  19. SLOT="0"
  20. pkg_postinst() {
  21. optfeature "mobi support" dev-python/mobi
  22. optfeature_header "Text-to-Speech support"
  23. optfeature "one of needed programs for TTS" media-sound/sox
  24. optfeature "one of needed programs for TTS (can be found in overlays)" \
  25. app-accessibility/svox
  26. }