zoxide-0.7.3.ebuild 1.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114
  1. # Copyright 2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. CRATES="
  5. anyhow-1.0.42
  6. arrayvec-0.5.2
  7. askama-0.10.5
  8. askama_derive-0.10.5
  9. askama_escape-0.10.1
  10. askama_shared-0.11.1
  11. assert_cmd-1.0.8
  12. atty-0.2.14
  13. autocfg-1.0.1
  14. bincode-1.3.3
  15. bitflags-1.2.1
  16. bitvec-0.19.5
  17. bstr-0.2.15
  18. cfg-if-1.0.0
  19. clap-3.0.0-beta.2
  20. clap_derive-3.0.0-beta.2
  21. clap_generate-3.0.0-beta.2
  22. difflib-0.4.0
  23. dirs-next-2.0.0
  24. dirs-sys-next-0.1.2
  25. doc-comment-0.3.3
  26. dunce-1.0.2
  27. either-1.6.1
  28. funty-1.1.0
  29. getrandom-0.2.3
  30. glob-0.3.0
  31. hashbrown-0.11.2
  32. heck-0.3.3
  33. hermit-abi-0.1.19
  34. indexmap-1.7.0
  35. itertools-0.10.1
  36. lazy_static-1.4.0
  37. lexical-core-0.7.6
  38. libc-0.2.98
  39. memchr-2.3.4
  40. nom-6.2.1
  41. num-traits-0.2.14
  42. ordered-float-2.7.0
  43. os_str_bytes-2.4.0
  44. ppv-lite86-0.2.10
  45. predicates-2.0.1
  46. predicates-core-1.0.2
  47. predicates-tree-1.0.2
  48. proc-macro-error-1.0.4
  49. proc-macro-error-attr-1.0.4
  50. proc-macro2-1.0.28
  51. quote-1.0.9
  52. radium-0.5.3
  53. rand-0.8.4
  54. rand_chacha-0.3.1
  55. rand_core-0.6.3
  56. rand_hc-0.3.1
  57. redox_syscall-0.2.9
  58. redox_users-0.4.0
  59. regex-automata-0.1.10
  60. remove_dir_all-0.5.3
  61. rstest-0.11.0
  62. rustc_version-0.4.0
  63. ryu-1.0.5
  64. semver-1.0.4
  65. serde-1.0.127
  66. serde_derive-1.0.127
  67. static_assertions-1.1.0
  68. strsim-0.10.0
  69. syn-1.0.74
  70. tap-1.0.1
  71. tempfile-3.2.0
  72. termcolor-1.1.2
  73. textwrap-0.12.1
  74. treeline-0.1.0
  75. unicode-segmentation-1.8.0
  76. unicode-width-0.1.8
  77. unicode-xid-0.2.2
  78. vec_map-0.8.2
  79. version_check-0.9.3
  80. wait-timeout-0.2.0
  81. wasi-0.10.2+wasi-snapshot-preview1
  82. winapi-0.3.9
  83. winapi-i686-pc-windows-gnu-0.4.0
  84. winapi-util-0.1.5
  85. winapi-x86_64-pc-windows-gnu-0.4.0
  86. wyz-0.2.0
  87. ${P}
  88. "
  89. inherit cargo
  90. DESCRIPTION="A smarter cd command"
  91. HOMEPAGE="
  92. https://crates.io/crates/zoxide
  93. https://github.com/ajeetdsouza/zoxide
  94. "
  95. SRC_URI="$(cargo_crate_uris ${CRATES})"
  96. RESTRICT="mirror"
  97. LICENSE="Apache-2.0 CC0-1.0 MIT"
  98. SLOT="0"
  99. KEYWORDS="amd64 ~x86"
  100. src_install() {
  101. local DOCS=( README.md )
  102. doman man/*
  103. einstalldocs
  104. dobin "target/release/${PN}"
  105. }