onefetch-2.10.2.ebuild 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222
  1. # Copyright 2017-2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. CRATES="
  5. addr2line-0.15.2
  6. adler-1.0.2
  7. adler32-1.2.0
  8. aho-corasick-0.7.18
  9. ansi_term-0.11.0
  10. ansi_term-0.12.1
  11. arrayvec-0.4.12
  12. askalono-0.4.3
  13. atty-0.2.14
  14. autocfg-1.0.1
  15. backtrace-0.3.60
  16. base64-0.13.0
  17. bitflags-1.2.1
  18. block-buffer-0.7.3
  19. block-padding-0.1.5
  20. bstr-0.2.16
  21. byte-tools-0.3.1
  22. byte-unit-4.0.12
  23. bytecount-0.6.2
  24. bytemuck-1.7.0
  25. byteorder-1.4.3
  26. cc-1.0.68
  27. cfg-if-1.0.0
  28. chrono-0.4.19
  29. chrono-humanize-0.2.1
  30. chrono-tz-0.5.3
  31. clap-2.33.3
  32. color_quant-1.1.0
  33. colored-2.0.0
  34. crc32fast-1.2.1
  35. crossbeam-channel-0.5.1
  36. crossbeam-deque-0.8.0
  37. crossbeam-epoch-0.9.5
  38. crossbeam-utils-0.8.5
  39. dashmap-4.0.2
  40. deflate-0.8.6
  41. deunicode-0.4.3
  42. digest-0.8.1
  43. dirs-3.0.2
  44. dirs-sys-0.3.6
  45. dtoa-0.4.8
  46. either-1.6.1
  47. encoding_rs-0.8.28
  48. encoding_rs_io-0.1.7
  49. env_logger-0.8.4
  50. error-chain-0.12.4
  51. failure-0.1.8
  52. failure_derive-0.1.8
  53. fake-simd-0.1.2
  54. flate2-1.0.20
  55. fnv-1.0.7
  56. form_urlencoded-1.0.1
  57. generic-array-0.12.4
  58. getrandom-0.2.3
  59. gif-0.11.2
  60. gimli-0.24.0
  61. git2-0.13.20
  62. glob-0.3.0
  63. globset-0.4.8
  64. globwalk-0.8.1
  65. grep-matcher-0.1.5
  66. grep-searcher-0.1.8
  67. heck-0.3.3
  68. hermit-abi-0.1.19
  69. humansize-1.1.1
  70. humantime-2.1.0
  71. idna-0.2.3
  72. ignore-0.4.18
  73. image-0.23.14
  74. instant-0.1.9
  75. itertools-0.9.0
  76. itoa-0.4.7
  77. jobserver-0.1.22
  78. jpeg-decoder-0.1.22
  79. json-0.12.4
  80. lazy_static-1.4.0
  81. libc-0.2.97
  82. libgit2-sys-0.12.21+1.1.0
  83. libz-sys-1.1.3
  84. linked-hash-map-0.5.4
  85. lock_api-0.4.4
  86. log-0.4.14
  87. maplit-1.0.2
  88. matches-0.1.8
  89. memchr-2.4.0
  90. memmap2-0.3.0
  91. memoffset-0.6.4
  92. miniz_oxide-0.3.7
  93. miniz_oxide-0.4.4
  94. more-asserts-0.2.1
  95. nodrop-0.1.14
  96. num-format-0.4.0
  97. num-integer-0.1.44
  98. num-iter-0.1.42
  99. num-rational-0.3.2
  100. num-traits-0.2.14
  101. num_cpus-1.13.0
  102. object-0.25.3
  103. once_cell-1.8.0
  104. opaque-debug-0.2.3
  105. parking_lot-0.11.1
  106. parking_lot_core-0.8.3
  107. parse-zoneinfo-0.3.0
  108. paste-1.0.5
  109. percent-encoding-2.1.0
  110. pest-2.1.3
  111. pest_derive-2.1.0
  112. pest_generator-2.1.3
  113. pest_meta-2.1.3
  114. pkg-config-0.3.19
  115. png-0.16.8
  116. ppv-lite86-0.2.10
  117. proc-macro2-1.0.27
  118. quote-1.0.9
  119. rand-0.8.4
  120. rand_chacha-0.3.1
  121. rand_core-0.6.3
  122. rand_hc-0.3.1
  123. rayon-1.5.1
  124. rayon-core-1.9.1
  125. redox_syscall-0.2.9
  126. redox_users-0.4.0
  127. regex-1.5.4
  128. regex-syntax-0.6.25
  129. rmp-0.8.10
  130. rmp-serde-0.14.4
  131. rustc-demangle-0.1.20
  132. ryu-1.0.5
  133. same-file-1.0.6
  134. scoped_threadpool-0.1.9
  135. scopeguard-1.1.0
  136. serde-1.0.126
  137. serde_derive-1.0.126
  138. serde_json-1.0.64
  139. serde_yaml-0.8.17
  140. sha-1-0.8.2
  141. slug-0.1.4
  142. smallvec-1.6.1
  143. strsim-0.8.0
  144. strum-0.21.0
  145. strum_macros-0.21.1
  146. syn-1.0.73
  147. synstructure-0.12.4
  148. tera-1.12.0
  149. term_size-0.3.2
  150. termcolor-1.1.2
  151. textwrap-0.11.0
  152. thread_local-1.1.3
  153. tiff-0.6.1
  154. time-0.1.43
  155. tinyvec-1.2.0
  156. tinyvec_macros-0.1.0
  157. tokei-12.1.2
  158. toml-0.5.8
  159. typenum-1.13.0
  160. ucd-trie-0.1.3
  161. unic-char-property-0.9.0
  162. unic-char-range-0.9.0
  163. unic-common-0.9.0
  164. unic-segment-0.9.0
  165. unic-ucd-segment-0.9.0
  166. unic-ucd-version-0.9.0
  167. unicode-bidi-0.3.5
  168. unicode-normalization-0.1.19
  169. unicode-segmentation-1.8.0
  170. unicode-width-0.1.8
  171. unicode-xid-0.2.2
  172. url-2.2.2
  173. utf8-width-0.1.5
  174. vcpkg-0.2.15
  175. vec_map-0.8.2
  176. version_check-0.9.3
  177. walkdir-2.3.2
  178. wasi-0.10.2+wasi-snapshot-preview1
  179. weezl-0.1.5
  180. winapi-0.3.9
  181. winapi-i686-pc-windows-gnu-0.4.0
  182. winapi-util-0.1.5
  183. winapi-x86_64-pc-windows-gnu-0.4.0
  184. yaml-rust-0.4.5
  185. zstd-0.5.4+zstd.1.4.7
  186. zstd-safe-2.0.6+zstd.1.4.7
  187. zstd-sys-1.4.18+zstd.1.4.7
  188. ${P}
  189. "
  190. inherit cargo flag-o-matic
  191. DESCRIPTION="Git repository summary on your terminal"
  192. HOMEPAGE="
  193. https://crates.io/crates/onefetch
  194. https://github.com/o2sh/onefetch
  195. "
  196. SRC_URI="$(cargo_crate_uris ${CRATES})"
  197. RESTRICT="mirror"
  198. LICENSE="Apache-2.0 BSD CC0-1.0 MIT MPL-2.0 ZLIB"
  199. SLOT="0"
  200. KEYWORDS="amd64"
  201. src_prepare() {
  202. filter-flags -flto* # building fails when compiling with LTO
  203. default
  204. }
  205. src_configure() {
  206. local myfeatures=( fail-on-deprecated )
  207. cargo_src_configure
  208. }
  209. src_install() {
  210. cargo_src_install
  211. doman "docs/${PN}.1"
  212. }