gpg-tui-0.8.0.ebuild 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203
  1. # Copyright 2017-2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. CRATES="
  5. ansi_term-0.11.0
  6. ansi_term-0.12.1
  7. anyhow-1.0.43
  8. atty-0.2.14
  9. autocfg-1.0.1
  10. bitflags-1.3.2
  11. block-0.1.6
  12. block-buffer-0.9.0
  13. bytemuck-1.7.2
  14. byteorder-1.4.3
  15. cassowary-0.3.0
  16. cc-1.0.70
  17. cfg-if-0.1.10
  18. cfg-if-1.0.0
  19. chrono-0.4.19
  20. clap-2.33.3
  21. clipboard-win-3.1.1
  22. color_quant-1.1.0
  23. colorsys-0.6.4
  24. conv-0.3.3
  25. copypasta-0.7.1
  26. copypasta-ext-0.3.7
  27. cpufeatures-0.2.1
  28. crossterm-0.20.0
  29. crossterm-0.21.0
  30. crossterm_winapi-0.8.0
  31. cstr-argument-0.1.1
  32. ctor-0.1.21
  33. custom_derive-0.1.7
  34. diff-0.1.12
  35. digest-0.9.0
  36. dirs-next-2.0.0
  37. dirs-sys-next-0.1.2
  38. dlib-0.5.0
  39. downcast-rs-1.2.0
  40. either-1.6.1
  41. generic-array-0.14.4
  42. getrandom-0.2.3
  43. gpg-error-0.5.2
  44. gpgme-0.10.0
  45. gpgme-sys-0.10.0
  46. heck-0.3.3
  47. hermit-abi-0.1.19
  48. hex-literal-0.3.3
  49. image-0.23.14
  50. instant-0.1.10
  51. jpeg-decoder-0.1.22
  52. lazy-bytes-cast-5.0.1
  53. lazy_static-1.4.0
  54. libc-0.2.101
  55. libgpg-error-sys-0.5.2
  56. libloading-0.7.0
  57. lock_api-0.4.5
  58. log-0.4.14
  59. malloc_buf-0.0.6
  60. memchr-2.4.1
  61. memmap2-0.2.3
  62. minimal-lexical-0.1.2
  63. mio-0.7.13
  64. miow-0.3.7
  65. nix-0.20.0
  66. nom-7.0.0
  67. ntapi-0.3.6
  68. num-integer-0.1.44
  69. num-iter-0.1.42
  70. num-rational-0.3.2
  71. num-traits-0.2.14
  72. objc-0.2.7
  73. objc-foundation-0.1.1
  74. objc_id-0.1.1
  75. once_cell-1.8.0
  76. opaque-debug-0.3.0
  77. output_vt100-0.1.2
  78. parking_lot-0.11.2
  79. parking_lot_core-0.8.5
  80. pkg-config-0.3.19
  81. pretty_assertions-0.7.2
  82. proc-macro-error-1.0.4
  83. proc-macro-error-attr-1.0.4
  84. proc-macro2-1.0.29
  85. quote-1.0.9
  86. redox_syscall-0.2.10
  87. redox_users-0.4.0
  88. rust-embed-6.2.0
  89. rust-embed-impl-6.1.0
  90. rust-embed-utils-7.0.0
  91. same-file-1.0.6
  92. scoped-tls-1.0.0
  93. scopeguard-1.1.0
  94. serde-1.0.130
  95. serde_derive-1.0.130
  96. sha2-0.9.6
  97. shellexpand-2.1.0
  98. signal-hook-0.3.10
  99. signal-hook-mio-0.2.1
  100. signal-hook-registry-1.4.0
  101. smallvec-1.6.1
  102. smithay-client-toolkit-0.14.0
  103. smithay-clipboard-0.6.4
  104. static_assertions-1.1.0
  105. strsim-0.8.0
  106. structopt-0.3.23
  107. structopt-derive-0.4.16
  108. syn-1.0.75
  109. term_size-0.3.2
  110. textwrap-0.11.0
  111. time-0.1.44
  112. toml-0.5.8
  113. tui-0.16.0
  114. typenum-1.13.0
  115. unicode-segmentation-1.8.0
  116. unicode-width-0.1.8
  117. unicode-xid-0.2.2
  118. version_check-0.9.3
  119. walkdir-2.3.2
  120. wasi-0.10.0+wasi-snapshot-preview1
  121. wayland-client-0.28.6
  122. wayland-commons-0.28.6
  123. wayland-cursor-0.28.6
  124. wayland-protocols-0.28.6
  125. wayland-scanner-0.28.6
  126. wayland-sys-0.28.6
  127. which-4.2.2
  128. winapi-0.3.9
  129. winapi-i686-pc-windows-gnu-0.4.0
  130. winapi-util-0.1.5
  131. winapi-x86_64-pc-windows-gnu-0.4.0
  132. winreg-0.7.0
  133. winreg-0.9.0
  134. x11-clipboard-0.5.2
  135. xcb-0.9.0
  136. xcursor-0.3.4
  137. xml-rs-0.8.4
  138. ${P}
  139. "
  140. inherit bash-completion-r1 cargo
  141. DESCRIPTION="Terminal User Interface for GnuPG"
  142. HOMEPAGE="
  143. https://crates.io/crates/gpg-tui
  144. https://github.com/orhun/gpg-tui
  145. "
  146. SRC_URI="
  147. $(cargo_crate_uris ${CRATES})
  148. https://github.com/orhun/${PN}/raw/v${PV}/man/${PN}.1 -> ${P}.man.1
  149. "
  150. LICENSE="Apache-2.0 BSD Boost-1.0 ISC LGPL-2.1 MIT Unlicense"
  151. SLOT="0"
  152. KEYWORDS="amd64 ~x86"
  153. RESTRICT="mirror"
  154. DEPEND="
  155. app-crypt/gpgme
  156. dev-libs/libgpg-error
  157. x11-libs/libxcb
  158. "
  159. RDEPEND="${DEPEND}"
  160. BDEPEND="x11-libs/libxkbcommon"
  161. src_unpack() {
  162. cargo_src_unpack
  163. cp -v -- "${DISTDIR}/${P}.man.1" "${S}/${PN}.1" || die
  164. }
  165. src_compile() {
  166. local completions="${S}/completions"
  167. cargo_src_compile
  168. ebegin "generating completions"
  169. mkdir -p -- "${completions}" || die
  170. OUT_DIR="${completions}" "./target/release/${PN}-completions"
  171. eend "${?}" 'failed to generate completions' || die "${_}"
  172. }
  173. src_install() {
  174. doman "${PN}.1"
  175. dobin "target/release/${PN}"
  176. # bash-completion
  177. newbashcomp "completions/${PN}.bash" "${PN}"
  178. # zsh-completion
  179. insinto /usr/share/zsh/site-functions
  180. doins "completions/_${PN}"
  181. # fish-completion
  182. insinto /usr/share/fish/vendor_completions.d
  183. doins "completions/${PN}.fish"
  184. }