zola-0.19.2.ebuild 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573
  1. # Copyright 2023-2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. # internal crates are located in `components/`
  5. CRATES="
  6. addr2line@0.22.0
  7. adler@1.0.2
  8. ahash@0.7.8
  9. ahash@0.8.11
  10. aho-corasick@0.7.20
  11. aho-corasick@1.1.3
  12. aligned-vec@0.5.0
  13. ammonia@4.0.0
  14. android-tzdata@0.1.1
  15. android_system_properties@0.1.5
  16. anstream@0.6.14
  17. anstyle@1.0.7
  18. anstyle-parse@0.2.4
  19. anstyle-query@1.1.0
  20. anstyle-wincon@3.0.3
  21. any_ascii@0.1.7
  22. anyhow@1.0.86
  23. arbitrary@1.3.2
  24. arg_enum_proc_macro@0.3.4
  25. arrayvec@0.7.4
  26. assert-json-diff@2.0.2
  27. atty@0.2.14
  28. autocfg@1.3.0
  29. av1-grain@0.2.3
  30. avif-serialize@0.8.1
  31. backtrace@0.3.73
  32. base64@0.21.7
  33. base64@0.22.1
  34. base64-simd@0.7.0
  35. bincode@1.3.3
  36. bit_field@0.10.2
  37. bitflags@1.3.2
  38. bitflags@2.5.0
  39. bitstream-io@2.4.1
  40. bitvec@1.0.1
  41. block-buffer@0.7.3
  42. block-buffer@0.10.4
  43. block-padding@0.1.5
  44. bstr@1.9.1
  45. build_const@0.2.2
  46. built@0.7.3
  47. bumpalo@3.16.0
  48. byte-tools@0.3.1
  49. bytecheck@0.6.12
  50. bytecheck_derive@0.6.12
  51. bytecount@0.6.8
  52. bytemuck@1.16.0
  53. byteorder@1.5.0
  54. byteorder-lite@0.1.0
  55. bytes@0.4.12
  56. bytes@1.6.0
  57. cc@1.0.99
  58. cedarwood@0.4.6
  59. cfg-expr@0.15.8
  60. cfg-if@0.1.10
  61. cfg-if@1.0.0
  62. cfg_aliases@0.1.1
  63. chrono@0.4.38
  64. chrono-tz@0.9.0
  65. chrono-tz-build@0.3.0
  66. clap@3.2.25
  67. clap@4.5.7
  68. clap_builder@4.5.7
  69. clap_complete@4.5.5
  70. clap_derive@3.2.25
  71. clap_derive@4.5.5
  72. clap_lex@0.2.4
  73. clap_lex@0.7.1
  74. codemap@0.1.3
  75. color_quant@1.1.0
  76. colorchoice@1.0.1
  77. colored@2.1.0
  78. console@0.15.8
  79. const-str@0.3.2
  80. const-str-proc-macro@0.3.2
  81. core-foundation@0.9.4
  82. core-foundation-sys@0.8.6
  83. cpufeatures@0.2.12
  84. crc@1.8.1
  85. crc32fast@1.4.2
  86. crossbeam-channel@0.5.13
  87. crossbeam-deque@0.8.5
  88. crossbeam-epoch@0.9.18
  89. crossbeam-utils@0.8.20
  90. crunchy@0.2.2
  91. crypto-common@0.1.6
  92. cssparser@0.33.0
  93. cssparser-color@0.1.0
  94. cssparser-macros@0.6.1
  95. csv@1.3.0
  96. csv-core@0.1.11
  97. ctrlc@3.4.4
  98. dashmap@5.5.3
  99. data-encoding@2.6.0
  100. data-url@0.1.1
  101. deranged@0.3.11
  102. deunicode@1.6.0
  103. digest@0.8.1
  104. digest@0.10.7
  105. displaydoc@0.2.4
  106. doc-comment@0.3.3
  107. dtoa@1.0.9
  108. dtoa-short@0.3.5
  109. either@1.12.0
  110. elasticlunr-rs@3.0.2
  111. encode_unicode@0.3.6
  112. encoding@0.2.33
  113. encoding-index-japanese@1.20141219.5
  114. encoding-index-korean@1.20141219.5
  115. encoding-index-simpchinese@1.20141219.5
  116. encoding-index-singlebyte@1.20141219.5
  117. encoding-index-tradchinese@1.20141219.5
  118. encoding_index_tests@0.1.4
  119. encoding_rs@0.8.34
  120. env_logger@0.9.3
  121. equivalent@1.0.1
  122. errno@0.3.9
  123. exr@1.72.0
  124. fake-simd@0.1.2
  125. fastrand@2.1.0
  126. fdeflate@0.3.4
  127. file-id@0.2.1
  128. filetime@0.2.23
  129. flate2@1.0.30
  130. flume@0.11.0
  131. fnv@1.0.7
  132. foreign-types@0.3.2
  133. foreign-types-shared@0.1.1
  134. form_urlencoded@1.2.1
  135. fsevent-sys@4.1.0
  136. fuchsia-zircon@0.3.3
  137. fuchsia-zircon-sys@0.3.3
  138. funty@2.0.0
  139. futf@0.1.5
  140. futures-channel@0.3.30
  141. futures-core@0.3.30
  142. futures-io@0.3.30
  143. futures-sink@0.3.30
  144. futures-task@0.3.30
  145. futures-util@0.3.30
  146. fxhash@0.2.1
  147. generic-array@0.12.4
  148. generic-array@0.14.7
  149. getrandom@0.1.16
  150. getrandom@0.2.15
  151. gh-emoji@1.0.8
  152. gif@0.13.1
  153. gimli@0.29.0
  154. glob@0.3.1
  155. globset@0.4.14
  156. globwalk@0.9.1
  157. grass@0.13.3
  158. grass_compiler@0.13.3
  159. h2@0.3.26
  160. half@2.4.1
  161. hashbrown@0.12.3
  162. hashbrown@0.13.2
  163. hashbrown@0.14.5
  164. heck@0.4.1
  165. heck@0.5.0
  166. hermit-abi@0.1.19
  167. html5ever@0.27.0
  168. http@0.2.12
  169. http-body@0.4.6
  170. httparse@1.9.3
  171. httpdate@1.0.3
  172. humansize@2.1.3
  173. humantime@2.1.0
  174. hyper@0.14.29
  175. hyper-rustls@0.24.2
  176. hyper-tls@0.5.0
  177. iana-time-zone@0.1.60
  178. iana-time-zone-haiku@0.1.2
  179. icu_collections@1.5.0
  180. icu_locid@1.5.0
  181. icu_locid_transform@1.5.0
  182. icu_locid_transform_data@1.5.0
  183. icu_normalizer@1.5.0
  184. icu_normalizer_data@1.5.0
  185. icu_properties@1.5.0
  186. icu_properties_data@1.5.0
  187. icu_provider@1.5.0
  188. icu_provider_macros@1.5.0
  189. idna@1.0.0
  190. ignore@0.4.22
  191. image@0.25.1
  192. image-webp@0.1.2
  193. imgref@1.10.1
  194. indexmap@1.9.3
  195. indexmap@2.2.6
  196. inotify@0.9.6
  197. inotify-sys@0.1.5
  198. insta@1.39.0
  199. interpolate_name@0.2.4
  200. iovec@0.1.4
  201. ipnet@2.9.0
  202. is-docker@0.2.0
  203. is-wsl@0.4.0
  204. is_terminal_polyfill@1.70.0
  205. itertools@0.10.5
  206. itertools@0.12.1
  207. itoa@1.0.11
  208. jieba-rs@0.6.8
  209. jobserver@0.1.31
  210. jpeg-decoder@0.3.1
  211. js-sys@0.3.69
  212. kamadak-exif@0.5.5
  213. kernel32-sys@0.2.2
  214. kqueue@1.0.8
  215. kqueue-sys@1.0.4
  216. lasso@0.7.2
  217. lazy_static@1.4.0
  218. lazycell@1.3.0
  219. lebe@0.5.2
  220. lexical-sort@0.3.1
  221. libc@0.2.155
  222. libfuzzer-sys@0.4.7
  223. libm@0.2.8
  224. libwebp-sys@0.9.5
  225. lightningcss@1.0.0-alpha.57
  226. lindera@0.14.0
  227. lindera-cc-cedict-builder@0.13.5
  228. lindera-core@0.13.5
  229. lindera-decompress@0.13.5
  230. lindera-dictionary@0.13.5
  231. lindera-ipadic@0.13.5
  232. lindera-ipadic-builder@0.13.5
  233. lindera-ko-dic-builder@0.13.5
  234. lindera-unidic-builder@0.13.5
  235. line-wrap@0.2.0
  236. linked-hash-map@0.5.6
  237. linux-raw-sys@0.4.14
  238. litemap@0.7.3
  239. lock_api@0.4.12
  240. log@0.4.21
  241. loop9@0.1.5
  242. lzma-rs@0.2.0
  243. mac@0.1.1
  244. maplit@1.0.2
  245. markup5ever@0.12.1
  246. matches@0.1.10
  247. maybe-rayon@0.1.1
  248. memchr@2.7.4
  249. mime@0.3.17
  250. mime_guess@2.0.4
  251. minidom@0.12.0
  252. minify-html@0.15.0
  253. minify-html-common@0.0.2
  254. minify-js@0.5.6
  255. minimal-lexical@0.2.1
  256. miniz_oxide@0.7.3
  257. mio@0.6.23
  258. mio@0.8.11
  259. mio-extras@2.0.6
  260. miow@0.2.2
  261. mockito@0.31.1
  262. mutate_once@0.1.1
  263. native-tls@0.2.12
  264. net2@0.2.39
  265. new_debug_unreachable@1.0.6
  266. nix@0.28.0
  267. nom@7.1.3
  268. nom-bibtex@0.5.0
  269. nom-tracable@0.9.1
  270. nom-tracable-macros@0.9.1
  271. nom_locate@4.2.0
  272. noop_proc_macro@0.3.0
  273. notify@6.1.1
  274. notify-debouncer-full@0.3.1
  275. num-bigint@0.4.5
  276. num-conv@0.1.0
  277. num-derive@0.4.2
  278. num-format@0.4.4
  279. num-integer@0.1.46
  280. num-rational@0.4.2
  281. num-traits@0.2.19
  282. num_threads@0.1.7
  283. object@0.36.0
  284. once_cell@1.19.0
  285. onig@6.4.0
  286. onig_sys@69.8.1
  287. opaque-debug@0.2.3
  288. open@5.1.4
  289. openssl@0.10.64
  290. openssl-macros@0.1.1
  291. openssl-probe@0.1.5
  292. openssl-sys@0.9.102
  293. os_str_bytes@6.6.1
  294. outref@0.1.0
  295. parcel_selectors@0.26.5
  296. parcel_sourcemap@2.1.1
  297. parking_lot@0.12.3
  298. parking_lot_core@0.9.10
  299. parse-js@0.17.0
  300. parse-zoneinfo@0.3.1
  301. paste@1.0.15
  302. path-slash@0.2.1
  303. pathdiff@0.2.1
  304. percent-encoding@2.3.1
  305. pest@2.7.10
  306. pest_derive@2.7.10
  307. pest_generator@2.7.10
  308. pest_meta@2.7.10
  309. phf@0.10.1
  310. phf@0.11.2
  311. phf_codegen@0.10.0
  312. phf_codegen@0.11.2
  313. phf_generator@0.10.0
  314. phf_generator@0.11.2
  315. phf_macros@0.11.2
  316. phf_shared@0.10.0
  317. phf_shared@0.11.2
  318. pin-project-lite@0.2.14
  319. pin-utils@0.1.0
  320. pkg-config@0.3.30
  321. plist@1.6.1
  322. png@0.17.13
  323. powerfmt@0.2.0
  324. ppv-lite86@0.2.17
  325. precomputed-hash@0.1.1
  326. proc-macro-error@1.0.4
  327. proc-macro-error-attr@1.0.4
  328. proc-macro2@1.0.85
  329. profiling@1.0.15
  330. profiling-procmacros@1.0.15
  331. ptr_meta@0.1.4
  332. ptr_meta_derive@0.1.4
  333. pulldown-cmark@0.11.0
  334. pulldown-cmark-escape@0.11.0
  335. pure-rust-locales@0.8.1
  336. qoi@0.4.1
  337. quick-error@2.0.1
  338. quick-xml@0.17.2
  339. quick-xml@0.31.0
  340. quickxml_to_serde@0.6.0
  341. quote@1.0.36
  342. radium@0.7.0
  343. rand@0.7.3
  344. rand@0.8.5
  345. rand_chacha@0.2.2
  346. rand_chacha@0.3.1
  347. rand_core@0.5.1
  348. rand_core@0.6.4
  349. rand_hc@0.2.0
  350. rav1e@0.7.1
  351. ravif@0.11.7
  352. rayon@1.10.0
  353. rayon-core@1.12.1
  354. redox_syscall@0.4.1
  355. redox_syscall@0.5.2
  356. regex@1.10.5
  357. regex-automata@0.4.7
  358. regex-syntax@0.8.4
  359. relative-path@1.9.3
  360. rend@0.4.2
  361. reqwest@0.11.27
  362. rgb@0.8.37
  363. ring@0.17.8
  364. rkyv@0.7.44
  365. rkyv_derive@0.7.44
  366. roxmltree@0.20.0
  367. rust-stemmers@1.2.0
  368. rustc-demangle@0.1.24
  369. rustc-hash@1.1.0
  370. rustix@0.38.34
  371. rustls@0.21.12
  372. rustls-pemfile@1.0.4
  373. rustls-webpki@0.101.7
  374. ryu@1.0.18
  375. same-file@1.0.6
  376. schannel@0.1.23
  377. scopeguard@1.2.0
  378. sct@0.7.1
  379. seahash@4.1.0
  380. security-framework@2.11.0
  381. security-framework-sys@2.11.0
  382. serde@1.0.203
  383. serde_derive@1.0.203
  384. serde_json@1.0.117
  385. serde_spanned@0.6.6
  386. serde_urlencoded@0.7.1
  387. serde_yaml@0.9.34+deprecated
  388. sha-1@0.8.2
  389. sha2@0.10.8
  390. simd-abstraction@0.7.1
  391. simd-adler32@0.3.7
  392. simd_helpers@0.1.0
  393. simdutf8@0.1.4
  394. similar@2.5.0
  395. siphasher@0.3.11
  396. slab@0.4.9
  397. slug@0.1.5
  398. smallvec@1.13.2
  399. socket2@0.5.7
  400. spin@0.9.8
  401. stable_deref_trait@1.2.0
  402. string_cache@0.8.7
  403. string_cache_codegen@0.5.2
  404. strsim@0.10.0
  405. strsim@0.11.1
  406. svg_metadata@0.5.1
  407. syn@1.0.109
  408. syn@2.0.66
  409. sync_wrapper@0.1.2
  410. synstructure@0.13.1
  411. syntect@5.2.0
  412. system-configuration@0.5.1
  413. system-configuration-sys@0.5.0
  414. system-deps@6.2.2
  415. tap@1.0.1
  416. tar@0.4.41
  417. target-lexicon@0.12.14
  418. tempfile@3.10.1
  419. tendril@0.4.3
  420. tera@1.20.0
  421. termcolor@1.4.1
  422. test-case@3.3.1
  423. test-case-core@3.3.1
  424. test-case-macros@3.3.1
  425. textwrap@0.16.1
  426. thiserror@1.0.61
  427. thiserror-impl@1.0.61
  428. tiff@0.9.1
  429. time@0.3.36
  430. time-core@0.1.2
  431. time-macros@0.2.18
  432. tinystr@0.7.6
  433. tinyvec@1.6.0
  434. tinyvec_macros@0.1.1
  435. tokio@1.38.0
  436. tokio-native-tls@0.3.1
  437. tokio-rustls@0.24.1
  438. tokio-util@0.7.11
  439. toml@0.5.11
  440. toml@0.8.14
  441. toml_datetime@0.6.6
  442. toml_edit@0.22.14
  443. tower-service@0.3.2
  444. tracing@0.1.40
  445. tracing-core@0.1.32
  446. try-lock@0.2.5
  447. typenum@1.17.0
  448. ucd-trie@0.1.6
  449. unic-char-property@0.9.0
  450. unic-char-range@0.9.0
  451. unic-common@0.9.0
  452. unic-langid@0.9.5
  453. unic-langid-impl@0.9.5
  454. unic-segment@0.9.0
  455. unic-ucd-segment@0.9.0
  456. unic-ucd-version@0.9.0
  457. unicase@2.7.0
  458. unicode-ident@1.0.12
  459. unicode-segmentation@1.11.0
  460. unsafe-libyaml@0.2.11
  461. untrusted@0.9.0
  462. url@2.5.1
  463. utf-8@0.7.6
  464. utf16_iter@1.0.5
  465. utf8_iter@1.0.4
  466. utf8parse@0.2.2
  467. uuid@1.8.0
  468. v_frame@0.3.8
  469. vcpkg@0.2.15
  470. version-compare@0.2.0
  471. version_check@0.9.4
  472. vlq@0.5.1
  473. walkdir@2.5.0
  474. want@0.3.1
  475. wasi@0.9.0+wasi-snapshot-preview1
  476. wasi@0.11.0+wasi-snapshot-preview1
  477. wasm-bindgen@0.2.92
  478. wasm-bindgen-backend@0.2.92
  479. wasm-bindgen-futures@0.4.42
  480. wasm-bindgen-macro@0.2.92
  481. wasm-bindgen-macro-support@0.2.92
  482. wasm-bindgen-shared@0.2.92
  483. web-sys@0.3.69
  484. webp@0.3.0
  485. webpki-roots@0.25.4
  486. weezl@0.1.8
  487. winapi@0.2.8
  488. winapi@0.3.9
  489. winapi-build@0.1.1
  490. winapi-i686-pc-windows-gnu@0.4.0
  491. winapi-util@0.1.8
  492. winapi-x86_64-pc-windows-gnu@0.4.0
  493. windows-core@0.52.0
  494. windows-sys@0.48.0
  495. windows-sys@0.52.0
  496. windows-targets@0.48.5
  497. windows-targets@0.52.5
  498. windows_aarch64_gnullvm@0.48.5
  499. windows_aarch64_gnullvm@0.52.5
  500. windows_aarch64_msvc@0.48.5
  501. windows_aarch64_msvc@0.52.5
  502. windows_i686_gnu@0.48.5
  503. windows_i686_gnu@0.52.5
  504. windows_i686_gnullvm@0.52.5
  505. windows_i686_msvc@0.48.5
  506. windows_i686_msvc@0.52.5
  507. windows_x86_64_gnu@0.48.5
  508. windows_x86_64_gnu@0.52.5
  509. windows_x86_64_gnullvm@0.48.5
  510. windows_x86_64_gnullvm@0.52.5
  511. windows_x86_64_msvc@0.48.5
  512. windows_x86_64_msvc@0.52.5
  513. winnow@0.6.13
  514. winreg@0.50.0
  515. winres@0.1.12
  516. write16@1.0.0
  517. writeable@0.5.5
  518. ws@0.9.2
  519. ws2_32-sys@0.2.1
  520. wyz@0.5.1
  521. xattr@1.3.1
  522. yada@0.5.1
  523. yaml-rust@0.4.5
  524. yoke@0.7.4
  525. yoke-derive@0.7.4
  526. zerocopy@0.7.34
  527. zerocopy-derive@0.7.34
  528. zerofrom@0.1.4
  529. zerofrom-derive@0.1.4
  530. zerovec@0.10.2
  531. zerovec-derive@0.10.2
  532. zune-core@0.4.12
  533. zune-inflate@0.2.54
  534. zune-jpeg@0.4.11
  535. "
  536. inherit cargo edo shell-completion
  537. DESCRIPTION="A fast static site generator with everything built-in"
  538. HOMEPAGE="
  539. https://www.getzola.org/
  540. https://github.com/getzola/zola
  541. "
  542. SRC_URI="
  543. ${CARGO_CRATE_URIS}
  544. https://github.com/getzola/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
  545. "
  546. LICENSE="MIT"
  547. # Dependent crate licenses
  548. LICENSE+="
  549. Apache-2.0 BSD-2 BSD CC0-1.0 ISC MIT MPL-2.0 Unicode-DFS-2016 ZLIB
  550. "
  551. SLOT="0"
  552. KEYWORDS="amd64 ~x86"
  553. DEPEND="dev-libs/libsass"
  554. RDEPEND="${DEPEND}"
  555. QA_PRESTRIPPED="usr/bin/${PN}"
  556. src_install() {
  557. cargo_src_install
  558. local zola="${ED}/usr/bin/zola"
  559. edo "${zola}" completion bash | newbashcomp - "${PN}.bash"
  560. edo "${zola}" completion fish | newfishcomp - "${PN}.fish"
  561. edo "${zola}" completion zsh | newzshcomp - "_${PN}"
  562. }