123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573 |
- # Copyright 2023-2024 Gentoo Authors
- # Distributed under the terms of the GNU General Public License v2
- EAPI=8
- # internal crates are located in `components/`
- CRATES="
- addr2line@0.22.0
- adler@1.0.2
- ahash@0.7.8
- ahash@0.8.11
- aho-corasick@0.7.20
- aho-corasick@1.1.3
- aligned-vec@0.5.0
- ammonia@4.0.0
- android-tzdata@0.1.1
- android_system_properties@0.1.5
- anstream@0.6.14
- anstyle@1.0.7
- anstyle-parse@0.2.4
- anstyle-query@1.1.0
- anstyle-wincon@3.0.3
- any_ascii@0.1.7
- anyhow@1.0.86
- arbitrary@1.3.2
- arg_enum_proc_macro@0.3.4
- arrayvec@0.7.4
- assert-json-diff@2.0.2
- atty@0.2.14
- autocfg@1.3.0
- av1-grain@0.2.3
- avif-serialize@0.8.1
- backtrace@0.3.73
- base64@0.21.7
- base64@0.22.1
- base64-simd@0.7.0
- bincode@1.3.3
- bit_field@0.10.2
- bitflags@1.3.2
- bitflags@2.5.0
- bitstream-io@2.4.1
- bitvec@1.0.1
- block-buffer@0.7.3
- block-buffer@0.10.4
- block-padding@0.1.5
- bstr@1.9.1
- build_const@0.2.2
- built@0.7.3
- bumpalo@3.16.0
- byte-tools@0.3.1
- bytecheck@0.6.12
- bytecheck_derive@0.6.12
- bytecount@0.6.8
- bytemuck@1.16.0
- byteorder@1.5.0
- byteorder-lite@0.1.0
- bytes@0.4.12
- bytes@1.6.0
- cc@1.0.99
- cedarwood@0.4.6
- cfg-expr@0.15.8
- cfg-if@0.1.10
- cfg-if@1.0.0
- cfg_aliases@0.1.1
- chrono@0.4.38
- chrono-tz@0.9.0
- chrono-tz-build@0.3.0
- clap@3.2.25
- clap@4.5.7
- clap_builder@4.5.7
- clap_complete@4.5.5
- clap_derive@3.2.25
- clap_derive@4.5.5
- clap_lex@0.2.4
- clap_lex@0.7.1
- codemap@0.1.3
- color_quant@1.1.0
- colorchoice@1.0.1
- colored@2.1.0
- console@0.15.8
- const-str@0.3.2
- const-str-proc-macro@0.3.2
- core-foundation@0.9.4
- core-foundation-sys@0.8.6
- cpufeatures@0.2.12
- crc@1.8.1
- crc32fast@1.4.2
- crossbeam-channel@0.5.13
- crossbeam-deque@0.8.5
- crossbeam-epoch@0.9.18
- crossbeam-utils@0.8.20
- crunchy@0.2.2
- crypto-common@0.1.6
- cssparser@0.33.0
- cssparser-color@0.1.0
- cssparser-macros@0.6.1
- csv@1.3.0
- csv-core@0.1.11
- ctrlc@3.4.4
- dashmap@5.5.3
- data-encoding@2.6.0
- data-url@0.1.1
- deranged@0.3.11
- deunicode@1.6.0
- digest@0.8.1
- digest@0.10.7
- displaydoc@0.2.4
- doc-comment@0.3.3
- dtoa@1.0.9
- dtoa-short@0.3.5
- either@1.12.0
- elasticlunr-rs@3.0.2
- encode_unicode@0.3.6
- encoding@0.2.33
- encoding-index-japanese@1.20141219.5
- encoding-index-korean@1.20141219.5
- encoding-index-simpchinese@1.20141219.5
- encoding-index-singlebyte@1.20141219.5
- encoding-index-tradchinese@1.20141219.5
- encoding_index_tests@0.1.4
- encoding_rs@0.8.34
- env_logger@0.9.3
- equivalent@1.0.1
- errno@0.3.9
- exr@1.72.0
- fake-simd@0.1.2
- fastrand@2.1.0
- fdeflate@0.3.4
- file-id@0.2.1
- filetime@0.2.23
- flate2@1.0.30
- flume@0.11.0
- fnv@1.0.7
- foreign-types@0.3.2
- foreign-types-shared@0.1.1
- form_urlencoded@1.2.1
- fsevent-sys@4.1.0
- fuchsia-zircon@0.3.3
- fuchsia-zircon-sys@0.3.3
- funty@2.0.0
- futf@0.1.5
- futures-channel@0.3.30
- futures-core@0.3.30
- futures-io@0.3.30
- futures-sink@0.3.30
- futures-task@0.3.30
- futures-util@0.3.30
- fxhash@0.2.1
- generic-array@0.12.4
- generic-array@0.14.7
- getrandom@0.1.16
- getrandom@0.2.15
- gh-emoji@1.0.8
- gif@0.13.1
- gimli@0.29.0
- glob@0.3.1
- globset@0.4.14
- globwalk@0.9.1
- grass@0.13.3
- grass_compiler@0.13.3
- h2@0.3.26
- half@2.4.1
- hashbrown@0.12.3
- hashbrown@0.13.2
- hashbrown@0.14.5
- heck@0.4.1
- heck@0.5.0
- hermit-abi@0.1.19
- html5ever@0.27.0
- http@0.2.12
- http-body@0.4.6
- httparse@1.9.3
- httpdate@1.0.3
- humansize@2.1.3
- humantime@2.1.0
- hyper@0.14.29
- hyper-rustls@0.24.2
- hyper-tls@0.5.0
- iana-time-zone@0.1.60
- iana-time-zone-haiku@0.1.2
- icu_collections@1.5.0
- icu_locid@1.5.0
- icu_locid_transform@1.5.0
- icu_locid_transform_data@1.5.0
- icu_normalizer@1.5.0
- icu_normalizer_data@1.5.0
- icu_properties@1.5.0
- icu_properties_data@1.5.0
- icu_provider@1.5.0
- icu_provider_macros@1.5.0
- idna@1.0.0
- ignore@0.4.22
- image@0.25.1
- image-webp@0.1.2
- imgref@1.10.1
- indexmap@1.9.3
- indexmap@2.2.6
- inotify@0.9.6
- inotify-sys@0.1.5
- insta@1.39.0
- interpolate_name@0.2.4
- iovec@0.1.4
- ipnet@2.9.0
- is-docker@0.2.0
- is-wsl@0.4.0
- is_terminal_polyfill@1.70.0
- itertools@0.10.5
- itertools@0.12.1
- itoa@1.0.11
- jieba-rs@0.6.8
- jobserver@0.1.31
- jpeg-decoder@0.3.1
- js-sys@0.3.69
- kamadak-exif@0.5.5
- kernel32-sys@0.2.2
- kqueue@1.0.8
- kqueue-sys@1.0.4
- lasso@0.7.2
- lazy_static@1.4.0
- lazycell@1.3.0
- lebe@0.5.2
- lexical-sort@0.3.1
- libc@0.2.155
- libfuzzer-sys@0.4.7
- libm@0.2.8
- libwebp-sys@0.9.5
- lightningcss@1.0.0-alpha.57
- lindera@0.14.0
- lindera-cc-cedict-builder@0.13.5
- lindera-core@0.13.5
- lindera-decompress@0.13.5
- lindera-dictionary@0.13.5
- lindera-ipadic@0.13.5
- lindera-ipadic-builder@0.13.5
- lindera-ko-dic-builder@0.13.5
- lindera-unidic-builder@0.13.5
- line-wrap@0.2.0
- linked-hash-map@0.5.6
- linux-raw-sys@0.4.14
- litemap@0.7.3
- lock_api@0.4.12
- log@0.4.21
- loop9@0.1.5
- lzma-rs@0.2.0
- mac@0.1.1
- maplit@1.0.2
- markup5ever@0.12.1
- matches@0.1.10
- maybe-rayon@0.1.1
- memchr@2.7.4
- mime@0.3.17
- mime_guess@2.0.4
- minidom@0.12.0
- minify-html@0.15.0
- minify-html-common@0.0.2
- minify-js@0.5.6
- minimal-lexical@0.2.1
- miniz_oxide@0.7.3
- mio@0.6.23
- mio@0.8.11
- mio-extras@2.0.6
- miow@0.2.2
- mockito@0.31.1
- mutate_once@0.1.1
- native-tls@0.2.12
- net2@0.2.39
- new_debug_unreachable@1.0.6
- nix@0.28.0
- nom@7.1.3
- nom-bibtex@0.5.0
- nom-tracable@0.9.1
- nom-tracable-macros@0.9.1
- nom_locate@4.2.0
- noop_proc_macro@0.3.0
- notify@6.1.1
- notify-debouncer-full@0.3.1
- num-bigint@0.4.5
- num-conv@0.1.0
- num-derive@0.4.2
- num-format@0.4.4
- num-integer@0.1.46
- num-rational@0.4.2
- num-traits@0.2.19
- num_threads@0.1.7
- object@0.36.0
- once_cell@1.19.0
- onig@6.4.0
- onig_sys@69.8.1
- opaque-debug@0.2.3
- open@5.1.4
- openssl@0.10.64
- openssl-macros@0.1.1
- openssl-probe@0.1.5
- openssl-sys@0.9.102
- os_str_bytes@6.6.1
- outref@0.1.0
- parcel_selectors@0.26.5
- parcel_sourcemap@2.1.1
- parking_lot@0.12.3
- parking_lot_core@0.9.10
- parse-js@0.17.0
- parse-zoneinfo@0.3.1
- paste@1.0.15
- path-slash@0.2.1
- pathdiff@0.2.1
- percent-encoding@2.3.1
- pest@2.7.10
- pest_derive@2.7.10
- pest_generator@2.7.10
- pest_meta@2.7.10
- phf@0.10.1
- phf@0.11.2
- phf_codegen@0.10.0
- phf_codegen@0.11.2
- phf_generator@0.10.0
- phf_generator@0.11.2
- phf_macros@0.11.2
- phf_shared@0.10.0
- phf_shared@0.11.2
- pin-project-lite@0.2.14
- pin-utils@0.1.0
- pkg-config@0.3.30
- plist@1.6.1
- png@0.17.13
- powerfmt@0.2.0
- ppv-lite86@0.2.17
- precomputed-hash@0.1.1
- proc-macro-error@1.0.4
- proc-macro-error-attr@1.0.4
- proc-macro2@1.0.85
- profiling@1.0.15
- profiling-procmacros@1.0.15
- ptr_meta@0.1.4
- ptr_meta_derive@0.1.4
- pulldown-cmark@0.11.0
- pulldown-cmark-escape@0.11.0
- pure-rust-locales@0.8.1
- qoi@0.4.1
- quick-error@2.0.1
- quick-xml@0.17.2
- quick-xml@0.31.0
- quickxml_to_serde@0.6.0
- quote@1.0.36
- radium@0.7.0
- rand@0.7.3
- rand@0.8.5
- rand_chacha@0.2.2
- rand_chacha@0.3.1
- rand_core@0.5.1
- rand_core@0.6.4
- rand_hc@0.2.0
- rav1e@0.7.1
- ravif@0.11.7
- rayon@1.10.0
- rayon-core@1.12.1
- redox_syscall@0.4.1
- redox_syscall@0.5.2
- regex@1.10.5
- regex-automata@0.4.7
- regex-syntax@0.8.4
- relative-path@1.9.3
- rend@0.4.2
- reqwest@0.11.27
- rgb@0.8.37
- ring@0.17.8
- rkyv@0.7.44
- rkyv_derive@0.7.44
- roxmltree@0.20.0
- rust-stemmers@1.2.0
- rustc-demangle@0.1.24
- rustc-hash@1.1.0
- rustix@0.38.34
- rustls@0.21.12
- rustls-pemfile@1.0.4
- rustls-webpki@0.101.7
- ryu@1.0.18
- same-file@1.0.6
- schannel@0.1.23
- scopeguard@1.2.0
- sct@0.7.1
- seahash@4.1.0
- security-framework@2.11.0
- security-framework-sys@2.11.0
- serde@1.0.203
- serde_derive@1.0.203
- serde_json@1.0.117
- serde_spanned@0.6.6
- serde_urlencoded@0.7.1
- serde_yaml@0.9.34+deprecated
- sha-1@0.8.2
- sha2@0.10.8
- simd-abstraction@0.7.1
- simd-adler32@0.3.7
- simd_helpers@0.1.0
- simdutf8@0.1.4
- similar@2.5.0
- siphasher@0.3.11
- slab@0.4.9
- slug@0.1.5
- smallvec@1.13.2
- socket2@0.5.7
- spin@0.9.8
- stable_deref_trait@1.2.0
- string_cache@0.8.7
- string_cache_codegen@0.5.2
- strsim@0.10.0
- strsim@0.11.1
- svg_metadata@0.5.1
- syn@1.0.109
- syn@2.0.66
- sync_wrapper@0.1.2
- synstructure@0.13.1
- syntect@5.2.0
- system-configuration@0.5.1
- system-configuration-sys@0.5.0
- system-deps@6.2.2
- tap@1.0.1
- tar@0.4.41
- target-lexicon@0.12.14
- tempfile@3.10.1
- tendril@0.4.3
- tera@1.20.0
- termcolor@1.4.1
- test-case@3.3.1
- test-case-core@3.3.1
- test-case-macros@3.3.1
- textwrap@0.16.1
- thiserror@1.0.61
- thiserror-impl@1.0.61
- tiff@0.9.1
- time@0.3.36
- time-core@0.1.2
- time-macros@0.2.18
- tinystr@0.7.6
- tinyvec@1.6.0
- tinyvec_macros@0.1.1
- tokio@1.38.0
- tokio-native-tls@0.3.1
- tokio-rustls@0.24.1
- tokio-util@0.7.11
- toml@0.5.11
- toml@0.8.14
- toml_datetime@0.6.6
- toml_edit@0.22.14
- tower-service@0.3.2
- tracing@0.1.40
- tracing-core@0.1.32
- try-lock@0.2.5
- typenum@1.17.0
- ucd-trie@0.1.6
- unic-char-property@0.9.0
- unic-char-range@0.9.0
- unic-common@0.9.0
- unic-langid@0.9.5
- unic-langid-impl@0.9.5
- unic-segment@0.9.0
- unic-ucd-segment@0.9.0
- unic-ucd-version@0.9.0
- unicase@2.7.0
- unicode-ident@1.0.12
- unicode-segmentation@1.11.0
- unsafe-libyaml@0.2.11
- untrusted@0.9.0
- url@2.5.1
- utf-8@0.7.6
- utf16_iter@1.0.5
- utf8_iter@1.0.4
- utf8parse@0.2.2
- uuid@1.8.0
- v_frame@0.3.8
- vcpkg@0.2.15
- version-compare@0.2.0
- version_check@0.9.4
- vlq@0.5.1
- walkdir@2.5.0
- want@0.3.1
- wasi@0.9.0+wasi-snapshot-preview1
- wasi@0.11.0+wasi-snapshot-preview1
- wasm-bindgen@0.2.92
- wasm-bindgen-backend@0.2.92
- wasm-bindgen-futures@0.4.42
- wasm-bindgen-macro@0.2.92
- wasm-bindgen-macro-support@0.2.92
- wasm-bindgen-shared@0.2.92
- web-sys@0.3.69
- webp@0.3.0
- webpki-roots@0.25.4
- weezl@0.1.8
- winapi@0.2.8
- winapi@0.3.9
- winapi-build@0.1.1
- winapi-i686-pc-windows-gnu@0.4.0
- winapi-util@0.1.8
- winapi-x86_64-pc-windows-gnu@0.4.0
- windows-core@0.52.0
- windows-sys@0.48.0
- windows-sys@0.52.0
- windows-targets@0.48.5
- windows-targets@0.52.5
- windows_aarch64_gnullvm@0.48.5
- windows_aarch64_gnullvm@0.52.5
- windows_aarch64_msvc@0.48.5
- windows_aarch64_msvc@0.52.5
- windows_i686_gnu@0.48.5
- windows_i686_gnu@0.52.5
- windows_i686_gnullvm@0.52.5
- windows_i686_msvc@0.48.5
- windows_i686_msvc@0.52.5
- windows_x86_64_gnu@0.48.5
- windows_x86_64_gnu@0.52.5
- windows_x86_64_gnullvm@0.48.5
- windows_x86_64_gnullvm@0.52.5
- windows_x86_64_msvc@0.48.5
- windows_x86_64_msvc@0.52.5
- winnow@0.6.13
- winreg@0.50.0
- winres@0.1.12
- write16@1.0.0
- writeable@0.5.5
- ws@0.9.2
- ws2_32-sys@0.2.1
- wyz@0.5.1
- xattr@1.3.1
- yada@0.5.1
- yaml-rust@0.4.5
- yoke@0.7.4
- yoke-derive@0.7.4
- zerocopy@0.7.34
- zerocopy-derive@0.7.34
- zerofrom@0.1.4
- zerofrom-derive@0.1.4
- zerovec@0.10.2
- zerovec-derive@0.10.2
- zune-core@0.4.12
- zune-inflate@0.2.54
- zune-jpeg@0.4.11
- "
- inherit cargo edo shell-completion
- DESCRIPTION="A fast static site generator with everything built-in"
- HOMEPAGE="
- https://www.getzola.org/
- https://github.com/getzola/zola
- "
- SRC_URI="
- ${CARGO_CRATE_URIS}
- https://github.com/getzola/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- "
- LICENSE="MIT"
- # Dependent crate licenses
- LICENSE+="
- Apache-2.0 BSD-2 BSD CC0-1.0 ISC MIT MPL-2.0 Unicode-DFS-2016 ZLIB
- "
- SLOT="0"
- KEYWORDS="amd64 ~x86"
- DEPEND="dev-libs/libsass"
- RDEPEND="${DEPEND}"
- QA_PRESTRIPPED="usr/bin/${PN}"
- src_install() {
- cargo_src_install
- local zola="${ED}/usr/bin/zola"
- edo "${zola}" completion bash | newbashcomp - "${PN}.bash"
- edo "${zola}" completion fish | newfishcomp - "${PN}.fish"
- edo "${zola}" completion zsh | newzshcomp - "_${PN}"
- }
|