buildozer.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424
  1. [app]
  2. # (str) Title of your application
  3. title = Triangle_KINO
  4. # (str) Package name
  5. package.name = KINO
  6. # (str) Package domain (needed for android/ios packaging)
  7. package.domain = org.test
  8. # (str) Source code where the main.py live
  9. source.dir = .
  10. # (list) Source files to include (let empty to include all the files)
  11. source.include_exts = py,png,jpg,kv,atlas
  12. # (list) List of inclusions using pattern matching
  13. #source.include_patterns = assets/*,images/*.png
  14. # (list) Source files to exclude (let empty to not exclude anything)
  15. #source.exclude_exts = spec
  16. # (list) List of directory to exclude (let empty to not exclude anything)
  17. #source.exclude_dirs = tests, bin, venv
  18. # (list) List of exclusions using pattern matching
  19. # Do not prefix with './'
  20. #source.exclude_patterns = license,images/*/*.jpg
  21. # (str) Application versioning (method 1)
  22. version = 0.1
  23. # (str) Application versioning (method 2)
  24. # version.regex = __version__ = ['"](.*)['"]
  25. # version.filename = %(source.dir)s/main.py
  26. # (list) Application requirements
  27. # comma separated e.g. requirements = sqlite3,kivy
  28. requirements = python3,kivy==master,kivymd,android.permissions
  29. # (str) Custom source folders for requirements
  30. # Sets custom source for any requirements with recipes
  31. # requirements.source.kivy = ../../kivy
  32. # (str) Presplash of the application
  33. #presplash.filename = %(source.dir)s/data/presplash.png
  34. # (str) Icon of the application
  35. #icon.filename = %(source.dir)s/data/icon.png
  36. # (str) Supported orientation (one of landscape, sensorLandscape, portrait or all)
  37. orientation = portrait
  38. # (list) List of service to declare
  39. #services = NAME:ENTRYPOINT_TO_PY,NAME2:ENTRYPOINT2_TO_PY
  40. #
  41. # OSX Specific
  42. #
  43. #
  44. # author = © Copyright Info
  45. # change the major version of python used by the app
  46. osx.python_version = 3
  47. # Kivy version to use
  48. osx.kivy_version = 1.9.1
  49. #
  50. # Android specific
  51. #
  52. # (bool) Indicate if the application should be fullscreen or not
  53. fullscreen = 0
  54. # (string) Presplash background color (for android toolchain)
  55. # Supported formats are: #RRGGBB #AARRGGBB or one of the following names:
  56. # red, blue, green, black, white, gray, cyan, magenta, yellow, lightgray,
  57. # darkgray, grey, lightgrey, darkgrey, aqua, fuchsia, lime, maroon, navy,
  58. # olive, purple, silver, teal.
  59. #android.presplash_color = #FFFFFF
  60. # (string) Presplash animation using Lottie format.
  61. # see https://lottiefiles.com/ for examples and https://airbnb.design/lottie/
  62. # for general documentation.
  63. # Lottie files can be created using various tools, like Adobe After Effect or Synfig.
  64. #android.presplash_lottie = "path/to/lottie/file.json"
  65. # (str) Adaptive icon of the application (used if Android API level is 26+ at runtime)
  66. #icon.adaptive_foreground.filename = %(source.dir)s/data/icon_fg.png
  67. #icon.adaptive_background.filename = %(source.dir)s/data/icon_bg.png
  68. # (list) Permissions
  69. android.permissions = INTERNET,ACCESS_NETWORK_STATE,ACCESS_WIFI_STATE,READ_EXTERNAL_STORAGE,WRITE_EXTERNAL_STORAGE
  70. # (list) features (adds uses-feature -tags to manifest)
  71. #android.features = android.hardware.usb.host
  72. # (int) Target Android API, should be as high as possible.
  73. #android.api = 27
  74. # (int) Minimum API your APK will support.
  75. #android.minapi = 21
  76. # (int) Android SDK version to use
  77. #android.sdk = 20
  78. # (str) Android NDK version to use
  79. #android.ndk = 19b
  80. # (int) Android NDK API to use. This is the minimum API your app will support, it should usually match android.minapi.
  81. #android.ndk_api = 21
  82. # (bool) Use --private data storage (True) or --dir public storage (False)
  83. #android.private_storage = True
  84. # (str) Android NDK directory (if empty, it will be automatically downloaded.)
  85. #android.ndk_path =
  86. # (str) Android SDK directory (if empty, it will be automatically downloaded.)
  87. #android.sdk_path =
  88. # (str) ANT directory (if empty, it will be automatically downloaded.)
  89. #android.ant_path =
  90. # (bool) If True, then skip trying to update the Android sdk
  91. # This can be useful to avoid excess Internet downloads or save time
  92. # when an update is due and you just want to test/build your package
  93. # android.skip_update = False
  94. # (bool) If True, then automatically accept SDK license
  95. # agreements. This is intended for automation only. If set to False,
  96. # the default, you will be shown the license when first running
  97. # buildozer.
  98. # android.accept_sdk_license = False
  99. # (str) Android entry point, default is ok for Kivy-based app
  100. #android.entrypoint = org.kivy.android.PythonActivity
  101. # (str) Full name including package path of the Java class that implements Android Activity
  102. # use that parameter together with android.entrypoint to set custom Java class instead of PythonActivity
  103. #android.activity_class_name = org.kivy.android.PythonActivity
  104. # (str) Extra xml to write directly inside the <manifest> element of AndroidManifest.xml
  105. # use that parameter to provide a filename from where to load your custom XML code
  106. #android.extra_manifest_xml = ./src/android/extra_manifest.xml
  107. # (str) Extra xml to write directly inside the <manifest><application> tag of AndroidManifest.xml
  108. # use that parameter to provide a filename from where to load your custom XML arguments:
  109. #android.extra_manifest_application_arguments = ./src/android/extra_manifest_application_arguments.xml
  110. # (str) Full name including package path of the Java class that implements Python Service
  111. # use that parameter to set custom Java class instead of PythonService
  112. #android.service_class_name = org.kivy.android.PythonService
  113. # (str) Android app theme, default is ok for Kivy-based app
  114. # android.apptheme = "@android:style/Theme.NoTitleBar"
  115. # (list) Pattern to whitelist for the whole project
  116. #android.whitelist =
  117. # (str) Path to a custom whitelist file
  118. #android.whitelist_src =
  119. # (str) Path to a custom blacklist file
  120. #android.blacklist_src =
  121. # (list) List of Java .jar files to add to the libs so that pyjnius can access
  122. # their classes. Don't add jars that you do not need, since extra jars can slow
  123. # down the build process. Allows wildcards matching, for example:
  124. # OUYA-ODK/libs/*.jar
  125. #android.add_jars = foo.jar,bar.jar,path/to/more/*.jar
  126. # (list) List of Java files to add to the android project (can be java or a
  127. # directory containing the files)
  128. #android.add_src =
  129. # (list) Android AAR archives to add
  130. #android.add_aars =
  131. # (list) Put these files or directories in the apk assets directory.
  132. # Either form may be used, and assets need not be in 'source.include_exts'.
  133. # 1) android.add_assets = source_asset_relative_path
  134. # 2) android.add_assets = source_asset_path:destination_asset_relative_path
  135. #android.add_assets =
  136. # (list) Gradle dependencies to add
  137. #android.gradle_dependencies =
  138. # (bool) Enable AndroidX support. Enable when 'android.gradle_dependencies'
  139. # contains an 'androidx' package, or any package from Kotlin source.
  140. # android.enable_androidx requires android.api >= 28
  141. #android.enable_androidx = False
  142. # (list) add java compile options
  143. # this can for example be necessary when importing certain java libraries using the 'android.gradle_dependencies' option
  144. # see https://developer.android.com/studio/write/java8-support for further information
  145. # android.add_compile_options = "sourceCompatibility = 1.8", "targetCompatibility = 1.8"
  146. # (list) Gradle repositories to add {can be necessary for some android.gradle_dependencies}
  147. # please enclose in double quotes
  148. # e.g. android.gradle_repositories = "maven { url 'https://kotlin.bintray.com/ktor' }"
  149. #android.add_gradle_repositories =
  150. # (list) packaging options to add
  151. # see https://google.github.io/android-gradle-dsl/current/com.android.build.gradle.internal.dsl.PackagingOptions.html
  152. # can be necessary to solve conflicts in gradle_dependencies
  153. # please enclose in double quotes
  154. # e.g. android.add_packaging_options = "exclude 'META-INF/common.kotlin_module'", "exclude 'META-INF/*.kotlin_module'"
  155. #android.add_packaging_options =
  156. # (list) Java classes to add as activities to the manifest.
  157. #android.add_activities = com.example.ExampleActivity
  158. # (str) OUYA Console category. Should be one of GAME or APP
  159. # If you leave this blank, OUYA support will not be enabled
  160. #android.ouya.category = GAME
  161. # (str) Filename of OUYA Console icon. It must be a 732x412 png image.
  162. #android.ouya.icon.filename = %(source.dir)s/data/ouya_icon.png
  163. # (str) XML file to include as an intent filters in <activity> tag
  164. #android.manifest.intent_filters =
  165. # (str) launchMode to set for the main activity
  166. #android.manifest.launch_mode = standard
  167. # (list) Android additional libraries to copy into libs/armeabi
  168. #android.add_libs_armeabi = libs/android/*.so
  169. #android.add_libs_armeabi_v7a = libs/android-v7/*.so
  170. #android.add_libs_arm64_v8a = libs/android-v8/*.so
  171. #android.add_libs_x86 = libs/android-x86/*.so
  172. #android.add_libs_mips = libs/android-mips/*.so
  173. # (bool) Indicate whether the screen should stay on
  174. # Don't forget to add the WAKE_LOCK permission if you set this to True
  175. #android.wakelock = False
  176. # (list) Android application meta-data to set (key=value format)
  177. #android.meta_data =
  178. # (list) Android library project to add (will be added in the
  179. # project.properties automatically.)
  180. #android.library_references =
  181. # (list) Android shared libraries which will be added to AndroidManifest.xml using <uses-library> tag
  182. #android.uses_library =
  183. # (str) Android logcat filters to use
  184. #android.logcat_filters = *:S python:D
  185. # (bool) Android logcat only display log for activity's pid
  186. #android.logcat_pid_only = False
  187. # (str) Android additional adb arguments
  188. #android.adb_args = -H host.docker.internal
  189. # (bool) Copy library instead of making a libpymodules.so
  190. #android.copy_libs = 1
  191. # (str) The Android arch to build for, choices: armeabi-v7a, arm64-v8a, x86, x86_64
  192. android.arch = armeabi-v7a
  193. # (int) overrides automatic versionCode computation (used in build.gradle)
  194. # this is not the same as app version and should only be edited if you know what you're doing
  195. # android.numeric_version = 1
  196. # (bool) enables Android auto backup feature (Android API >=23)
  197. android.allow_backup = True
  198. # (str) XML file for custom backup rules (see official auto backup documentation)
  199. # android.backup_rules =
  200. # (str) If you need to insert variables into your AndroidManifest.xml file,
  201. # you can do so with the manifestPlaceholders property.
  202. # This property takes a map of key-value pairs. (via a string)
  203. # Usage example : android.manifest_placeholders = [myCustomUrl:\"org.kivy.customurl\"]
  204. # android.manifest_placeholders = [:]
  205. # (bool) disables the compilation of py to pyc/pyo files when packaging
  206. # android.no-compile-pyo = True
  207. #
  208. # Python for android (p4a) specific
  209. #
  210. # (str) python-for-android URL to use for checkout
  211. #p4a.url =
  212. # (str) python-for-android fork to use in case if p4a.url is not specified, defaults to upstream (kivy)
  213. #p4a.fork = kivy
  214. # (str) python-for-android branch to use, defaults to master
  215. #p4a.branch = master
  216. # (str) python-for-android specific commit to use, defaults to HEAD, must be within p4a.branch
  217. #p4a.commit = HEAD
  218. # (str) python-for-android git clone directory (if empty, it will be automatically cloned from github)
  219. #p4a.source_dir =
  220. # (str) The directory in which python-for-android should look for your own build recipes (if any)
  221. #p4a.local_recipes =
  222. # (str) Filename to the hook for p4a
  223. #p4a.hook =
  224. # (str) Bootstrap to use for android builds
  225. # p4a.bootstrap = sdl2
  226. # (int) port number to specify an explicit --port= p4a argument (eg for bootstrap flask)
  227. #p4a.port =
  228. # Control passing the --use-setup-py vs --ignore-setup-py to p4a
  229. # "in the future" --use-setup-py is going to be the default behaviour in p4a, right now it is not
  230. # Setting this to false will pass --ignore-setup-py, true will pass --use-setup-py
  231. # NOTE: this is general setuptools integration, having pyproject.toml is enough, no need to generate
  232. # setup.py if you're using Poetry, but you need to add "toml" to source.include_exts.
  233. #p4a.setup_py = false
  234. # (str) extra command line arguments to pass when invoking pythonforandroid.toolchain
  235. #p4a.extra_args =
  236. #
  237. # iOS specific
  238. #
  239. # (str) Path to a custom kivy-ios folder
  240. #ios.kivy_ios_dir = ../kivy-ios
  241. # Alternately, specify the URL and branch of a git checkout:
  242. ios.kivy_ios_url = https://github.com/kivy/kivy-ios
  243. ios.kivy_ios_branch = master
  244. # Another platform dependency: ios-deploy
  245. # Uncomment to use a custom checkout
  246. #ios.ios_deploy_dir = ../ios_deploy
  247. # Or specify URL and branch
  248. ios.ios_deploy_url = https://github.com/phonegap/ios-deploy
  249. ios.ios_deploy_branch = 1.10.0
  250. # (bool) Whether or not to sign the code
  251. ios.codesign.allowed = false
  252. # (str) Name of the certificate to use for signing the debug version
  253. # Get a list of available identities: buildozer ios list_identities
  254. #ios.codesign.debug = "iPhone Developer: <lastname> <firstname> (<hexstring>)"
  255. # (str) The development team to use for signing the debug version
  256. #ios.codesign.development_team.debug = <hexstring>
  257. # (str) Name of the certificate to use for signing the release version
  258. #ios.codesign.release = %(ios.codesign.debug)s
  259. # (str) The development team to use for signing the release version
  260. #ios.codesign.development_team.release = <hexstring>
  261. # (str) URL pointing to .ipa file to be installed
  262. # This option should be defined along with `display_image_url` and `full_size_image_url` options.
  263. #ios.manifest.app_url =
  264. # (str) URL pointing to an icon (57x57px) to be displayed during download
  265. # This option should be defined along with `app_url` and `full_size_image_url` options.
  266. #ios.manifest.display_image_url =
  267. # (str) URL pointing to a large icon (512x512px) to be used by iTunes
  268. # This option should be defined along with `app_url` and `display_image_url` options.
  269. #ios.manifest.full_size_image_url =
  270. [buildozer]
  271. # (int) Log level (0 = error only, 1 = info, 2 = debug (with command output))
  272. log_level = 2
  273. # (int) Display warning if buildozer is run as root (0 = False, 1 = True)
  274. warn_on_root = 1
  275. # (str) Path to build artifact storage, absolute or relative to spec file
  276. # build_dir = ./.buildozer
  277. # (str) Path to build output (i.e. .apk, .ipa) storage
  278. # bin_dir = ./bin
  279. # -----------------------------------------------------------------------------
  280. # List as sections
  281. #
  282. # You can define all the "list" as [section:key].
  283. # Each line will be considered as a option to the list.
  284. # Let's take [app] / source.exclude_patterns.
  285. # Instead of doing:
  286. #
  287. #[app]
  288. #source.exclude_patterns = license,data/audio/*.wav,data/images/original/*
  289. #
  290. # This can be translated into:
  291. #
  292. #[app:source.exclude_patterns]
  293. #license
  294. #data/audio/*.wav
  295. #data/images/original/*
  296. #
  297. # -----------------------------------------------------------------------------
  298. # Profiles
  299. #
  300. # You can extend section / key with a profile
  301. # For example, you want to deploy a demo version of your application without
  302. # HD content. You could first change the title to add "(demo)" in the name
  303. # and extend the excluded directories to remove the HD content.
  304. #
  305. #[app@demo]
  306. #title = My Application (demo)
  307. #
  308. #[app:source.exclude_patterns@demo]
  309. #images/hd/*
  310. #
  311. # Then, invoke the command line with the "demo" profile:
  312. #
  313. #buildozer --profile demo android debug