pkgconf.SlackBuild 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143
  1. #!/bin/sh
  2. # Slackware build script for pkgconf
  3. # Copyright 2016-2021 Hunter Sezen California, USA
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=pkgconf
  23. VERSION=${VERSION:-1.7.4}
  24. BUILD=${BUILD:-1}
  25. TAG=${TAG:-_SBo}
  26. if [ -z "$ARCH" ]; then
  27. case "$( uname -m )" in
  28. i?86) ARCH=i586 ;;
  29. arm*) ARCH=arm ;;
  30. *) ARCH=$( uname -m ) ;;
  31. esac
  32. fi
  33. CWD=$(pwd)
  34. TMP=${TMP:-/tmp/SBo}
  35. PKG=$TMP/package-$PRGNAM
  36. OUTPUT=${OUTPUT:-/tmp}
  37. if [ "$ARCH" = "i586" ]; then
  38. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  39. LIBDIRSUFFIX=""
  40. elif [ "$ARCH" = "i686" ]; then
  41. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  42. LIBDIRSUFFIX=""
  43. elif [ "$ARCH" = "x86_64" ]; then
  44. SLKCFLAGS="-O2 -fPIC"
  45. LIBDIRSUFFIX="64"
  46. else
  47. SLKCFLAGS="-O2"
  48. LIBDIRSUFFIX=""
  49. fi
  50. set -eu
  51. rm -rf $PKG
  52. mkdir -p $TMP $PKG $OUTPUT
  53. cd $TMP
  54. rm -rf $PRGNAM-$VERSION
  55. tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
  56. cd $PRGNAM-$VERSION
  57. chown -R root:root .
  58. find -L . \
  59. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  60. -o -perm 511 \) -exec chmod 755 {} \; -o \
  61. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  62. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  63. [ "${DEBUG:=0}" = 0 ] ||
  64. SLKCFLAGS="$(printf %s "$SLKCFLAGS" | sed 's/-O2/-O0 -g/')"
  65. autoreconf -fi
  66. CFLAGS="$SLKCFLAGS" \
  67. CXXFLAGS="$SLKCFLAGS" \
  68. ./configure \
  69. --prefix=/usr \
  70. --libdir=/usr/lib${LIBDIRSUFFIX} \
  71. --mandir=/usr/man \
  72. --docdir=/usr/doc/$PRGNAM-$VERSION \
  73. --with-pkg-config-dir=/usr/local/lib${LIBDIRSUFFIX}/pkgconfig:/usr/local/share/pkgconfig:/usr/lib${LIBDIRSUFFIX}/pkgconfig:/usr/share/pkgconfig \
  74. --with-system-libdir=/usr/local/lib${LIBDIRSUFFIX}:/lib${LIBDIRSUFFIX}:/usr/lib${LIBDIRSUFFIX} \
  75. --disable-static \
  76. --build=$ARCH-slackware-linux
  77. make
  78. make install DESTDIR=$PKG
  79. ( cd $PKG/usr/bin; ln -sf $PRGNAM pkg-config )
  80. ( cd $PKG/usr/man/man1; ln -s $PRGNAM.1 pkg-config.1 )
  81. if [ "$ARCH" = x86_64 ]; then
  82. if [ -f /usr/lib/libgcc_s.so ]; then
  83. arch='i586 x86_64'
  84. else
  85. arch=x86_64
  86. fi
  87. else
  88. arch=i586
  89. fi
  90. platform=slackware-linux-gnu
  91. mkdir -p $PKG/usr/share/pkgconfig/personality.d
  92. # adapted from fedora and arch
  93. eval "set -- $arch"
  94. for i do
  95. case "$i" in
  96. i586) libdir= ;;
  97. x86_64) libdir=64 ;;
  98. esac
  99. sed -e "s|@TARGET_PLATFORM@|$i-$platform|" \
  100. -e "s|@PKGCONF_LIBDIRS@|/usr/local/lib$libdir/pkgconfig:/usr/local/share/pkgconfig:/usr/lib$libdir/pkgconfig:/usr/share/pkgconfig|" \
  101. -e "s|@PKGCONF_SYSLIBDIR@|/usr/local/lib$libdir:/lib$libdir:/usr/lib$libdir|" \
  102. -e "s|@PKGCONF_SYSINCDIR@|/usr/local/include:/usr/include|" \
  103. < $CWD/platform-pkg-config.in \
  104. > $PKG/usr/share/pkgconfig/personality.d/$i-$platform.personality
  105. ( cd $PKG/usr/bin; ln -s $PRGNAM $i-$platform-pkg-config )
  106. done
  107. if [ "$DEBUG" = 0 ]; then
  108. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
  109. grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  110. fi
  111. find $PKG/usr/man -type f -exec gzip -9 {} \;
  112. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  113. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  114. cp -a AUTHORS COPYING NEWS README.md $PKG/usr/doc/$PRGNAM-$VERSION
  115. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  116. mkdir -p $PKG/install
  117. cat $CWD/slack-desc > $PKG/install/slack-desc
  118. cd $PKG
  119. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}