guix.SlackBuild 4.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149
  1. #!/bin/sh
  2. # Slackware build script for Guix
  3. # Copyright 2015-2016 Hunter Sezen California, USA
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=guix
  23. VERSION=${VERSION:-0.12.0}
  24. BUILD=${BUILD:-1}
  25. TAG=${TAG:-_SBo}
  26. if [ -z "$ARCH" ]; then
  27. case "$( uname -m )" in
  28. i?86) ARCH=i586 ;;
  29. arm*) ARCH=arm ;;
  30. *) ARCH=$( uname -m ) ;;
  31. esac
  32. fi
  33. CWD=$(pwd)
  34. TMP=${TMP:-/tmp/SBo}
  35. PKG=$TMP/package-$PRGNAM
  36. OUTPUT=${OUTPUT:-/tmp}
  37. if [ "$ARCH" = "i586" ]; then
  38. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  39. LIBDIRSUFFIX=""
  40. elif [ "$ARCH" = "i686" ]; then
  41. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  42. LIBDIRSUFFIX=""
  43. elif [ "$ARCH" = "x86_64" ]; then
  44. SLKCFLAGS="-O2 -fPIC"
  45. LIBDIRSUFFIX="64"
  46. else
  47. SLKCFLAGS="-O2"
  48. LIBDIRSUFFIX=""
  49. fi
  50. set -e
  51. rm -rf $PKG
  52. mkdir -p $TMP $PKG $OUTPUT
  53. cd $TMP
  54. rm -rf $PRGNAM-$VERSION
  55. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  56. cd $PRGNAM-$VERSION
  57. for bin in armhf i686 mips64el x86_64; do
  58. case "$bin" in
  59. armhf ) GVERS=2.0.11 ;;
  60. * ) GVERS=2.0.9 ;;
  61. esac
  62. if [ -f $CWD/guile_${bin}_linux-${GVERS}.tar.xz ]; then
  63. cp $CWD/guile_${bin}_linux-${GVERS}.tar.xz \
  64. gnu/packages/bootstrap/${bin}-linux/guile-${GVERS}.tar.xz
  65. fi
  66. done
  67. chown -R root:root .
  68. find -L . \
  69. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  70. -o -perm 511 \) -exec chmod 755 {} \; -o \
  71. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  72. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  73. # To share the store with nix
  74. SHARE=${SHARE:-no}
  75. if [ "${SHARE:-yes}" = "yes" ]; then
  76. share="--with-store-dir=/nix/store"
  77. var="--localstatedir=/nix/var"
  78. else
  79. var="--localstatedir=/var"
  80. fi
  81. # To use the nix-daemon instead of the guix-daemon
  82. NIX=${NIX:-no}
  83. if [ "${NIX:-yes}" = "yes" ]; then
  84. nix="--disable-daemon"
  85. else
  86. nix=""
  87. fi
  88. # import: crate: Do not build when guile-json is not available.
  89. # http://git.savannah.gnu.org/cgit/guix.git/commit/?id=6023041346c79f7ac4105bba2552a82019fae840
  90. zcat $CWD/guile-json.patch.gz | patch -p1
  91. autoreconf -fi
  92. CFLAGS="$SLKCFLAGS" \
  93. CXXFLAGS="$SLKCFLAGS" \
  94. ./configure \
  95. --prefix=/usr \
  96. --libdir=/usr/lib${LIBDIRSUFFIX} \
  97. --sysconfdir=/etc \
  98. --infodir=/usr/info \
  99. --mandir=/usr/man \
  100. --disable-rpath \
  101. --build=$ARCH-slackware-linux \
  102. --host=$ARCH-slackware-linux \
  103. $nix \
  104. $share \
  105. $var
  106. make
  107. make install DESTDIR=$PKG
  108. install -D --mode 0755 $CWD/config/rc.guix $PKG/etc/rc.d/rc.guix.new
  109. mkdir -p $PKG/gnu
  110. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
  111. grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  112. find $PKG/usr/man -type f -exec gzip -9 {} \;
  113. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  114. rm -f $PKG/usr/info/dir
  115. gzip -9 $PKG/usr/info/*.info*
  116. for i in systemd upstart; do rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/$i; done
  117. DOCS="ABOUT-NLS AUTHORS CODE-OF-CONDUCT COPYING HACKING INSTALL NEWS README \
  118. ROADMAP THANKS TODO"
  119. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  120. cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
  121. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  122. mkdir -p $PKG/install
  123. cat $CWD/slack-desc > $PKG/install/slack-desc
  124. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  125. cd $PKG
  126. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}