xpad-dkms.SlackBuild 2.7 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091
  1. #!/bin/sh
  2. # Slackware build script for xpad-dkms
  3. # Copyright 2016, 2018 orbea
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=xpad-dkms
  23. SRCNAM=${PRGNAM%%-*}
  24. BRANCH=${BRANCH:-master}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_git}
  27. if [ -z "$ARCH" ]; then
  28. case "$( uname -m )" in
  29. i?86) ARCH=i586 ;;
  30. arm*) ARCH=arm ;;
  31. *) ARCH=$( uname -m ) ;;
  32. esac
  33. fi
  34. CWD=$(pwd)
  35. TMP=${TMP:-/tmp/SBo}
  36. PKG=$TMP/package-$PRGNAM
  37. OUTPUT=${OUTPUT:-/tmp}
  38. set -eu
  39. rm -rf $PKG
  40. mkdir -p $TMP $PKG $OUTPUT
  41. cd $TMP
  42. rm -rf $PRGNAM
  43. git clone --depth=1 -b $BRANCH https://github.com/paroj/$SRCNAM $PRGNAM
  44. cd $PRGNAM
  45. [ "${COMMIT:=}" ] && git fetch --unshallow --tags && git checkout "$COMMIT"
  46. HEAD="$(git rev-parse --short HEAD)"
  47. DATE="$(git show -s --format=%cd --date=format:%Y.%m.%d)"
  48. chown -R root:root .
  49. find -L . \
  50. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  51. -o -perm 511 \) -exec chmod 755 {} \; -o \
  52. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  53. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  54. KERNEL=${KERNEL:-$(uname -r)}
  55. VERSION="$(printf %s ${DATE}_${HEAD}_$KERNEL | tr - _)"
  56. make KVERSION="$KERNEL"
  57. install -Dm0644 $SRCNAM.ko \
  58. $PKG/lib/modules/$KERNEL/extra/$SRCNAM.ko
  59. # Write a depmod conf
  60. mkdir -p $PKG/etc/depmod.d
  61. cat > $PKG/etc/depmod.d/$PRGNAM-$KERNEL.conf <<EOF
  62. override $SRCNAM $KERNEL extra
  63. EOF
  64. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  65. cp -a README.md $PKG/usr/doc/$PRGNAM-$VERSION
  66. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  67. mkdir -p $PKG/install
  68. cat $CWD/slack-desc > $PKG/install/slack-desc
  69. cat > $PKG/install/doinst.sh <<EOF
  70. if [ -x /sbin/depmod ]; then
  71. chroot . /sbin/depmod -a $KERNEL 1> /dev/null 2> /dev/null
  72. fi
  73. EOF
  74. cd $PKG
  75. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-${VERSION}_$BRANCH-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}