mpv.SlackBuild 3.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105
  1. #!/bin/sh
  2. # Slackware build script for mpv
  3. # Copyright 2015 John Vogel Corning, NY USA
  4. # Copyright 2015-2018, 2020 orbea
  5. # All rights reserved.
  6. #
  7. # Redistribution and use of this script, with or without modification, is
  8. # permitted provided that the following conditions are met:
  9. #
  10. # 1. Redistributions of this script must retain the above copyright
  11. # notice, this list of conditions and the following disclaimer.
  12. #
  13. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  14. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  15. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  16. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  17. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  18. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  19. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  20. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  21. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  22. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE
  23. PRGNAM=mpv
  24. BRANCH=${BRANCH:-master}
  25. WAFBRN=${WAFBRN:-master}
  26. BUILD=${BUILD:-1}
  27. TAG=${TAG:-_git}
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) ARCH=i586 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. CWD=$(pwd)
  36. TMP=${TMP:-/tmp/SBo}
  37. PKG=$TMP/package-$PRGNAM
  38. OUTPUT=${OUTPUT:-/tmp}
  39. LIBDIRSUFFIX=
  40. [ "$ARCH" != x86_64 ] || LIBDIRSUFFIX=64
  41. set -eu
  42. rm -rf $PKG
  43. mkdir -p $TMP $PKG $OUTPUT
  44. cd $TMP
  45. rm -rf $PRGNAM
  46. git clone --depth=1 -b $BRANCH https://github.com/$PRGNAM-player/$PRGNAM
  47. cd $PRGNAM
  48. [ "${COMMIT:=}" ] && git fetch --unshallow --tags && git checkout "$COMMIT"
  49. HEAD="$(git rev-parse --short HEAD)"
  50. DATE="$(git show -s --format=%cd --date=format:%Y.%m.%d)"
  51. VERSION="${DATE}_$HEAD"
  52. git clone --depth=1 -b $WAFBRN https://gitlab.com/ita1024/waf.git
  53. [ -z "${WAFCOM:=}" ] || ( cd waf; git fetch --unshallow --tags && git checkout "$WAFCOM" )
  54. chown -R root:root .
  55. find -L . \
  56. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  57. -o -perm 511 \) -exec chmod 755 {} \; -o \
  58. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  59. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  60. ( cd waf; python3 ./waf-light configure build )
  61. python3 ./waf/waf configure build install \
  62. --enable-libmpv-shared \
  63. ${BUILD_OPTS:-} \
  64. --prefix=/usr \
  65. --bindir=/usr/bin \
  66. --libdir=/usr/lib${LIBDIRSUFFIX} \
  67. --mandir=/usr/man \
  68. --docdir=/usr/doc/$PRGNAM-$VERSION \
  69. --confdir=/etc/$PRGNAM \
  70. --disable-build-date \
  71. --disable-optimize \
  72. --destdir=$PKG
  73. for f in $PKG/etc/$PRGNAM/*.conf; do
  74. mv -- "$f" "$f.new"
  75. done
  76. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
  77. grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  78. find $PKG/usr/man -type f -exec gzip -9 {} \;
  79. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  80. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/manual
  81. cp -a Copyright LICENSE* README.md $PKG/usr/doc/$PRGNAM-$VERSION
  82. cp -a DOCS/*.md DOCS/*.rst DOCS/*.txt $PKG/usr/doc/$PRGNAM-$VERSION/manual
  83. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  84. mkdir -p $PKG/install
  85. cat $CWD/slack-desc > $PKG/install/slack-desc
  86. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  87. cd $PKG
  88. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-${VERSION}_$BRANCH-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}