mupen64plus.SlackBuild 4.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166
  1. #!/bin/sh
  2. # Slackware build script for mupen64plus
  3. # Copyright 2016-2020 orbea
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=mupen64plus
  23. BRANCH=${BRANCH:-master}
  24. BUILD=${BUILD:-1}
  25. TAG=${TAG:-_git}
  26. if [ -z "$ARCH" ]; then
  27. case "$( uname -m )" in
  28. i?86) ARCH=i586 ;;
  29. arm*) ARCH=arm ;;
  30. *) ARCH=$( uname -m ) ;;
  31. esac
  32. fi
  33. CWD=$(pwd)
  34. TMP=${TMP:-/tmp/SBo}
  35. PKG=$TMP/package-$PRGNAM
  36. OUTPUT=${OUTPUT:-/tmp}
  37. if [ "$ARCH" = "i586" ]; then
  38. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  39. LIBDIRSUFFIX=""
  40. elif [ "$ARCH" = "i686" ]; then
  41. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  42. LIBDIRSUFFIX=""
  43. elif [ "$ARCH" = "x86_64" ]; then
  44. SLKCFLAGS="-O2"
  45. LIBDIRSUFFIX="64"
  46. else
  47. SLKCFLAGS="-O2"
  48. LIBDIRSUFFIX=""
  49. fi
  50. set -eu
  51. UI_PYTHON='ui-python'
  52. python -c 'import PyQt5' 2>/dev/null || UI_PYTHON=
  53. PLUGINS="core \
  54. audio-sdl \
  55. input-sdl \
  56. rsp-cxd4 \
  57. rsp-hle \
  58. rsp-z64 \
  59. ui-console \
  60. $UI_PYTHON \
  61. video-glide64 \
  62. video-glide64mk2 \
  63. video-rice \
  64. video-z64"
  65. rm -rf $TMP/$PRGNAM $PKG
  66. mkdir -p $TMP/$PRGNAM $PKG $OUTPUT
  67. cd $TMP/$PRGNAM
  68. eval "set -- $PLUGINS"
  69. for src do
  70. git clone --depth=1 -b $BRANCH https://github.com/$PRGNAM/$PRGNAM-$src
  71. (
  72. cd $PRGNAM-$src
  73. HEAD="$(git rev-parse --short HEAD)"
  74. DATE="$(git show -s --format=%cd --date=format:%Y.%m.%d)"
  75. printf %s\\n "${DATE}_$HEAD" 2>&1 | tee VERSION
  76. )
  77. done
  78. VERSION=$(cat $PRGNAM-core/VERSION)
  79. chown -R root:root .
  80. find -L . \
  81. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  82. -o -perm 511 \) -exec chmod 755 {} \; -o \
  83. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  84. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  85. if [ "${DEBUG:=0}" != 0 ]; then
  86. DEBUG=1
  87. SLKCFLAGS="$(printf %s "$SLKCFLAGS" | sed 's/-02/-O0/')"
  88. fi
  89. [ "${GLES:=0}" = 0 ] || GLES=1
  90. DOCS="AUTHORS \
  91. ChangeLog \
  92. COPYING \
  93. CREDITS \
  94. INSTALL \
  95. LICENSES \
  96. README.md \
  97. README \
  98. RELEASE \
  99. VERSION"
  100. eval "set -- $PLUGINS"
  101. for src do
  102. if [ "$src" = "$UI_PYTHON" ]; then
  103. (
  104. cd $PRGNAM-$src
  105. python setup.py install --root=$PKG \
  106. --install-scripts=/usr/games
  107. )
  108. else
  109. (
  110. cd $PRGNAM-$src/projects/unix
  111. make install \
  112. CC="${CC:-cc}" \
  113. CXX="${CXX:-c++}" \
  114. OPTFLAGS="$SLKCFLAGS" \
  115. PREFIX=/usr \
  116. APIDIR=$PKG/usr/include/$PRGNAM \
  117. BINDIR=/usr/games \
  118. LIBDIR=/usr/lib${LIBDIRSUFFIX} \
  119. MANDIR=/usr/man \
  120. SHAREDIR=/usr/share/games/$PRGNAM \
  121. DEBUG=$DEBUG \
  122. USE_GLES=$GLES \
  123. DESTDIR=$PKG
  124. )
  125. fi
  126. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM-$src
  127. eval "set -- $DOCS"
  128. for file do
  129. if [ -f $PRGNAM-$src/$file ]; then
  130. cp -a $PRGNAM-$src/$file $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM-$src
  131. fi
  132. done
  133. done
  134. if [ $DEBUG = 0 ]; then
  135. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
  136. grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  137. fi
  138. find $PKG/usr/man -type f -exec gzip -9 {} \;
  139. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  140. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  141. mkdir -p $PKG/install
  142. cat $CWD/slack-desc > $PKG/install/slack-desc
  143. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  144. cd $PKG
  145. /sbin/makepkg -l y -c n -p $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}