123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144 |
- #!/bin/sh
- # Slackware build script for nestopia
- # Copyright 2016, 2018-2019 orbea
- # All rights reserved.
- #
- # Redistribution and use of this script, with or without modification, is
- # permitted provided that the following conditions are met:
- #
- # 1. Redistributions of this script must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- #
- # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
- # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
- # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
- # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
- # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
- # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
- # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
- # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
- # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
- # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- PRGNAM=nestopia
- LIBNAM=${PRGNAM}_libretro
- BRANCH=${BRANCH:-master}
- BUILD=${BUILD:-1}
- TAG=${TAG:-_git}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- CWD=$(pwd)
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- fi
- set -eu
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $PRGNAM
- git clone --depth=1 -b $BRANCH https://github.com/0ldsk00l/$PRGNAM
- cd $PRGNAM
- HEAD="$(git rev-parse --short HEAD)"
- DATE="$(git show -s --format=%cd --date=format:%Y.%m.%d)"
- VERSION="${DATE}_$HEAD"
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- if [ "${DEBUG:=0}" != 0 ]; then
- DEBUG=1
- SLKCFLAGS="$(printf %s "$SLKCFLAGS" | sed 's/-O2/-O0 -g/')"
- fi
- if [ "${GUI:-0}" != 0 ]; then
- gui=enable
- else
- gui=disable
- fi
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- if [ -f /usr/share/aclocal/ax_am_macros.m4 ] && pkg-config --exists sdl2; then
- autoreconf -fi
- CFLAGS="$SLKCFLAGS" \
- CXXFLAGS="$SLKCFLAGS -std=c++98" \
- ./configure \
- --prefix=/usr \
- --bindir=/usr/games \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --datadir=/usr/share/games \
- --$gui-gui \
- --build=$ARCH-slackware-linux
- make
- make install DESTDIR=$PKG
- cat > $PKG/install/doinst.sh <<EOF
- if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
- fi
- if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
- fi
- fi
- EOF
- else
- install -Dm0644 NstDatabase.xml \
- $PKG/usr/share/games/$PRGNAM/NstDatabase.xml
- fi
- make -C libretro DEBUG=$DEBUG
- install -Dm0644 libretro/$LIBNAM.so \
- $PKG/usr/lib${LIBDIRSUFFIX}/libretro/$LIBNAM.so
- curl --create-dirs -o $PKG/usr/lib${LIBDIRSUFFIX}/libretro/info/$LIBNAM.info \
- https://raw.githubusercontent.com/libretro/libretro-super/master/dist/info/$LIBNAM.info
- find $PKG/usr/lib${LIBDIRSUFFIX}/libretro -mindepth 1 -type d -exec chmod 755 {} \;
- if [ $DEBUG = 0 ]; then
- find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
- grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- fi
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a AUTHORS COPYING ChangeLog README.md $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-${VERSION}_$BRANCH-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|