nestopia.SlackBuild 4.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144
  1. #!/bin/sh
  2. # Slackware build script for nestopia
  3. # Copyright 2016, 2018-2019 orbea
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=nestopia
  23. LIBNAM=${PRGNAM}_libretro
  24. BRANCH=${BRANCH:-master}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_git}
  27. if [ -z "$ARCH" ]; then
  28. case "$( uname -m )" in
  29. i?86) ARCH=i586 ;;
  30. arm*) ARCH=arm ;;
  31. *) ARCH=$( uname -m ) ;;
  32. esac
  33. fi
  34. CWD=$(pwd)
  35. TMP=${TMP:-/tmp/SBo}
  36. PKG=$TMP/package-$PRGNAM
  37. OUTPUT=${OUTPUT:-/tmp}
  38. if [ "$ARCH" = "i586" ]; then
  39. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  40. LIBDIRSUFFIX=""
  41. elif [ "$ARCH" = "i686" ]; then
  42. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  43. LIBDIRSUFFIX=""
  44. elif [ "$ARCH" = "x86_64" ]; then
  45. SLKCFLAGS="-O2 -fPIC"
  46. LIBDIRSUFFIX="64"
  47. else
  48. SLKCFLAGS="-O2"
  49. LIBDIRSUFFIX=""
  50. fi
  51. set -eu
  52. rm -rf $PKG
  53. mkdir -p $TMP $PKG $OUTPUT
  54. cd $TMP
  55. rm -rf $PRGNAM
  56. git clone --depth=1 -b $BRANCH https://github.com/0ldsk00l/$PRGNAM
  57. cd $PRGNAM
  58. HEAD="$(git rev-parse --short HEAD)"
  59. DATE="$(git show -s --format=%cd --date=format:%Y.%m.%d)"
  60. VERSION="${DATE}_$HEAD"
  61. chown -R root:root .
  62. find -L . \
  63. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  64. -o -perm 511 \) -exec chmod 755 {} \; -o \
  65. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  66. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  67. if [ "${DEBUG:=0}" != 0 ]; then
  68. DEBUG=1
  69. SLKCFLAGS="$(printf %s "$SLKCFLAGS" | sed 's/-O2/-O0 -g/')"
  70. fi
  71. if [ "${GUI:-0}" != 0 ]; then
  72. gui=enable
  73. else
  74. gui=disable
  75. fi
  76. mkdir -p $PKG/install
  77. cat $CWD/slack-desc > $PKG/install/slack-desc
  78. if [ -f /usr/share/aclocal/ax_am_macros.m4 ] && pkg-config --exists sdl2; then
  79. autoreconf -fi
  80. CFLAGS="$SLKCFLAGS" \
  81. CXXFLAGS="$SLKCFLAGS -std=c++98" \
  82. ./configure \
  83. --prefix=/usr \
  84. --bindir=/usr/games \
  85. --libdir=/usr/lib${LIBDIRSUFFIX} \
  86. --docdir=/usr/doc/$PRGNAM-$VERSION \
  87. --datadir=/usr/share/games \
  88. --$gui-gui \
  89. --build=$ARCH-slackware-linux
  90. make
  91. make install DESTDIR=$PKG
  92. cat > $PKG/install/doinst.sh <<EOF
  93. if [ -x /usr/bin/update-desktop-database ]; then
  94. /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
  95. fi
  96. if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
  97. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  98. /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
  99. fi
  100. fi
  101. EOF
  102. else
  103. install -Dm0644 NstDatabase.xml \
  104. $PKG/usr/share/games/$PRGNAM/NstDatabase.xml
  105. fi
  106. make -C libretro DEBUG=$DEBUG
  107. install -Dm0644 libretro/$LIBNAM.so \
  108. $PKG/usr/lib${LIBDIRSUFFIX}/libretro/$LIBNAM.so
  109. curl --create-dirs -o $PKG/usr/lib${LIBDIRSUFFIX}/libretro/info/$LIBNAM.info \
  110. https://raw.githubusercontent.com/libretro/libretro-super/master/dist/info/$LIBNAM.info
  111. find $PKG/usr/lib${LIBDIRSUFFIX}/libretro -mindepth 1 -type d -exec chmod 755 {} \;
  112. if [ $DEBUG = 0 ]; then
  113. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
  114. grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  115. fi
  116. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  117. cp -a AUTHORS COPYING ChangeLog README.md $PKG/usr/doc/$PRGNAM-$VERSION
  118. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  119. cd $PKG
  120. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-${VERSION}_$BRANCH-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}