RetroArch.SlackBuild 6.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192
  1. #!/bin/sh
  2. # Slackware build script for RetroArch
  3. # Copyright 2016-2020 orbea
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=RetroArch
  23. BRANCH=${BRANCH:-master}
  24. ASSETS=${ASSETS:-master}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_git}
  27. if [ -z "$ARCH" ]; then
  28. case "$( uname -m )" in
  29. i?86) ARCH=i586 ;;
  30. arm*) ARCH=arm ;;
  31. *) ARCH=$( uname -m ) ;;
  32. esac
  33. fi
  34. CWD=$(pwd)
  35. TMP=${TMP:-/tmp/SBo}
  36. PKG=$TMP/package-$PRGNAM
  37. OUTPUT=${OUTPUT:-/tmp}
  38. if [ "$ARCH" = "i586" ]; then
  39. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  40. LIBDIRSUFFIX=""
  41. elif [ "$ARCH" = "i686" ]; then
  42. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  43. LIBDIRSUFFIX=""
  44. elif [ "$ARCH" = "x86_64" ]; then
  45. SLKCFLAGS="-O2 -fPIC"
  46. LIBDIRSUFFIX="64"
  47. else
  48. SLKCFLAGS="-O2"
  49. LIBDIRSUFFIX=""
  50. fi
  51. set -eu
  52. rm -rf $PKG
  53. mkdir -p $TMP $PKG $OUTPUT
  54. cd $TMP
  55. rm -rf $PRGNAM
  56. git clone --depth=1 -b $BRANCH https://github.com/libretro/$PRGNAM
  57. cd $PRGNAM
  58. [ "${COMMIT:=}" ] && git fetch --unshallow --tags && git checkout "$COMMIT"
  59. HEAD="$(git rev-parse --short HEAD)"
  60. DATE="$(git show -s --format=%cd --date=format:%Y.%m.%d)"
  61. VERSION="${DATE}_$HEAD"
  62. git clone --depth=1 -b $ASSETS https://github.com/libretro/retroarch-assets media/assets
  63. chown -R root:root .
  64. find -L . \
  65. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  66. -o -perm 511 \) -exec chmod 755 {} \; -o \
  67. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  68. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  69. lib=
  70. if [ "${DEBUG:=0}" != 0 ]; then
  71. case "${ASAN:=}" in
  72. '' ) : ;;
  73. thread ) ASAN=thread ;;
  74. * ) ASAN=address ;;
  75. esac
  76. RELEASE=debug
  77. SLKCFLAGS="$(printf %s "$SLKCFLAGS" | sed 's/-O2/-O0 -g/')"
  78. lib="${lib} --enable-debug"
  79. else
  80. ASAN=
  81. RELEASE=release
  82. fi
  83. [ "${CDROM:-no}" != no ] || lib="${lib} --disable-cdrom"
  84. [ "${DISCORD:-no}" != no ] || lib="${lib} --disable-discord"
  85. [ "${OPENGL1:-no}" != no ] || lib="${lib} --disable-opengl1"
  86. if [ "${GLES:-0}" != 0 ]; then
  87. lib="${lib} --enable-opengles"
  88. elif [ "${GLES3:-0}" != 0 ]; then
  89. lib="${lib} --enable-opengles --enable-opengles3"
  90. fi
  91. pkg-config --exists flac && lib="${lib} --disable-builtinflac"
  92. pkg-config --exists zlib && lib="${lib} --disable-builtinzlib"
  93. [ -d /usr/include/mbedtls ] && lib="${lib} --disable-builtinmbedtls"
  94. [ -d /usr/include/miniupnpc ] && lib="${lib} --disable-builtinminiupnpc"
  95. [ "${MENU:-yes}" != yes ] && lib="${lib} --disable-menu"
  96. [ "${PULSE:-yes}" != yes ] && lib="${lib} --disable-pulse"
  97. [ "${QT:-yes}" != yes ] && lib="${lib} --disable-qt"
  98. [ "${GLUI:-yes}" != yes ] && lib="${lib} --disable-materialui"
  99. [ "${OZONE:-yes}" != yes ] && lib="${lib} --disable-ozone"
  100. [ "${RGUI:-yes}" != yes ] && lib="${lib} --disable-rgui"
  101. [ "${XMB:-yes}" != yes ] && lib="${lib} --disable-xmb"
  102. # Disable downloading cores with the online updater
  103. # https://github.com/libretro/RetroArch/issues/3237
  104. SED_CORE=; SED_INFO=; SED_MENU=
  105. if [ "${BUILDBOT:-0}" = 0 ]; then
  106. libdir="/usr/lib${LIBDIRSUFFIX}/libretro"
  107. infodir="${libdir}/info"
  108. SED_CORE="s|# libretro_directory =|libretro_directory = $libdir|"
  109. SED_INFO="s|# libretro_info_path =|libretro_info_path = $infodir|"
  110. SED_MENU='s|# menu_show_core_updater = true|menu_show_core_updater = false|'
  111. fi
  112. filter_dir="/usr/lib${LIBDIRSUFFIX}/retroarch/filters"
  113. # Set the default directories to be consistent with the installation.
  114. sed -e "s|# audio_filter_dir =|audio_filter_dir = ${filter_dir}/audio|" \
  115. -e "s|# video_filter_dir =|video_filter_dir = ${filter_dir}/video|" \
  116. -e "$SED_CORE;$SED_INFO;$SED_MENU" \
  117. -i retroarch.cfg
  118. # Set $lib to a portable array
  119. eval "set -- $lib"
  120. CFLAGS="$SLKCFLAGS" \
  121. CXXFLAGS="$SLKCFLAGS" \
  122. ./configure \
  123. --prefix=/usr \
  124. --bindir=/usr/games \
  125. --mandir=/usr/man \
  126. --docdir=/usr/doc/$PRGNAM-$VERSION \
  127. --with-assets_dir=/usr/share/games \
  128. --disable-update_assets \
  129. --build=$ARCH-slackware-linux \
  130. "$@"
  131. make SANITIZER=$ASAN
  132. make install DESTDIR=$PKG
  133. for filter in audio video; do
  134. case $filter in
  135. audio )
  136. EXT=dsp
  137. DIR="libretro-common/$filter/dsp_filters"
  138. ;;
  139. video )
  140. EXT=filt
  141. DIR="gfx/${filter}_filters"
  142. ;;
  143. esac
  144. ( cd $DIR ; make build=$RELEASE compiler="${CC:-cc}" )
  145. mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/retroarch/filters/$filter
  146. cp $DIR/*.$EXT $DIR/*.so $PKG/usr/lib${LIBDIRSUFFIX}/retroarch/filters/$filter
  147. chmod 0644 $PKG/usr/lib${LIBDIRSUFFIX}/retroarch/filters/$filter/*
  148. done
  149. mv $PKG/etc/retroarch.cfg $PKG/etc/retroarch.cfg.new
  150. if [ "$DEBUG" = 0 ]; then
  151. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
  152. grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  153. fi
  154. find $PKG/usr/man -type f -exec gzip -9 {} \;
  155. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  156. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  157. cp -a CHANGES.md CONTRIBUTING.md README-* $PKG/usr/doc/$PRGNAM-$VERSION
  158. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  159. mkdir -p $PKG/install
  160. cat $CWD/slack-desc > $PKG/install/slack-desc
  161. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  162. cd $PKG
  163. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-${VERSION}_$BRANCH-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}