GLideN64.SlackBuild 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125
  1. #!/bin/sh
  2. # Slackware build script for GLideN64
  3. # Copyright 2016-2019 orbea
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=GLideN64
  23. BRANCH=${BRANCH:-master}
  24. BUILD=${BUILD:-1}
  25. TAG=${TAG:-_git}
  26. if [ -z "$ARCH" ]; then
  27. case "$( uname -m )" in
  28. i?86) ARCH=i586 ;;
  29. arm*) ARCH=arm ;;
  30. *) ARCH=$( uname -m ) ;;
  31. esac
  32. fi
  33. CWD=$(pwd)
  34. TMP=${TMP:-/tmp/SBo}
  35. PKG=$TMP/package-$PRGNAM
  36. OUTPUT=${OUTPUT:-/tmp}
  37. if [ "$ARCH" = "i586" ]; then
  38. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  39. LIBDIRSUFFIX=""
  40. elif [ "$ARCH" = "i686" ]; then
  41. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  42. LIBDIRSUFFIX=""
  43. elif [ "$ARCH" = "x86_64" ]; then
  44. SLKCFLAGS="-O2 -fPIC"
  45. LIBDIRSUFFIX="64"
  46. else
  47. SLKCFLAGS="-O2"
  48. LIBDIRSUFFIX=""
  49. fi
  50. set -eu
  51. rm -rf $PKG
  52. mkdir -p $TMP $PKG $OUTPUT
  53. cd $TMP
  54. rm -rf $PRGNAM
  55. git clone --depth=1 -b $BRANCH https://github.com/gonetz/$PRGNAM
  56. cd $PRGNAM
  57. [ "${COMMIT:=}" ] && git fetch --unshallow --tags && git checkout "$COMMIT"
  58. HEAD="$(git rev-parse --short HEAD)"
  59. DATE="$(git show -s --format=%cd --date=format:%Y.%m.%d)"
  60. VERSION="${DATE}_$HEAD"
  61. sh src/getRevision.sh
  62. chown -R root:root .
  63. find -L . \
  64. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  65. -o -perm 511 \) -exec chmod 755 {} \; -o \
  66. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  67. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  68. if [ "${DEBUG:=0}" != 0 ]; then
  69. RELEASE=Debug
  70. SLKCFLAGS="$(printf %s "$SLKCFLAGS" | sed 's/-O2/-O0/')"
  71. else
  72. RELEASE=Release
  73. fi
  74. [ "${EGL:=OFF}" != OFF ] && EGL=ON
  75. [ "${VEC4:=OFF}" != OFF ] && VEC4=ON
  76. [ "${NOHQ:=OFF}" != OFF ] && NOHQ=ON
  77. mkdir -p src/build
  78. cd src/build
  79. cmake -GNinja \
  80. -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
  81. -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
  82. -DVEC4_OPT=$VEC4 \
  83. -DNOHQ=$NOHQ \
  84. -DMUPENPLUSAPI=ON \
  85. -DUSE_SYSTEM_LIBS=ON \
  86. -DEGL=$EGL \
  87. -DCMAKE_BUILD_TYPE=$RELEASE ..
  88. "${NINJA:=ninja}"
  89. install -Dm0644 plugin/$RELEASE/mupen64plus-video-$PRGNAM.so \
  90. $PKG/usr/lib64/mupen64plus/mupen64plus-video-$PRGNAM.so
  91. cd ../..
  92. if [ "$DEBUG" = 0 ]; then
  93. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
  94. grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  95. fi
  96. for DOCDIR in GlideHQ Glow gles2n64; do
  97. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/$DOCDIR
  98. for file in gpl-2.0.txt LICENSE; do
  99. if [ -f licenses/$DOCDIR/$file ]; then
  100. cp -a licenses/$DOCDIR/$file $PKG/usr/doc/$PRGNAM-$VERSION/$DOCDIR
  101. fi
  102. done
  103. done
  104. cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
  105. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  106. mkdir -p $PKG/install
  107. cat $CWD/slack-desc > $PKG/install/slack-desc
  108. cd $PKG
  109. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-${VERSION}_$BRANCH-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}