The Neocities Gem - A CLI and library for using the Neocities web site API.

Kyle Drake 0d9411f3c3 0.0.15 1 year ago
bin 2b17f0b893 More major changes. Biggest is Net::HTTP so gem can work without compilation 4 years ago
ext 562b79b608 fix win32 cert issues 4 years ago
lib 0d9411f3c3 0.0.15 1 year ago
.gitignore 2b17f0b893 More major changes. Biggest is Net::HTTP so gem can work without compilation 4 years ago
Gemfile d779aa1a39 beginnings of ruby client API and CLI 4 years ago
README.md 714824650d Improve documentation 3 years ago
neocities.gemspec bb98bdb29d Merge pull request #15 from dotcomboom/patch-1 2 years ago

README.md

The Neocities Gem

A CLI and library for using the Neocities API. Makes it easy to quickly upload, push, delete, and list your Neocities site.

Installation

Mac OSX

If you're using OSX (or already have ruby installed):

gem install neocities

Ubuntu/Debian

sudo apt-get install ruby

Windows

Install ruby with RubyInstaller. Then you can install the gem with the above command.

Running

After that, you are all set! Run neocities in a command line to see the options and get started.

Neocities::Client

This gem also ships with Neocities::Client, which you can use to write code that interfaces with the Neocities API.