#11 Not reboot 20210522 lenovo x200

Closed
opened 4 months ago by nikolayp · 5 comments

My system has blackscreen afte reboot at 20210522 seabios_withgrub_x200_8mb_libgfxinit_corebootfb_usqwerty.rom and no any graphic in grub

My system has blackscreen afte reboot at 20210522 seabios_withgrub_x200_8mb_libgfxinit_corebootfb_usqwerty.rom and no any graphic in grub
Leah Rowe commented 4 months ago
Owner

hey ignore my earlier reply, i misread you.

To be clear, does the machine boot normally (when turning it on, while it's not turned on), and perfectly work, but then you get a black screen when you go for reboot?

If so, please report this here: #3

hey ignore my earlier reply, i misread you. To be clear, does the machine boot normally (when turning it on, while it's not turned on), and perfectly work, but then you get a black screen when you go for reboot? If so, please report this here: https://notabug.org/libreboot/lbmk/issues/3
nikolayp commented 4 months ago
Poster

Thank you. My problem is the same as #3. Sorry for the double.

Thank you. My problem is the same as #3. Sorry for the double.
Leah Rowe commented 4 months ago
Owner

Thanks. I have now cross referred this issue on that issue, and renamed that issue to reflect that it affects both machines.

Thanks. I have now cross referred this issue on that issue, and renamed that issue to reflect that it affects both machines.
Leah Rowe commented 4 months ago
Owner

Could you, on issue 11, try to show logs? Probably difficult on x200 unless you have an ehci debug dongle or something, and I'd need to compile a special rom for you with the exact same config otherwise as 20210522. Coreboot can show detailed logs during bootup, like how you have linux kernel logs.

Don't worry if you can't. I have lots of machines here, and it happens for at least you and 2 other people, on seemingly all gm45 machines.

I will investigate this myself. I have lots of these machines. I think it's likely just a code cleanup/refactor in coreboot (they do a lot of that in the last year or two), and something got b0rked. This has happened before recently (a different bug).

I know coreboot 4.13 works fine for reboot. This libreboot release is based on coreboot 4.14. So I can run a git bisect to see when this broke, after I reproduce the issue. Thank you for reporting this!

Could you, on issue 11, try to show logs? Probably difficult on x200 unless you have an ehci debug dongle or something, and I'd need to compile a special rom for you with the exact same config otherwise as 20210522. Coreboot can show detailed logs during bootup, like how you have linux kernel logs. Don't worry if you can't. I have lots of machines here, and it happens for at least you and 2 other people, on seemingly all gm45 machines. I will investigate this myself. I have lots of these machines. I think it's likely just a code cleanup/refactor in coreboot (they do a lot of that in the last year or two), and something got b0rked. This has happened before recently (a different bug). I know coreboot 4.13 works fine for reboot. This libreboot release is based on coreboot 4.14. So I can run a git bisect to see when this broke, after I reproduce the issue. Thank you for reporting this!
nikolayp commented 4 months ago
Poster

How i can view reboot log? After reboot i view black screen.

How i can view reboot log? After reboot i view black screen.
Sign in to join this conversation.
No Label
No Milestone
No assignee
2 Participants
Loading...
Cancel
Save
There is no content yet.