123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179 |
- #!/bin/sh
- # Slackware build script for d9vk
- # Copyright 2019 Hunter Sezen California, USA
- # All rights reserved.
- #
- # Redistribution and use of this script, with or without modification, is
- # permitted provided that the following conditions are met:
- #
- # 1. Redistributions of this script must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- #
- # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
- # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
- # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
- # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
- # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
- # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
- # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
- # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
- # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
- # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- PRGNAM=d9vk
- VERSION=${VERSION:-0.22}
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- CWD=$(pwd)
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- fi
- set -eu
- exists () {
- v=1
- while [ $# -gt 0 ]; do
- arg="$1"; shift
- case "$arg" in ''|*/) continue ;; esac
- x="${arg##*/}" z="${arg%/*}"
- [ ! -f "$z/$x" ] || [ ! -x "$z/$x" ] && [ "$z/$x" = "$arg" ] && continue
- [ "$x" = "$z" ] && [ -x "$z/$x" ] && [ ! -f "$arg" ] && z=
- p=":$z:$PATH"
- while [ "$p" != "${p#*:}" ]; do
- p="${p#*:}"; d="${p%%:*}"
- if [ -f "$d/$x" ] && [ -x "$d/$x" ]; then
- printf %s\\n "$d/$x"
- v=0
- break
- fi
- done
- done
- return $v
- }
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $PRGNAM-$VERSION
- tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
- cd $PRGNAM-$VERSION
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- if [ "${DEBUG:=0}" != 0 ]; then
- NDEBUG=false
- RELEASE=debug
- SLKCFLAGS="$(printf %s "$SLKCFLAGS" | sed 's/-O2/-O0/')"
- else
- NDEBUG=true
- RELEASE=plain
- fi
- if [ "$ARCH" = x86_64 ]; then
- if exists wine >/dev/null 2>&1 && exists wine64 >/dev/null 2>&1; then
- arch='32 64'
- elif exists wine >/dev/null 2>&1; then
- arch=32
- else
- arch=64
- fi
- else
- arch=32
- fi
- eval "set -- $arch"
- for bin do
- CFLAGS="$SLKCFLAGS" \
- CXXFLAGS="$SLKCFLAGS" \
- meson \
- --prefix=/usr \
- --libdir=share/$PRGNAM/x$bin \
- --cross-file=build-wine$bin.txt \
- -Denable_dxgi=false \
- -Denable_d3d10=false \
- -Denable_d3d11=false \
- -Dstrip=$NDEBUG \
- -Db_ndebug=$NDEBUG \
- -Dbuildtype=$RELEASE \
- build$bin
- "${NINJA:=ninja}" -C build$bin
- DESTDIR=$PKG "$NINJA" -C build$bin install
- done
- mkdir -p $PKG/usr/bin
- cat > $PKG/usr/bin/setup_$PRGNAM<<EOF
- #!/bin/sh
- set -eu
- install=
- while [ \$# -gt 0 ]; do
- option="\$1"
- shift
- case "\$option" in
- -- )
- break
- ;;
- install|uninstall )
- install="\$option"
- ;;
- * )
- printf '%s\\n' "Unrecognized option '\$option'." >&2
- exit 1
- ;;
- esac
- done
- /usr/share/$PRGNAM/setup_$PRGNAM.sh "\$install" --symlink --without-dxgi
- EOF
- # Don't warn about missing d3d10/d3d11 dlls
- sed '/$action d3d1/d' setup_dxvk.sh > $PKG/usr/share/$PRGNAM/setup_$PRGNAM.sh
- chmod 0755 $PKG/usr/share/$PRGNAM/setup_$PRGNAM.sh
- chmod 0755 $PKG/usr/bin/setup_$PRGNAM
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|