d9vk.SlackBuild 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179
  1. #!/bin/sh
  2. # Slackware build script for d9vk
  3. # Copyright 2019 Hunter Sezen California, USA
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=d9vk
  23. VERSION=${VERSION:-0.22}
  24. BUILD=${BUILD:-1}
  25. TAG=${TAG:-_SBo}
  26. if [ -z "$ARCH" ]; then
  27. case "$( uname -m )" in
  28. i?86) ARCH=i586 ;;
  29. arm*) ARCH=arm ;;
  30. *) ARCH=$( uname -m ) ;;
  31. esac
  32. fi
  33. CWD=$(pwd)
  34. TMP=${TMP:-/tmp/SBo}
  35. PKG=$TMP/package-$PRGNAM
  36. OUTPUT=${OUTPUT:-/tmp}
  37. if [ "$ARCH" = "i586" ]; then
  38. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  39. LIBDIRSUFFIX=""
  40. elif [ "$ARCH" = "i686" ]; then
  41. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  42. LIBDIRSUFFIX=""
  43. elif [ "$ARCH" = "x86_64" ]; then
  44. SLKCFLAGS="-O2 -fPIC"
  45. LIBDIRSUFFIX="64"
  46. else
  47. SLKCFLAGS="-O2"
  48. LIBDIRSUFFIX=""
  49. fi
  50. set -eu
  51. exists () {
  52. v=1
  53. while [ $# -gt 0 ]; do
  54. arg="$1"; shift
  55. case "$arg" in ''|*/) continue ;; esac
  56. x="${arg##*/}" z="${arg%/*}"
  57. [ ! -f "$z/$x" ] || [ ! -x "$z/$x" ] && [ "$z/$x" = "$arg" ] && continue
  58. [ "$x" = "$z" ] && [ -x "$z/$x" ] && [ ! -f "$arg" ] && z=
  59. p=":$z:$PATH"
  60. while [ "$p" != "${p#*:}" ]; do
  61. p="${p#*:}"; d="${p%%:*}"
  62. if [ -f "$d/$x" ] && [ -x "$d/$x" ]; then
  63. printf %s\\n "$d/$x"
  64. v=0
  65. break
  66. fi
  67. done
  68. done
  69. return $v
  70. }
  71. rm -rf $PKG
  72. mkdir -p $TMP $PKG $OUTPUT
  73. cd $TMP
  74. rm -rf $PRGNAM-$VERSION
  75. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  76. cd $PRGNAM-$VERSION
  77. chown -R root:root .
  78. find -L . \
  79. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  80. -o -perm 511 \) -exec chmod 755 {} \; -o \
  81. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  82. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  83. if [ "${DEBUG:=0}" != 0 ]; then
  84. NDEBUG=false
  85. RELEASE=debug
  86. SLKCFLAGS="$(printf %s "$SLKCFLAGS" | sed 's/-O2/-O0/')"
  87. else
  88. NDEBUG=true
  89. RELEASE=plain
  90. fi
  91. if [ "$ARCH" = x86_64 ]; then
  92. if exists wine >/dev/null 2>&1 && exists wine64 >/dev/null 2>&1; then
  93. arch='32 64'
  94. elif exists wine >/dev/null 2>&1; then
  95. arch=32
  96. else
  97. arch=64
  98. fi
  99. else
  100. arch=32
  101. fi
  102. eval "set -- $arch"
  103. for bin do
  104. CFLAGS="$SLKCFLAGS" \
  105. CXXFLAGS="$SLKCFLAGS" \
  106. meson \
  107. --prefix=/usr \
  108. --libdir=share/$PRGNAM/x$bin \
  109. --cross-file=build-wine$bin.txt \
  110. -Denable_dxgi=false \
  111. -Denable_d3d10=false \
  112. -Denable_d3d11=false \
  113. -Dstrip=$NDEBUG \
  114. -Db_ndebug=$NDEBUG \
  115. -Dbuildtype=$RELEASE \
  116. build$bin
  117. "${NINJA:=ninja}" -C build$bin
  118. DESTDIR=$PKG "$NINJA" -C build$bin install
  119. done
  120. mkdir -p $PKG/usr/bin
  121. cat > $PKG/usr/bin/setup_$PRGNAM<<EOF
  122. #!/bin/sh
  123. set -eu
  124. install=
  125. while [ \$# -gt 0 ]; do
  126. option="\$1"
  127. shift
  128. case "\$option" in
  129. -- )
  130. break
  131. ;;
  132. install|uninstall )
  133. install="\$option"
  134. ;;
  135. * )
  136. printf '%s\\n' "Unrecognized option '\$option'." >&2
  137. exit 1
  138. ;;
  139. esac
  140. done
  141. /usr/share/$PRGNAM/setup_$PRGNAM.sh "\$install" --symlink --without-dxgi
  142. EOF
  143. # Don't warn about missing d3d10/d3d11 dlls
  144. sed '/$action d3d1/d' setup_dxvk.sh > $PKG/usr/share/$PRGNAM/setup_$PRGNAM.sh
  145. chmod 0755 $PKG/usr/share/$PRGNAM/setup_$PRGNAM.sh
  146. chmod 0755 $PKG/usr/bin/setup_$PRGNAM
  147. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  148. cp LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
  149. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  150. mkdir -p $PKG/install
  151. cat $CWD/slack-desc > $PKG/install/slack-desc
  152. cd $PKG
  153. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}