unknown-option---.diff 1007 B

123456789101112131415161718192021222324252627282930313233
  1. On Tue, 2008-09-23 at 12:58 +0200, Paul Slootman wrote:
  2. > In debian bug #493559 (http://bugs.debian.org/493559) the problem is
  3. > that when requesting a file from an older version rsync, the remote
  4. > server gives an error:
  5. >
  6. > $ rsync rsync://rsync.blackholes.us/zones/countries/countries.rbl /tmp
  7. > rsync: on remote machine: -: unknown option
  8. > rsync error: requested action not supported (code 4) at clientserver.c(517)
  9. > rsync: connection unexpectedly closed (4 bytes received so far) [receiver]
  10. > rsync error: error in rsync protocol data stream (code 12) at io.c(632) [receiver=3.0.4]
  11. This appears to be a result of adding the -e server option and
  12. incompletely removing it for pre-protocol-30 servers. This patch should
  13. fix it:
  14. --- a/options.c
  15. +++ b/options.c
  16. @@ -2267,7 +2267,8 @@ void server_options(char **args, int *argc_p)
  17. argstr[x] = '\0';
  18. - args[ac++] = argstr;
  19. + if (x != 1)
  20. + args[ac++] = argstr;
  21. #ifdef ICONV_OPTION
  22. if (iconv_opt) {
  23. The patch is also in my repository.
  24. Matt