These are the main patches to the rsync source.
(The changes to the manpages for correct hyphens
and quotes is a bit big, so not included.)
If you're wondering about the lack of patches, the
explanation is that upstream has adopted most of them :-)
logdir.diff - fix the location of the logdir
ssh-6-option.diff - call ssh with -6 option if rsync was called with -6,
ditto with -4
rsyncd.conf.5.comment.diff - explain that a hash can only be at the beginning
of a line.
unknown-option---.diff - when transferring from an older rsync daemon without
options, a "-" is passed which isn't understood.
xattr-hlink.diff - fix possible segfaults when transferring files with -X
These are patches from the development branch that I consider important
enough to include now:
cast--1-size_t.diff
- Explicitly cast a -1 that is being assigned to a size_t.
hash-64bit-cast.diff
- Explicitly cast an int64 to an int32.
progress-cursor-pos.diff
- The --progress output now leaves the cursor at the end of the line
(instead of the start) in order to be extra sure that an error won't
overwrite it. We also ensure that the progress option can't be enabled
on the server side.
mod-path.diff
- log format '%P' didn't show the actual module path if the module was
chrooted.