fix-srfi-60-copy-bit-doc.diff 668 B

1234567891011121314151617181920212223
  1. Index: sid/srfi/srfi-60.c
  2. ===================================================================
  3. --- sid.orig/srfi/srfi-60.c
  4. +++ sid/srfi/srfi-60.c
  5. @@ -63,7 +63,7 @@
  6. SCM_DEFINE (scm_srfi60_copy_bit, "copy-bit", 3, 0, 0,
  7. - (SCM index, SCM n, SCM bit),
  8. + (SCM index, SCM n, SCM newbit),
  9. "Return @var{n} with the bit at @var{index} set according to\n"
  10. "@var{newbit}. @var{newbit} should be @code{#t} to set the bit\n"
  11. "to 1, or @code{#f} to set it to 0. Bits other than at\n"
  12. @@ -79,7 +79,7 @@
  13. int bb;
  14. ii = scm_to_ulong (index);
  15. - bb = scm_to_bool (bit);
  16. + bb = scm_to_bool (newbit);
  17. if (SCM_I_INUMP (n))
  18. {