stig-0.12.10_alpha0.ebuild 986 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 2023-2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DISTUTILS_USE_PEP517=setuptools
  5. PYTHON_COMPAT=( python3_{10..12} )
  6. inherit distutils-r1 pypi optfeature
  7. DESCRIPTION="TUI and CLI for the BitTorrent client Transmission"
  8. HOMEPAGE="
  9. https://pypi.org/project/stig
  10. https://github.com/rndusr/stig
  11. "
  12. LICENSE="GPL-3"
  13. SLOT="0"
  14. KEYWORDS="~amd64 ~x86"
  15. RDEPEND="
  16. >=dev-python/urwid-2.6.12[${PYTHON_USEDEP}]
  17. ~dev-python/urwidtrees-1.0.3[${PYTHON_USEDEP}]
  18. =dev-python/aiohttp-3*[${PYTHON_USEDEP}]
  19. dev-python/async-timeout[${PYTHON_USEDEP}]
  20. dev-python/pyxdg[${PYTHON_USEDEP}]
  21. dev-python/blinker[${PYTHON_USEDEP}]
  22. dev-python/natsort[${PYTHON_USEDEP}]
  23. "
  24. DEPEND="${RDEPEND}"
  25. pkg_postinst() {
  26. optfeature "Tunnel the connection to the Transmission daemon through a SOCKS5, SOCKS4 or HTTP proxy" \
  27. dev-python/aiohttp-socks
  28. optfeature "Strip arguments from process title when running in tmux session" dev-python/setproctitle
  29. }