telebot-9999.ebuild 464 B

123456789101112131415161718192021222324252627
  1. # Copyright 2020-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit cmake git-r3
  5. DESCRIPTION="Telegram Bot API in C"
  6. HOMEPAGE="
  7. https://elmurod.net/telebot
  8. https://github.com/smartnode/telebot
  9. "
  10. EGIT_REPO_URI="https://github.com/smartnode/${PN}.git"
  11. LICENSE="Apache-2.0"
  12. SLOT="0"
  13. KEYWORDS=""
  14. DEPEND="
  15. net-misc/curl
  16. dev-libs/json-c
  17. "
  18. RDEPEND="${DEPEND}"
  19. CMAKE_USE_DIR="${S}"
  20. BUILD_DIR="${CMAKE_USE_DIR}"