gifski-1.32.0.ebuild 2.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147
  1. # Copyright 2021-2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. CRATES="
  5. adler@1.0.2
  6. ahash@0.8.11
  7. aho-corasick@1.1.3
  8. anstream@0.6.13
  9. anstyle@1.0.6
  10. anstyle-parse@0.2.3
  11. anstyle-query@1.0.2
  12. anstyle-wincon@3.0.2
  13. arrayvec@0.7.4
  14. autocfg@1.2.0
  15. bindgen@0.64.0
  16. bitflags@1.3.2
  17. bytemuck@1.15.0
  18. cc@1.0.94
  19. cexpr@0.6.0
  20. cfg-if@1.0.0
  21. clang-sys@1.7.0
  22. clap@4.5.4
  23. clap_builder@4.5.2
  24. clap_lex@0.7.0
  25. colorchoice@1.0.0
  26. crc32fast@1.4.0
  27. crossbeam-channel@0.5.12
  28. crossbeam-deque@0.8.5
  29. crossbeam-epoch@0.9.18
  30. crossbeam-utils@0.8.19
  31. dunce@1.0.4
  32. either@1.11.0
  33. fallible_collections@0.4.9
  34. ffmpeg-next@6.1.1
  35. ffmpeg-sys-next@6.1.0
  36. flate2@1.0.28
  37. gif@0.13.1
  38. gif-dispose@5.0.0
  39. glob@0.3.1
  40. hashbrown@0.13.2
  41. hermit-abi@0.3.9
  42. imagequant@4.3.0
  43. imgref@1.10.1
  44. lazy_static@1.4.0
  45. lazycell@1.3.0
  46. libc@0.2.153
  47. libloading@0.8.3
  48. lodepng@3.10.1
  49. loop9@0.1.5
  50. memchr@2.7.2
  51. minimal-lexical@0.2.1
  52. miniz_oxide@0.7.2
  53. natord@1.0.9
  54. nom@7.1.3
  55. num-traits@0.2.18
  56. num_cpus@1.16.0
  57. once_cell@1.19.0
  58. ordered-channel@1.1.0
  59. pbr@1.1.1
  60. peeking_take_while@0.1.2
  61. pkg-config@0.3.30
  62. proc-macro2@1.0.79
  63. quick-error@2.0.1
  64. quote@1.0.36
  65. rayon@1.10.0
  66. rayon-core@1.12.1
  67. regex@1.10.4
  68. regex-automata@0.4.6
  69. regex-syntax@0.8.3
  70. resize@0.8.4
  71. rgb@0.8.37
  72. rustc-hash@1.1.0
  73. shlex@1.3.0
  74. strsim@0.11.1
  75. syn@1.0.109
  76. syn@2.0.58
  77. thread_local@1.1.8
  78. unicode-ident@1.0.12
  79. utf8parse@0.2.1
  80. vcpkg@0.2.15
  81. version_check@0.9.4
  82. weezl@0.1.8
  83. wild@2.2.1
  84. winapi@0.3.9
  85. winapi-i686-pc-windows-gnu@0.4.0
  86. winapi-x86_64-pc-windows-gnu@0.4.0
  87. windows-sys@0.52.0
  88. windows-targets@0.52.5
  89. windows_aarch64_gnullvm@0.52.5
  90. windows_aarch64_msvc@0.52.5
  91. windows_i686_gnu@0.52.5
  92. windows_i686_gnullvm@0.52.5
  93. windows_i686_msvc@0.52.5
  94. windows_x86_64_gnu@0.52.5
  95. windows_x86_64_gnullvm@0.52.5
  96. windows_x86_64_msvc@0.52.5
  97. y4m@0.8.0
  98. yuv@0.1.5
  99. zerocopy@0.7.32
  100. zerocopy-derive@0.7.32
  101. ${PN}@${PV}
  102. "
  103. inherit cargo
  104. DESCRIPTION="Highest-quality GIF encoder based on pngquant"
  105. HOMEPAGE="
  106. https://gif.ski/
  107. https://crates.io/crates/gifski
  108. "
  109. SRC_URI="${CARGO_CRATE_URIS}"
  110. LICENSE="AGPL-3+"
  111. # Dependent crate licenses
  112. LICENSE+=" Apache-2.0 BSD GPL-3+ ISC MIT Unicode-DFS-2016 WTFPL-2 ZLIB"
  113. SLOT="0"
  114. KEYWORDS="amd64 ~x86"
  115. IUSE="video"
  116. DEPEND="
  117. video? ( >=media-video/ffmpeg-4[dav1d(+)] )
  118. "
  119. RDEPEND="${DEPEND}"
  120. BDEPEND="video? ( sys-devel/clang:* )"
  121. QA_PRESTRIPPED="usr/bin/${PN}"
  122. # src_prepare() {
  123. # default
  124. # # patch for ffmpeg-sys-next is only needed for mac
  125. # # comment it out to not depend on git source
  126. # sed -i "${S}/Cargo.toml" \
  127. # -e 's/^ffmpeg-sys-next\s.*/# &/' || die
  128. # }
  129. src_configure() {
  130. local myfeatures=(
  131. binary
  132. gifsicle
  133. $(usev video)
  134. )
  135. cargo_src_configure --no-default-features
  136. }