gitui-0.26.3.ebuild 6.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351
  1. # Copyright 2022-2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. AG_PV="${PV}"
  5. CRATES="
  6. addr2line@0.21.0
  7. adler@1.0.2
  8. aead@0.5.2
  9. aes@0.8.4
  10. aes-gcm@0.10.3
  11. ahash@0.8.11
  12. aho-corasick@1.1.3
  13. allocator-api2@0.2.18
  14. android-tzdata@0.1.1
  15. android_system_properties@0.1.5
  16. anstream@0.6.14
  17. anstyle@1.0.7
  18. anstyle-parse@0.2.4
  19. anstyle-query@1.0.3
  20. anstyle-wincon@3.0.3
  21. anyhow@1.0.86
  22. autocfg@1.3.0
  23. backtrace@0.3.71
  24. base16ct@0.2.0
  25. base64@0.21.7
  26. base64ct@1.6.0
  27. bcrypt-pbkdf@0.10.0
  28. bincode@1.3.3
  29. bit-set@0.5.3
  30. bit-vec@0.6.3
  31. bitflags@1.3.2
  32. bitflags@2.5.0
  33. block-buffer@0.10.4
  34. block-padding@0.3.3
  35. blowfish@0.9.1
  36. bugreport@0.5.0
  37. bumpalo@3.16.0
  38. bwrap@1.3.0
  39. byteorder@1.5.0
  40. bytesize@1.3.0
  41. cassowary@0.3.0
  42. castaway@0.2.2
  43. cbc@0.1.2
  44. cc@1.0.98
  45. cfg-if@1.0.0
  46. chacha20@0.9.1
  47. chrono@0.4.38
  48. cipher@0.4.4
  49. clap@4.5.4
  50. clap_builder@4.5.2
  51. clap_lex@0.7.0
  52. colorchoice@1.0.1
  53. compact_str@0.7.1
  54. const-oid@0.9.6
  55. core-foundation-sys@0.8.6
  56. cpufeatures@0.2.12
  57. crc32fast@1.4.2
  58. crossbeam-channel@0.5.13
  59. crossbeam-deque@0.8.5
  60. crossbeam-epoch@0.9.18
  61. crossbeam-utils@0.8.20
  62. crossterm@0.27.0
  63. crossterm_winapi@0.9.1
  64. crypto-bigint@0.5.5
  65. crypto-common@0.1.6
  66. ctr@0.9.2
  67. curve25519-dalek@4.1.2
  68. curve25519-dalek-derive@0.1.1
  69. der@0.7.9
  70. deranged@0.3.11
  71. diff@0.1.13
  72. digest@0.10.7
  73. dirs@5.0.1
  74. dirs-sys@0.4.1
  75. easy-cast@0.5.2
  76. ecdsa@0.16.9
  77. ed25519@2.2.3
  78. ed25519-dalek@2.1.1
  79. either@1.12.0
  80. elliptic-curve@0.13.8
  81. env_filter@0.1.0
  82. env_logger@0.11.3
  83. equivalent@1.0.1
  84. errno@0.3.9
  85. fancy-regex@0.11.0
  86. fastrand@2.1.0
  87. ff@0.13.0
  88. fiat-crypto@0.2.9
  89. filetime@0.2.23
  90. filetreelist@0.5.1
  91. flate2@1.0.30
  92. fnv@1.0.7
  93. form_urlencoded@1.2.1
  94. fsevent-sys@4.1.0
  95. fuzzy-matcher@0.3.7
  96. generic-array@0.14.7
  97. getrandom@0.2.15
  98. gh-emoji@1.0.8
  99. ghash@0.5.1
  100. gimli@0.28.1
  101. git-version@0.3.9
  102. git-version-macro@0.3.9
  103. git2@0.18.3
  104. git2-hooks@0.3.1
  105. group@0.13.0
  106. hashbrown@0.14.5
  107. heck@0.4.1
  108. hmac@0.12.1
  109. home@0.5.9
  110. humantime@2.1.0
  111. iana-time-zone@0.1.60
  112. iana-time-zone-haiku@0.1.2
  113. idna@0.5.0
  114. indexmap@2.2.6
  115. inotify@0.9.6
  116. inotify-sys@0.1.5
  117. inout@0.1.3
  118. is_terminal_polyfill@1.70.0
  119. itertools@0.12.1
  120. itoa@1.0.11
  121. jobserver@0.1.31
  122. js-sys@0.3.69
  123. kqueue@1.0.8
  124. kqueue-sys@1.0.4
  125. lazy_static@1.4.0
  126. libc@0.2.155
  127. libgit2-sys@0.16.2+1.7.2
  128. libm@0.2.8
  129. libredox@0.1.3
  130. libssh2-sys@0.3.0
  131. libz-sys@1.1.16
  132. linux-raw-sys@0.4.14
  133. lock_api@0.4.12
  134. log@0.4.21
  135. lru@0.12.3
  136. memchr@2.7.2
  137. miniz_oxide@0.7.3
  138. mio@0.8.11
  139. notify@6.1.1
  140. notify-debouncer-mini@0.4.1
  141. num-bigint-dig@0.8.4
  142. num-conv@0.1.0
  143. num-integer@0.1.46
  144. num-iter@0.1.45
  145. num-traits@0.2.19
  146. object@0.32.2
  147. once_cell@1.19.0
  148. onig@6.4.0
  149. onig_sys@69.8.1
  150. opaque-debug@0.3.1
  151. openssl-probe@0.1.5
  152. openssl-src@300.2.3+3.2.1
  153. openssl-sys@0.9.102
  154. option-ext@0.2.0
  155. p256@0.13.2
  156. p384@0.13.0
  157. p521@0.13.3
  158. parking_lot@0.12.2
  159. parking_lot_core@0.9.9
  160. paste@1.0.15
  161. pbkdf2@0.12.2
  162. pem-rfc7468@0.7.0
  163. percent-encoding@2.3.1
  164. phf@0.11.2
  165. phf_shared@0.11.2
  166. pkcs1@0.7.5
  167. pkcs8@0.10.2
  168. pkg-config@0.3.30
  169. platforms@3.4.0
  170. poly1305@0.8.0
  171. polyval@0.6.2
  172. powerfmt@0.2.0
  173. ppv-lite86@0.2.17
  174. pretty_assertions@1.4.0
  175. primeorder@0.13.6
  176. proc-macro2@1.0.83
  177. quote@1.0.36
  178. rand@0.8.5
  179. rand_chacha@0.3.1
  180. rand_core@0.6.4
  181. ratatui@0.26.3
  182. rayon@1.10.0
  183. rayon-core@1.12.1
  184. redox_syscall@0.4.1
  185. redox_users@0.4.5
  186. regex@1.10.4
  187. regex-automata@0.4.6
  188. regex-syntax@0.8.3
  189. rfc6979@0.4.0
  190. ron@0.8.1
  191. rsa@0.9.6
  192. rustc-demangle@0.1.24
  193. rustc_version@0.4.0
  194. rustix@0.38.34
  195. rustversion@1.0.17
  196. ryu@1.0.18
  197. same-file@1.0.6
  198. scopeguard@1.2.0
  199. scopetime@0.1.2
  200. sec1@0.7.3
  201. semver@1.0.23
  202. serde@1.0.202
  203. serde_derive@1.0.202
  204. serde_json@1.0.117
  205. sha2@0.10.8
  206. shell-escape@0.1.5
  207. shellexpand@3.1.0
  208. signal-hook@0.3.17
  209. signal-hook-mio@0.2.3
  210. signal-hook-registry@1.4.2
  211. signature@2.2.0
  212. simplelog@0.12.2
  213. siphasher@0.3.11
  214. smallvec@1.13.2
  215. spin@0.5.2
  216. spki@0.7.3
  217. ssh-cipher@0.2.0
  218. ssh-encoding@0.2.0
  219. ssh-key@0.6.6
  220. stability@0.2.0
  221. static_assertions@1.1.0
  222. strsim@0.11.1
  223. struct-patch@0.4.1
  224. struct-patch-derive@0.4.1
  225. strum@0.26.2
  226. strum_macros@0.26.2
  227. subtle@2.5.0
  228. syn@2.0.65
  229. syntect@5.2.0
  230. sys-info@0.9.1
  231. tempfile@3.10.1
  232. thiserror@1.0.61
  233. thiserror-impl@1.0.61
  234. thread_local@1.1.8
  235. time@0.3.36
  236. time-core@0.1.2
  237. time-macros@0.2.18
  238. tinyvec@1.6.0
  239. tinyvec_macros@0.1.1
  240. tui-textarea@0.4.0
  241. two-face@0.4.0
  242. typenum@1.17.0
  243. unicode-bidi@0.3.15
  244. unicode-ident@1.0.12
  245. unicode-normalization@0.1.23
  246. unicode-segmentation@1.11.0
  247. unicode-truncate@1.0.0
  248. unicode-width@0.1.12
  249. universal-hash@0.5.1
  250. url@2.5.0
  251. utf8parse@0.2.1
  252. vcpkg@0.2.15
  253. version_check@0.9.4
  254. walkdir@2.5.0
  255. wasi@0.11.0+wasi-snapshot-preview1
  256. wasm-bindgen@0.2.92
  257. wasm-bindgen-backend@0.2.92
  258. wasm-bindgen-macro@0.2.92
  259. wasm-bindgen-macro-support@0.2.92
  260. wasm-bindgen-shared@0.2.92
  261. which@6.0.1
  262. winapi@0.3.9
  263. winapi-i686-pc-windows-gnu@0.4.0
  264. winapi-util@0.1.8
  265. winapi-x86_64-pc-windows-gnu@0.4.0
  266. windows-core@0.52.0
  267. windows-sys@0.48.0
  268. windows-sys@0.52.0
  269. windows-targets@0.48.5
  270. windows-targets@0.52.5
  271. windows_aarch64_gnullvm@0.48.5
  272. windows_aarch64_gnullvm@0.52.5
  273. windows_aarch64_msvc@0.48.5
  274. windows_aarch64_msvc@0.52.5
  275. windows_i686_gnu@0.48.5
  276. windows_i686_gnu@0.52.5
  277. windows_i686_gnullvm@0.52.5
  278. windows_i686_msvc@0.48.5
  279. windows_i686_msvc@0.52.5
  280. windows_x86_64_gnu@0.48.5
  281. windows_x86_64_gnu@0.52.5
  282. windows_x86_64_gnullvm@0.48.5
  283. windows_x86_64_gnullvm@0.52.5
  284. windows_x86_64_msvc@0.48.5
  285. windows_x86_64_msvc@0.52.5
  286. winsafe@0.0.19
  287. yansi@0.5.1
  288. zerocopy@0.7.34
  289. zerocopy-derive@0.7.34
  290. zeroize@1.7.0
  291. asyncgit@${AG_PV}
  292. ${PN}@${PV}
  293. "
  294. inherit cargo
  295. DESCRIPTION="Blazing fast terminal-ui for git"
  296. HOMEPAGE="
  297. https://crates.io/crates/gitui
  298. https://github.com/extrawurst/gitui
  299. "
  300. SRC_URI="${CARGO_CRATE_URIS}"
  301. LICENSE="MIT"
  302. # Dependent crate licenses
  303. LICENSE+="
  304. Apache-2.0 BSD-2 BSD CC0-1.0 ISC MIT MPL-2.0 Unicode-DFS-2016
  305. "
  306. SLOT="0"
  307. KEYWORDS="amd64 ~arm64 x86"
  308. IUSE="ghemoji trace-libgit"
  309. RDEPEND="
  310. >=dev-libs/libgit2-1.2.0:=
  311. trace-libgit? ( dev-libs/libgit2[trace(+)] )
  312. dev-libs/openssl
  313. "
  314. DEPEND="${RDEPEND}"
  315. RESTRICT="mirror"
  316. src_configure() {
  317. local myfeatures=(
  318. $(usev ghemoji)
  319. $(usev trace-libgit)
  320. regex-fancy
  321. )
  322. cargo_src_configure --no-default-features
  323. }
  324. src_install() {
  325. local DOCS=({README,KEY_CONFIG,THEMES}.md)
  326. cargo_src_install
  327. insinto "/usr/share/${P}/examples"
  328. doins vim_style_key_config.ron
  329. einstalldocs
  330. }
  331. pkg_postinst() {
  332. einfo "Example of vim keybindings config stored in '/usr/share/${P}/examples'"
  333. einfo 'to use it put example config in `$XDG_CONFIG_HOME/gitui/key_bindings.ron`'
  334. }