tokei-13.0.0_alpha5.ebuild 4.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247
  1. # Copyright 2017-2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. CRATES="
  5. aho-corasick@1.1.3
  6. android-tzdata@0.1.1
  7. android_system_properties@0.1.5
  8. anstream@0.6.15
  9. anstyle@1.0.8
  10. anstyle-parse@0.2.5
  11. anstyle-query@1.1.1
  12. anstyle-wincon@3.0.4
  13. arbitrary@1.3.2
  14. arrayvec@0.7.6
  15. autocfg@1.3.0
  16. bit-set@0.5.3
  17. bit-vec@0.6.3
  18. bitflags@2.6.0
  19. block-buffer@0.10.4
  20. bstr@1.10.0
  21. bumpalo@3.16.0
  22. byteorder@1.5.0
  23. cc@1.1.13
  24. cfg-if@1.0.0
  25. chrono@0.4.38
  26. chrono-tz@0.9.0
  27. chrono-tz-build@0.3.0
  28. clap@4.5.16
  29. clap_builder@4.5.15
  30. clap_lex@0.7.2
  31. colorchoice@1.0.2
  32. colored@2.1.0
  33. core-foundation-sys@0.8.7
  34. cpufeatures@0.2.13
  35. crossbeam-channel@0.5.13
  36. crossbeam-deque@0.8.5
  37. crossbeam-epoch@0.9.18
  38. crossbeam-utils@0.8.20
  39. crypto-common@0.1.6
  40. dashmap@6.0.1
  41. derive_arbitrary@1.3.2
  42. deunicode@1.6.0
  43. digest@0.10.7
  44. either@1.13.0
  45. encoding_rs@0.8.34
  46. encoding_rs_io@0.1.7
  47. env_filter@0.1.2
  48. env_logger@0.11.5
  49. equivalent@1.0.1
  50. errno@0.3.9
  51. etcetera@0.8.0
  52. fastrand@2.1.0
  53. fnv@1.0.7
  54. form_urlencoded@1.2.1
  55. generic-array@0.14.7
  56. getrandom@0.2.15
  57. git2@0.19.0
  58. globset@0.4.14
  59. globwalk@0.9.1
  60. grep-matcher@0.1.7
  61. grep-searcher@0.1.13
  62. half@1.8.3
  63. hashbrown@0.14.5
  64. heck@0.5.0
  65. hex@0.4.3
  66. home@0.5.9
  67. humansize@2.1.3
  68. humantime@2.1.0
  69. iana-time-zone@0.1.60
  70. iana-time-zone-haiku@0.1.2
  71. idna@0.5.0
  72. ignore@0.4.22
  73. indexmap@2.4.0
  74. is_terminal_polyfill@1.70.1
  75. itertools@0.11.0
  76. itoa@1.0.11
  77. jobserver@0.1.32
  78. js-sys@0.3.70
  79. json5@0.4.1
  80. lazy_static@1.5.0
  81. libc@0.2.156
  82. libgit2-sys@0.17.0+1.8.1
  83. libm@0.2.8
  84. libz-sys@1.1.19
  85. linux-raw-sys@0.4.14
  86. lock_api@0.4.12
  87. log@0.4.22
  88. memchr@2.7.4
  89. memmap2@0.9.4
  90. num-format@0.4.4
  91. num-traits@0.2.19
  92. once_cell@1.19.0
  93. parking_lot@0.12.3
  94. parking_lot_core@0.9.10
  95. parse-zoneinfo@0.3.1
  96. percent-encoding@2.3.1
  97. pest@2.7.11
  98. pest_derive@2.7.11
  99. pest_generator@2.7.11
  100. pest_meta@2.7.11
  101. phf@0.11.2
  102. phf_codegen@0.11.2
  103. phf_generator@0.11.2
  104. phf_shared@0.11.2
  105. pkg-config@0.3.30
  106. ppv-lite86@0.2.20
  107. proc-macro2@1.0.86
  108. proptest@1.5.0
  109. quick-error@1.2.3
  110. quote@1.0.36
  111. rand@0.8.5
  112. rand_chacha@0.3.1
  113. rand_core@0.6.4
  114. rand_xorshift@0.3.0
  115. rayon@1.10.0
  116. rayon-core@1.12.1
  117. redox_syscall@0.5.3
  118. regex@1.10.6
  119. regex-automata@0.4.7
  120. regex-syntax@0.8.4
  121. rustix@0.38.34
  122. rustversion@1.0.17
  123. rusty-fork@0.3.0
  124. ryu@1.0.18
  125. same-file@1.0.6
  126. scopeguard@1.2.0
  127. serde@1.0.208
  128. serde_cbor@0.11.2
  129. serde_derive@1.0.208
  130. serde_json@1.0.125
  131. serde_spanned@0.6.7
  132. serde_yaml@0.9.34+deprecated
  133. sha2@0.10.8
  134. shlex@1.3.0
  135. siphasher@0.3.11
  136. slug@0.1.6
  137. smallvec@1.13.2
  138. strsim@0.11.1
  139. strum@0.26.3
  140. strum_macros@0.26.4
  141. syn@2.0.74
  142. table_formatter@0.6.1
  143. tempfile@3.12.0
  144. tera@1.20.0
  145. term_size@0.3.2
  146. terminal_size@0.3.0
  147. thiserror@1.0.63
  148. thiserror-impl@1.0.63
  149. tinyvec@1.8.0
  150. tinyvec_macros@0.1.1
  151. toml@0.8.19
  152. toml_datetime@0.6.8
  153. toml_edit@0.22.20
  154. typenum@1.17.0
  155. ucd-trie@0.1.6
  156. unarray@0.1.4
  157. unic-char-property@0.9.0
  158. unic-char-range@0.9.0
  159. unic-common@0.9.0
  160. unic-segment@0.9.0
  161. unic-ucd-segment@0.9.0
  162. unic-ucd-version@0.9.0
  163. unicode-bidi@0.3.15
  164. unicode-ident@1.0.12
  165. unicode-normalization@0.1.23
  166. unsafe-libyaml@0.2.11
  167. url@2.5.2
  168. utf8parse@0.2.2
  169. vcpkg@0.2.15
  170. version_check@0.9.5
  171. wait-timeout@0.2.0
  172. walkdir@2.5.0
  173. wasi@0.11.0+wasi-snapshot-preview1
  174. wasm-bindgen@0.2.93
  175. wasm-bindgen-backend@0.2.93
  176. wasm-bindgen-macro@0.2.93
  177. wasm-bindgen-macro-support@0.2.93
  178. wasm-bindgen-shared@0.2.93
  179. winapi@0.3.9
  180. winapi-i686-pc-windows-gnu@0.4.0
  181. winapi-util@0.1.9
  182. winapi-x86_64-pc-windows-gnu@0.4.0
  183. windows-core@0.52.0
  184. windows-sys@0.48.0
  185. windows-sys@0.52.0
  186. windows-sys@0.59.0
  187. windows-targets@0.48.5
  188. windows-targets@0.52.6
  189. windows_aarch64_gnullvm@0.48.5
  190. windows_aarch64_gnullvm@0.52.6
  191. windows_aarch64_msvc@0.48.5
  192. windows_aarch64_msvc@0.52.6
  193. windows_i686_gnu@0.48.5
  194. windows_i686_gnu@0.52.6
  195. windows_i686_gnullvm@0.52.6
  196. windows_i686_msvc@0.48.5
  197. windows_i686_msvc@0.52.6
  198. windows_x86_64_gnu@0.48.5
  199. windows_x86_64_gnu@0.52.6
  200. windows_x86_64_gnullvm@0.48.5
  201. windows_x86_64_gnullvm@0.52.6
  202. windows_x86_64_msvc@0.48.5
  203. windows_x86_64_msvc@0.52.6
  204. winnow@0.6.18
  205. zerocopy@0.7.35
  206. zerocopy-derive@0.7.35
  207. "
  208. inherit cargo
  209. MY_PV="${PV/_alpha/-alpha.}"
  210. DESCRIPTION="Count your code, quickly"
  211. HOMEPAGE="https://github.com/XAMPPRocky/tokei"
  212. SRC_URI="
  213. https://github.com/XAMPPRocky/tokei/archive/v${MY_PV}.tar.gz -> ${PN}-${MY_PV}.tar.gz
  214. ${CARGO_CRATE_URIS}
  215. "
  216. S="${WORKDIR}/${PN}-${MY_PV}"
  217. LICENSE="BSD BSD-2 CC0-1.0 MIT ZLIB || ( Apache-2.0 Boost-1.0 )"
  218. SLOT="0"
  219. KEYWORDS="~amd64 ~x86"
  220. IUSE="test"
  221. RESTRICT="!test? ( test )"
  222. BDEPEND="
  223. test? (
  224. virtual/pkgconfig
  225. >=dev-libs/libgit2-1.1.0
  226. )
  227. "
  228. QA_FLAGS_IGNORED="usr/bin/tokei"
  229. src_configure() {
  230. cargo_src_configure --features all
  231. }
  232. src_install() {
  233. cargo_src_install
  234. dodoc CHANGELOG.md README.md tokei.example.toml
  235. }