alt-getopt-0.8.0.ebuild 763 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 2021-2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. LUA_COMPAT=( lua5-{1..4} luajit )
  5. inherit lua
  6. MY_PN="lua-${PN}"
  7. MY_P="${MY_PN}-${PV}"
  8. DESCRIPTION="Lua bindings to getopt_long"
  9. HOMEPAGE="https://github.com/cheusov/lua-alt-getopt"
  10. SRC_URI="https://github.com/cheusov/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
  11. S="${WORKDIR}/${MY_P}"
  12. LICENSE="MIT"
  13. SLOT="0"
  14. KEYWORDS="amd64 arm ppc x86 ~amd64-linux ~x86-linux"
  15. REQUIRED_USE="${LUA_REQUIRED_USE}"
  16. RDEPEND="${LUA_DEPS}"
  17. DEPEND="${RDEPEND}"
  18. DOCS=( README )
  19. LUA_S="${MY_P}"
  20. src_compile() { :; }
  21. lua_src_install() {
  22. insinto "$(lua_get_lmod_dir)"
  23. doins "${PN/-/_}.lua"
  24. }
  25. src_install() {
  26. einstalldocs
  27. lua_foreach_impl lua_src_install
  28. }