metalang99-1.13.3.ebuild 595 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DESCRIPTION="Full-blown preprocessor metaprogramming"
  5. HOMEPAGE="
  6. https://metalang99.readthedocs.io/en/latest/
  7. https://github.com/Hirrolot/metalang99
  8. "
  9. SRC_URI="
  10. https://github.com/Hirrolot/${PN}/archive/v${PV}.tar.gz
  11. -> ${P}.tar.gz
  12. "
  13. LICENSE="MIT"
  14. SLOT="0"
  15. KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x64-macos"
  16. src_compile() {
  17. :
  18. }
  19. src_install() {
  20. doheader -r include/*
  21. einstalldocs
  22. insinto "/usr/share/doc/${P}/examples"
  23. doins examples/*.c
  24. }