vim-9999.ebuild 417 B

12345678910111213141516171819202122232425
  1. # Copyright 2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. DESCRIPTION="Symlinks to use neovim as vim"
  5. HOMEPAGE="https://neovim.io/"
  6. LICENSE="Apache-2.0"
  7. SLOT="0"
  8. RDEPEND="app-editors/neovim"
  9. src_unpack() {
  10. mkdir -p "${S}"
  11. }
  12. src_install() {
  13. dosym nvim /usr/bin/vim
  14. dosym ../nvim/runtime /usr/share/vim/vimfiles
  15. exeinto /usr/bin
  16. doexe "${FILESDIR}/vimdiff"
  17. }